Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Problem with Realtek and 5.1 sound.

17 Feb 2009   #1

Windows 7, Build 7000
Problem with Realtek and 5.1 sound.

Hello everyone.
I hope someone here can help me, I've googled around for the last few days but I can't seem to get this working. My problem is that my 5.1 sound won't work.

I have a realtek card with the latest drivers installed (R215). My problem is that the computer won't recognize my back speakers and subwoofer/center speaker.

The problem here is that only the green jack on the back panel works. The blue one on the picture above is Line in and the pink one is mic in.

When I right click to change to "rear speaker out" or "center/subwoofer speaker out" I get this message ad it automatically reverts to Line in or mic in:

So what happens is that the green jack works, I can use my both front speakers. The sound is great on both of those. It is kind of annoying that I can't get the other speakers to work though. It all worked perfectly in XP/Vista/Ubuntu/Fedora.

I've tried to follow the tips in the stickied thread, but I don't have the DevType_0888_SS147b1083 or DevType_0885_SS18490890 folders.
Here's a print screen of my "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E96C-E325-11CE-BFC1-08002BE10318}\0000\Settings"

The folder on the picture doesn't contain any Pin00 to Pin 04 posts. Only a lot of long posts starting with Mute0_, Mute1_, Vol0_, Vol1_.

So, does anyone know how I can get my other speakers to work, and stop getting the "devide type not supported" message whenever I try to change the jack settings. Any help will be appreciated.

My System SpecsSystem Spec

17 Feb 2009   #2

Windows 7 Build 7048 x64

Hi waeras and welcome to the forum!

Please try uninstalling the sound drivers in device manager then restart.
Upon restart, your system should reinstall the driver again.
Check Realtek HD Device Manager again if it recognizes your hardware now
If it's still not accepting your settings, try using a lower build like R2.14 to install on your system.

Am using Realtek on my system as well and is working fine. I've encountered this issue on my system in Vista and an uninstall of the drivers did the trick.
My System SpecsSystem Spec
16 Nov 2009   #3

Windows7 Ultimate 32-bit

i fix problem with 5.1 sound that i set in realtek hd audio manager all speakers(front, rear and centar/subwoofer) on front speaker option on realtek hd audio manager and it work like on xp (tested in winamp and gomplayer)
My System SpecsSystem Spec


 Problem with Realtek and 5.1 sound.

Thread Tools

Similar help and support threads
Thread Forum
No headphone sound, Realtek driver problem.
Hi all, this is my first post so I feel a bit of a fraud getting help from here, but it's driving me insane. For a while now I've had the problem of no sound from my headphones. This is the situation and what I've tried: - Sound comes from the headphones when using the standard Windows 7...
Sound & Audio
Audio Service Not Running/No sound/No speakers/Realtek problem
I'm hoping someone can help me.I'm working on a custom pc that my brother built for me. The specs are in my signature. I recently upgraded from 32 bit to 64 bit Windows 7 home premium (I know it's not the best, but it's what I could afford). I did a drive reformat also. Initially, everything...
Sound & Audio
Realtek HD problem with sound
Hi all I hope someone can help me on this, as it is a problem I've had for quite some time now. I did a search and couldn't find a similar post, so if there is one, please direct me accordingly. I own a Samsung R720 Notebook. It comes standard with Windows7 Home Premium 32bit and all the...
Sound & Audio
Problem with Realtek sound.
Hi. I recently installed Windows 7 on my computer and when everything was set up and good to go, I started up iTunes. When no sound came out, I noticed that the default sound system had changed to the Digital Output thing. I unplugged and plugged the speakers back in, and the pop up message...
Sound & Audio
Sound Problem Please Help Realtek related
After installing Win 7 i have not been able to have sound on this computer period. I have installed several drivers from downloading from the realtek website or through windows updates with no success. First off this is what i am working with: ECS PT880PRO-A Onboard Audio - Realtek ALC655...
Sound & Audio
Sound problem with Realtek
Hello everyone, I have just installed windows 7 and I have problems with getting sound. I have "asuss p5ld2 se" board and ACL662 ( not sure about it ) sound in it. I have tryed installing newest driver from realtek no success, tryed older drivers 2.14 does not install. In device manager I find...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:04.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App