Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-fi Elite Pro - remote does not work


24 Nov 2009   #1

Windows 7 Home Premium (32 bit)
 
 
X-fi Elite Pro - remote does not work

Hi - I have the creative x-fi elite pro, and have just upgraded to Windows 7 from Windows XP pro. I have downloaded the most recent driver - 2.18.0013 from here:

Creative Worldwide Support > X-Fi Elite Pro

and it works GREAT in terms of sound.

My only problem is the remote control no longer works. When I press a key on the remote, I see the red light respond in the break-out box, but nothing else happens.

Can anyone help get this working? Thanks!



My System SpecsSystem Spec
.

24 Nov 2009   #2

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by davun4 View Post
Hi - I have the creative x-fi elite pro, and have just upgraded to Windows 7 from Windows XP pro. I have downloaded the most recent driver - 2.18.0013 from here:

Creative Worldwide Support > X-Fi Elite Pro

and it works GREAT in terms of sound.

My only problem is the remote control no longer works. When I press a key on the remote, I see the red light respond in the break-out box, but nothing else happens.

Can anyone help get this working? Thanks!
Hi and welcome

Can we verify the driver is correctly installed by typing device manager in search. go to the sound tab. Is your card listed? does it have a yellow triangle on it? Is there any other "unknown" devices with yellow on them?

Thanks


Ken J_++
My System SpecsSystem Spec
24 Nov 2009   #3

Windows 7 Home Premium (32 bit)
 
 

Hi Ken - yes, it's there - 'Creative SB X-Fi' - and under Properties->Driver, it says:
Driver Date: 6/3/2009
Driver Version 6.0.1.1373

everything looks good from Device Manager's point of view

-David
My System SpecsSystem Spec
.


24 Nov 2009   #4

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by davun4 View Post
Hi Ken - yes, it's there - 'Creative SB X-Fi' - and under Properties->Driver, it says:
Driver Date: 6/3/2009
Driver Version 6.0.1.1373

everything looks good from Device Manager's point of view

-David
Hi dave 32 bit or 64?
let me do some searching.
brb

KJ
My System SpecsSystem Spec
24 Nov 2009   #5

Windows 7 Home Premium (32 bit)
 
 

KJ - 32 bit. thanks
My System SpecsSystem Spec
24 Nov 2009   #6

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by davun4 View Post
Hi Ken - yes, it's there - 'Creative SB X-Fi' - and under Properties->Driver, it says:
Driver Date: 6/3/2009
Driver Version 6.0.1.1373

everything looks good from Device Manager's point of view

-David
DAve

look here Creative Worldwide Support it states Several Creative products may only require native drivers to function on Windows 7 while others will require drivers from Creative.

I dont know if that is what you already have but its a place to start

Ken J++
My System SpecsSystem Spec
24 Nov 2009   #7

Windows 7 Home Premium (32 bit)
 
 

Ken - I saw that link the other day - I am pretty sure the card I have needs creative drivers - it's got multiple modes, eq handlers, 3dfx, etc. The crazy thing is the sound on it is great. It's just for some reason, the box-receiver no longer responds to the remote signals. Here's a small image, courtesy of compusa:


any other ideas? I saw another poster here has the same issue with the related SB X-Fi Fatal1ty card (which also has a remote)

-David
My System SpecsSystem Spec
24 Nov 2009   #8

Windows 7 Home Premium (32 bit)
 
 

Note - I just tried installing the unnoficial Support Pack 2.0, described here:

SB X-Fi Series Support Pack 2.0 (05/15/2009) - Creative Labs

however, no luck. remote still not working. continuing to hunt the interwebs.
My System SpecsSystem Spec
15 Mar 2010   #9

 
 
My remote solution

Listen guys,for all of you that got problems with RC on Windows 7!
After reading a lot of posts, I eventually read Creative FAQ on this issue
Creative Worldwide Support
I have a X-Fi Platinum Fatal1ty Champion card and after upgrading from XP to 7 and Web driver update it didnt install Creative entertainment center so it does not support remote.
So all you have to do is fetch your Vista driver disk,and from there install the CE center,and remote works like it did in XP.
I dont know why they dont cover that in Web update,but Ill ask them.
My System SpecsSystem Spec
Reply

 X-fi Elite Pro - remote does not work




Thread Tools



Similar help and support threads for2: X-fi Elite Pro - remote does not work
Thread Forum
Remote Control Doesn't Work in Win-7 Hardware & Devices
remote shut down won't work please help! Network & Sharing
Phobya RGB LED controller remote will not work Hardware & Devices
I can't get Remote desktop connection to work Network & Sharing
HP Remote does not work with Win7 Media Center
X-Fi Elite Pro remote not working Hardware & Devices
my remote won't work Media Center

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:27 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33