Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BIG problem installing RealTek 2.37 & Windows 7 64-bit

25 Nov 2009   #1

Win 7 Ultimate
BIG problem installing RealTek 2.37 & Windows 7 64-bit

I am running (clean-installed) Windows 7 Ultimate x64 bit with EVGA 780i motherboard, which uses the RealTek audio drivers.

When I "clean-installed" Windows 7, I put in RealTek driver 2.35. When I saw revision 2.37 come out a few days ago, I downloaded. Yesterday, I spent lots of hours trying to recover from a mess. So please be forwarned.

I un-installed RealTek driver 2.35 via Control Panel
Upon reboot, Windows 7 found the generic driver (as always)
When I started to install 2.37, it got stuck at the "initializing" prompt after un-archiving.
After waiting more than 10 minutes, I aborted the install (Task Manager)
Upon reboot, I tried to uninstall 2.37 via control panel, but got an error.
Had to use Driver Sweeper to "uninstall" whatever parts that were partially installed
Tried re-installing 2.37, and same thing happened.
Clean-up and tried to go back to 2.35, but it would not install either!

Thank goodness for the System Restore function of Windows 7. I am back to version 2.35. Now, I am afraid to touch it!

Never had any such a problem on Vista from version 1.90 owards, and 2.15 in 64-bit version.

Anyone else have this experience with the 2.37 driver? Remember, I am running x64.

My System SpecsSystem Spec
27 Nov 2009   #2

Win 7 Ultimate

So no one has had or heard of this problem?
My System SpecsSystem Spec
27 Nov 2009   #3

Windows 8.1 Pro RTM x64

Try the installation method here Device Manager - Install Driver - Vista Forums This is the method that I use, and I have had no problem whatsoever - I am currently using the 2.37 driver.
My System SpecsSystem Spec

28 Nov 2009   #4

Windows 7 64Bit

I installed 2.37 on x64 Home several times yesterday trying to find a driver that functioned properly. I never had this install issue. I do have a MoBo and most likely and different audio chipset.
My System SpecsSystem Spec
27 Dec 2009   #5

Win 7 Ultimate
SOLVED - by installing v2.39 of the driver

I finally got "brave" and tried instal;ling the 2.39 of this driver, which came out last week. And it worked without any problems.

I guess there was something incompatible between my system and 2.37.

Glad to have this past me.
My System SpecsSystem Spec

 BIG problem installing RealTek 2.37 & Windows 7 64-bit

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Realtek + Windows 7 problem
Hi, I need some help cos I'm completely stumped with a problem that's developed on my laptop. (3 year-old Dell inspiron running Windows 7). I was trying to capture video from my minidv cam using Windows Movie Maker but the WMM wouldnt do it. I then re-installed Windows Live Essentials (which...
Sound Skippies on Windows 7 after installing Realtek HD audio
Guys, I have problem with Realtek HD audio when sound plays. The sound skippies on some areas. Please reply.
Sound & Audio
Realtek Hd Device problem on my Windows 7.
Hi, I have downloaded Realtek Hd Device on my Windows 7. And while installing the massage appears 'NO DRIVER WAS SUPPORTED IN THIS DRIVER PACKAGE' .. I have hp Pavilion 5000. Plz help guys..............
Sound & Audio
Realtek HD problem with Windows 7
Hi everyone! Well, im a bit sad with my situation. I just got from my university (MSDN) a copy of Win 7 Pro and I installed it in my notebook. But now i got a problem with my sound device. When i used the sound driver that came with the fresh install of the windows i got some noises with...
Sound & Audio
Problem with Realtek HD under Windows 7
Hi, I recently bought a new HP Elite 7000. I hear noise when I listen to music using Winamp or while I compose some music using Fruity Loops 9, but the sound is so pure when I use Windows Media Player. The sound card's driver is already installed. (Realtek HD codec ALC888S, audio 3D compatible...
Sound & Audio
Realtek 8100c problem in windows 7
I recently uploaded windows 7 ultimate on my pc but now it says no sound device detected and i do not have the cd for the soundcard anymore what can i do need help please:cry:
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:58.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App