Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound blaster driver problem fixed!!


20 Dec 2009   #1

Windows 7
 
 
Sound blaster driver problem fixed!!

I don't know why this works. I have a Sound Blaster Audigy Se sound card that wasn't working after installing Windows 7. I've been trying for days to fix this problem and finally and mysteriously I got my soundcard to work. I downloaded every driver from the Creative website to daniel_k's drivers and still nothing. Anyways, what I did was reinstall Windows 7 which takes no time at all. DO NOT INSTALL ANY UPDATES!!! Again, I don't know why, but I only chose to install the Sound Blaster Audigy update and it worked! The first time I installed windows 7 I installed updates and then tried to install the sound blaster updates and it didnt work. I highly recommend this to everyone!


My System SpecsSystem Spec
.

Reply

 Sound blaster driver problem fixed!!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:49 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33