Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Creative SB X-FI Elite Pro Not working

28 Feb 2010   #21


Hello All,
Iam having a problem with my new AMD based system powered with Creative Elit pro. Sound card.
When I open my DAW like (Cubase or Sonar) for recording.
A messege pos out, that your sound source is busy please make it free first.
Although every one knows that creative X-fi is a Full duplex Sound card.
I had no problem with my ols system with this card. on Windows XP.
But it is so disopinting to have these problems with latest OS.
even I have already Downloaded and Installed my Sound card Drivers properly.
Any suggestion welcome.

My System SpecsSystem Spec
28 Feb 2010   #22


i had similar issues when i installed my X-Fi card (SB0770), the control panel wouldn't work at all, even-though it was fully updated....

but i found by hunting down the ''Creative control panel standalone installer'' i was able to get it running...

glad to see you got it sorted though..
My System SpecsSystem Spec
15 Mar 2010   #23

Hardware not supported/detected!

I too had this same old problem in XP/Vista and now in 7.
It happened on Audigy 2 Platinum eX,Audigy SE,X-Fi Platinum Fatal1ty Champion and on Auzentech Forte with Creative I/O console.
It is noobish,but if you have any sound card installed in PCI or PCI-e,you have to uninstall and disable onboard sound!
Trick that works for me everytime! is too shutdown PC,take out the card and then enter windows with the card taken out.
Again poweroff PC,unplug the power cord! ( you can also clear cmos,but it is hassle for me because of OC so I dont do that)
Then install the card,and it should be recognized without any problems.
If you uninstalled drivers,then just install them again,and if you didnt its just going to work like nothing happened.
Whose to blame for this i dont know,because "product identification module" is not working too!
We just have to deal with it for now i guess.
My System SpecsSystem Spec


 Creative SB X-FI Elite Pro Not working

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Creative SB cards not working on new pc setup
Hello, i have 3 creative audio cards SB X-Fi Xtreme Gamer/Audio and SB Audigy 2 zs. Resently i have changed motherboard Asus M5A78LUSB3 with fx 6xxx CPU to Asus P8P67 LE with i7 4xxx CPU, all other components remained (they are 2 DIMM G Skill RipjawsX F3-10666CL7-4GBXH, AMD Radeon HD 5800 Series)....
Sound & Audio
Creative SBS 2.1 370 not working
My Creative SBS 2.1 370 not working I have attached an Image. It shows speaker is not plugged in.Help me Guys. My OS:Windows 7
Sound & Audio
[Fatal1ty Creative Headphones] Mic isn't working.
Hello! My problem is that my mic on these headphones will not pick up any of the things i'd like to say anymore. I've had these Fatal1ty Creative Headphones for a year now, and I haven't had any problems in the past. If someone could explain how i could fix this issue, that'd be great.! Oh,...
Sound & Audio
Creative HS-420 headset mic not working
I have a friend who has just purchased a Creative HS-420 headset to use with his Toshiba Satellite Laptop (running Windows 7 Home Premium). The headset cables are plugged into the correct headphone/mic sockets at the front left side of the laptop, and the headphones work fine but the microphone...
Sound & Audio
No sound with Creative X-FI Elite Pro
So I recently upgraded from windows xp to windows 7 and have been having problems with my sound card. When I select a Playback Device I don't get sound if I choose Creative SB X-fi. However I do get sound if I choose High Definition Audio Device. When I have the Creative SB X-fi selected as a...
Sound & Audio
X-Fi Elite Pro remote not working
Hi guys, I'm on windows 7 64 bit. Just got the creative x-fi elite pro today and I can't make the remote work with windows 7. I have installed the latest driver for windows 7 on their site. I even reformated and freshly installed the drivers to verify there was no conflict without any success....
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:10.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App