Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 64 bit HDMI Audio Problem


08 Jan 2010   #1

Windows 7 64 bit
 
 
Windows 7 64 bit HDMI Audio Problem

I have just built an i5 rig and can't get the audio to work over the HDMI, I have seen many posts but none of the solutions seem to work for me.

I have:

1) Realtek ALC888 onboard audio - R240 drivers.
2) A 9600GT with DVI to HDMI adapter - 195.62 drivers. (Tried the 181 drivers as well)
3) Patch lead from SPDIF out socket on the motherboard to the 9600GT card
4) Motherboard is a Gigabyte P55-US3L

If I select "Realtek digital output" in playback devices the level bars are moving as they should but obviously there is no audio from the monitor. I have seen a few posts mentioning an ATI HDMI Audo device, is there an NVIDIA equivalent? If so I haven't got one and can find no reference to HDMI audio.

In the NVIDIA control panel it shows my monitor as audio enabled but I can find no other settings to do with HDMI audio. I have plugged a bluray player into the monitor and the sound is fine so that discounts a faulty new monitor. Any ideas peeps........


My System SpecsSystem Spec
.

08 Jan 2010   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

If you have S/PDIF as one of the outputs, what happens if you select S/PDIF as the "playback device" in the Sounds Panel?
My System SpecsSystem Spec
09 Jan 2010   #3

Windows 7 64 bit
 
 

I have ony got 2 playback devices.

1) "Speakers" - This works fine.

2) "Realtek Digital Audio" - The green level indicators flicker but no output.

Cheers
Mark
My System SpecsSystem Spec
.


09 Jan 2010   #4

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

In the Playback panel, RIGHT click in an empty area and there should be two options, (1) to show disabled devices and (2) to show disconnected devices. If these are not checked, click the box(s) to show these devices in case the device you need is not shown.
My System SpecsSystem Spec
09 Jan 2010   #5

Windows 7 64 bit
 
 

Both options are ticked. I have unticked them and reticked them incase it needed refreshing but no joy.

Cheers
My System SpecsSystem Spec
09 Jan 2010   #6
Microsoft MVP

Win 7 Ultimate x64
 
 

Quick question for you,

Quote:
A 9600GT with DVI to HDMI adapter
Did the adapter come with the card or did you buy it separately? If purchased separately and just a regular DVI-HDMI addapter that would be why you aren't getting any sound over HDMI.

Great guide on hooking and setting up here,

Guide: 8800GT/9800GT/9800GTX Sound over HDMI (Now including Creative cards) - Overclock.net - Overclocking.net
My System SpecsSystem Spec
10 Jan 2010   #7

Windows 7 64 bit
 
 

Hi Stormy13, yes it is the adapter that came with the card.

I have dug out an old Sound Blaster Audigy 2 card and that gives the same results. Speakers work from the back but nothing from the HDMI port.

I think it may be time to change this old 9600GT .......
My System SpecsSystem Spec
10 Jan 2010   #8
Microsoft MVP

Win 7 Ultimate x64
 
 

Have you tried playing with the pass-through setting here,

http://forums.tweaktown.com/attachme...k-manger-2.jpg

Another question (may sound stupid), have you tried reversing how the connector is plugged onto the motherboard (2-1 instead of 1-2)?
My System SpecsSystem Spec
10 Jan 2010   #9
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by deke View Post
This adapter only for video output via HDMI. 9600GT doesn't have any audio capabilities.
No one said it did. And if you really want to get technical, there is no Nvidia card with audio capabilities. What most of them have (including the OP's 9600 GT) is a SPDIF header on them that when connected to the SPDIF out header on a sound card, allows the card to pass-through audio over HDMI, of which most of the cards need to use the DVI-HDMI adapter that came with the card to work (a standard DVI-HDMI adapter won't work) as most of them don't have a HDMI port on them.

Mark and Cath one thing I do remember seeing is that there was a driver release or two from Nvidia that somehow managed to break the audio out on those cards. Don't remember which driver(s) it was but have a look around over here,

NVIDIA Forums

pretty sure that is one of the forums I saw it mentioned on.
My System SpecsSystem Spec
10 Jan 2010   #10

Windows 7 64 bit
 
 

Hold the phones !

Right then I have found the issue. There is a file hidden in the installer folder called "hdaudio_1.00.00.63_xp_vista_win7.exe", problem is it fails to run on 64 Bit windows 7 but this is clearly the key to the issue.

When I get it or another version to run I will report back.

Cheers for now.......
My System SpecsSystem Spec
Reply

 Windows 7 64 bit HDMI Audio Problem




Thread Tools



Similar help and support threads for2: Windows 7 64 bit HDMI Audio Problem
Thread Forum
HDMI audio out problem Sound & Audio
Solved Another HDMI Audio Problem Sound & Audio
Hdmi audio problem Music, Pictures & Video
HDMI Audio Problem Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI Sound & Audio
Windows 7 - HDMI out no audio - Intel HDMI audio Sound & Audio
HDMI Audio Problem Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:31 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33