Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: HDMI surround sound

09 Jan 2010   #1
kb88

win 7
 
 
HDMI surround sound

my computer is connected to my surround sound box then to the TV. But windows only lets you choose 2 ch stero output via the HDMI. The only explaination i could come up for this is that windows detects my TV having only two speakers and doesn't detect my surround sound having 7.1 speaker set up....? how can you force win 7 to output 7.1 via HDMI????


My System SpecsSystem Spec
.

10 Jan 2010   #2
fireberd

Windows 7/8.1/10 64 bit
 
 

Windows is not "detecting" your TV - it doesn't know or care what is connected. However, many systems only output two channel stereo via the HDMI and it's up to the TV or surround audio system to provide the surround sound. This is also true of the S/PDIF output on many systems.
My System SpecsSystem Spec
11 Jan 2010   #3
kb88

win 7
 
 

If windows does not know what is connected then why does it have the information of my tv monitor including the max res, refresh rate and the model????
I know for a fact that the video files that i play have 6ch's to output but windows will not pass them on as it only lets you choose 2ch for HDMI. So maybe my theory is wrong but there should be no reason why windows shounld not be able to output dolby 5.1. The anoying part is that windows will let me set the normal speaker outputs on the back of the computer to dolby 5.1 surround sound.... surely there are ppl out there who can get surround sound through their hdmi set up...
My System SpecsSystem Spec
.


11 Jan 2010   #4
fireberd

Windows 7/8.1/10 64 bit
 
 

You didn't list your hardware profile in the System Specs. Knowing what you have will help someone to help you with the problem.
My System SpecsSystem Spec
12 Jan 2010   #5
kb88

win 7
 
 

AMD Athlon 64x2 5200
MSI main board K9AGM2
32" LCD 1080i
My System SpecsSystem Spec
Reply

 HDMI surround sound




Thread Tools





Similar help and support threads
Thread Forum
No surround sound through HDMI in Windows 7
I have a Asrock 330 running Windows 7. Whatever I do I am not able to get surround sound via HDMI. My setup: - Asrock 330 running Windows 7 pro rtm - HDX-1000 media streamer - Samsung 55" 7070 LED display - Onkyo surround reciever The Asrock and the HDX-1000 is hooked up tp the TV via...
Sound & Audio
No Surround Sound via HDMI
I have Windows 7 32 bit running on an Aver Aspire Revo 3610. The "sound card" is a High Definition Audio (I couldn't find further details on it). I'm trying to get surround sound on my Samsung reciever by plugging in a HDMI cable from the computer to the receiver. I get sound, but only through 2...
Sound & Audio
HDMI 5.1 surround sound not working
I am aware that there are a number of threads on this topic here and elsewhere, yet I have spent hours searching, reading, and attempting fixes to no avail. I have a computer with a NVIDIA GeForce GT240 graphics card that is passing audio and video via HDMI through a Denon AVR-591 receiver, and...
Sound & Audio
hdmi and surround sound
I have alot of trouble with getting surround to work through hdmi. My setup is the following - the Revo 3600 is connected through hdmi to my Denon AV-Receiver which sends the sound/picture to my Sony TV also through hdmi. But I have alot of trougle to get surround to work. When I look in the...
Sound & Audio
No surround sound through HDMI to AV Receiver
I am connecting my laptop to my AV receiver via HDMI cable. With both streaming video (netflix, hulu) and various video formats, I am not getting any surround sound. Is there a setting in Windows 7 I am missing? Thanks for any help!
Sound & Audio
Surround sound works via HDMI, but not WMV's, no audio
Hey everyone, new to this site, I've got a bit of a problem with my audio with my new installation of Windows 7. Previously I had Vista installed, and had no problems with my Realtek HD audio. Installed Windows 7 everything looked good, then realized my Sony A/V receiver model SA-WCT100 was not...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:52.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App