Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Need help with Sabrent SBT-SP6C No Sound Issue

11 Jan 2010   #1

W7
 
 
Need help with Sabrent SBT-SP6C No Sound Issue

I purchased a SBT-SP6C which is on Microsoft's Windows 7 acceptable hardware list. I've installed it and downloaded the Windows 7 drivers fromthe Sabrent website. The device shows up in my system, but I get no sound. I know my speakers work because I hooked them up to an external source. I can hear some feedback when I unplug the jack.

This is on my son's Dell 4600. Any ideas?

My System SpecsSystem Spec
.

11 Jan 2010   #2

Windows 7 Ultimate 32 bit
 
 
Sound

in sound properties make sure to select that device as playback device
My System SpecsSystem Spec
11 Jan 2010   #3

W7
 
 

It is, it's the only sound device in the computer.
My System SpecsSystem Spec
.


11 Jan 2010   #4

Windows 7 Ultimate 32 bit
 
 
Sound

check all output jacks and make sure to select how many speakers your using the sound control area in 7 at least on mine is a little weird to figure out
My System SpecsSystem Spec
11 Jan 2010   #5

Windows 7 Ultimate 32 bit
 
 

can you right click on the speaker icon and choose configure
My System SpecsSystem Spec
11 Jan 2010   #6

W7
 
 

I tried each output jack on the card. I could hear static each time I disconnected and reconnected the speakers. I configured the sound card. Windows says the card is working fine. Still no sound.
My System SpecsSystem Spec
11 Jan 2010   #7

Windows 7 Ultimate 32 bit
 
 
Sound Card

card may be faulty can you try it in another machine just to make sure
My System SpecsSystem Spec
11 Jan 2010   #8

Windows 7 Ultimate 32 bit
 
 

are you using 32 or 64 bit windows
My System SpecsSystem Spec
11 Jan 2010   #9

Windows 7 Ultimate 32 bit
 
 
Drivers

it appears there are no 64 bit drivers that i can find
My System SpecsSystem Spec
12 Jan 2010   #10

W7
 
 

I'm using 32 Bit. I e-mailed Sabrent and Jeff had me try and see if I got any different result on another PCI slot. I tried 2 other slots and had the same result...no sound. The weird thing is, I can go to the configurator and click the speaker to mute and un mute. I hear a noise when I do that.

This is very frustrating because I only purchased this sound card because it was on Microsoft's website for compatibility. I purchased two for two different computers because the card I had in them were not on Microsoft's list.
My System SpecsSystem Spec
Reply

 Need help with Sabrent SBT-SP6C No Sound Issue





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:07 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33