Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: New sound card install problem

19 Jan 2010   #1
Ingeld

Windows 7 64 bit
 
 
New sound card install problem

I just did a fresh install of windows 7 and I decided to replace my older X-Fi XtremeGamer Fatal1ty Pro Series that was in the old PCI slot with the PCI Express X-Fi Titanium Fatal1ty Pro Series. Problem is that windows install generic drivers for it and when I try to install creative drivers the software says it cant find the hardware. I found on Creatives site the Product Identification Module Update that from what I read if fixes the detection problem BUT it cant even find the hardware. Am I stuck using the default crap ass windows drivers or is there a fix for this? I am almost ready to try and take it back to the store I bought it from.


My System SpecsSystem Spec
.

19 Jan 2010   #2
Pauly

Win7 Ultimate X64
 
 

You could try uninstalling the device/software then re-installing from device manager and when it wants drivers point it a the folder you downloaded should stop it loading the generic windows driver
My System SpecsSystem Spec
19 Jan 2010   #3
Crispy

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)
 
 

Uninstall the generic driver then run this program Guru3D - Driver Sweeper it will clean out left over files from uninstalls, then download the drivers and reinstall: Creative Sound Cards.
My System SpecsSystem Spec
.


19 Jan 2010   #4
RST101

Windows 7 Ultimate x64.
 
 

Your not missing much anyway as all creative drivers are not much better(if they are at all).
My System SpecsSystem Spec
19 Jan 2010   #5
Ingeld

Windows 7 64 bit
 
 

I am really thinking of pulling the Titanium card out and reinstsll the older PCI version Xtreamgamer since I could get all the drivers working for it ..... I find it weird that that the PCI version gives me no probles at all but the PCIe version casnt even remotly be installed. I even tried installing the drives directly ... they would instsall but on reboot i get the red "X" and the card is disabled.
My System SpecsSystem Spec
20 Jan 2010   #6
Crispy

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)
 
 

Quote   Quote: Originally Posted by RST101 View Post
Your not missing much anyway as all creative drivers are not much better(if they are at all).
I still have a Audigy2 ZS and its shits over my onboard realtek card compared to the quality off the audio its outputs.
My System SpecsSystem Spec
20 Jan 2010   #7
Ingeld

Windows 7 64 bit
 
 

Ive tried the latest driver from Creative "2.17.2007" and it cant find/detect the hardware so I tried the "Product Identification Module Update" from them that claims to "This update resolves the hardware/device detection issue for Creative Sound Blaster® X-Fi™ and X-Fi Titanium series of audio devices in Microsoft® Windows® 7."
Its ALSO cant find the hardware in the system. Its very frustrating to buy a $150 sound card and not be able to use it proper because Creatives driver dont work and the generic Windows7 drivers don't enable 5.1 or anything else ...... it makes it as worthless as on-board sound.
My System SpecsSystem Spec
20 Jan 2010   #8
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

Have you tried to manually install just the driver? First you need to extract the downloaded driver file using something like Winrar, then you can try it one of two ways,

1. Go into the extracted folder, locate the Drivers folder and run the setup.exe found there (not the one found in the main folder).

2. If the above doesn't work try to install the driver manually in Device manager,

Device Manager - Install Driver - Vista Forums

that is from the Vista tutorials but the same steps apply in Windows 7. The file you are looking for once you click on "Browse my computer..." is wdma_emu.inf located in the 'Drivers\wdm" folder.

If either method works, you can then run the regular installer to get the rest of the apps that you want (Audio Console, Console Launcher, etc).

P.S. That update from Creative is a fix for their own Auto-update program, not for detection issues in Windows.
My System SpecsSystem Spec
20 Jan 2010   #9
Ingeld

Windows 7 64 bit
 
 

I tried that. The driver installed but then I got the red "X" on the hardware and it said it was disabled and needed to reinstall the driver. I thought that maybe at that point I could use Creatives update to fix it .... didn't work .. the update claimed there was no Creative hardware installed. And even with the generic Windows 7 drivers installed there is no output from any of the audio jacks even tho I could see that little green bar bouncing with the music. I think Creative as a whole is a FAIL of a company .. I mean .. how does a company wait for a OS to be released BEFORE they start trying to create drivers for he OS? Hell ... I had the beta back in February 09' why didn't they ?
My System SpecsSystem Spec
21 Jan 2010   #10
kawi250

WIN7-64
 
 
X-fi fix

Creative Worldwide Support > PCI Express X-Fi Titanium Fatal1ty Pro Series


Go here and d/l first item it will fix your problem.
My System SpecsSystem Spec
Reply

 New sound card install problem




Thread Tools





Similar help and support threads
Thread Forum
No Sound Card Driver fails install
I've been searching the internet for a few days now and I still cannot find the way to get my sound card to work. I have tried many different drivers and now that I'm set on keeping 7 I just need to figure this out. I'm running Windows 7 Ultimate 64 on my HP DV8000. Here is my id info for my...
Sound & Audio
Sound problem perrsists even after new sound card
As some of you might remember, a few weeks ago I had a problem with sound after I built a new PC and kept my old Win 7 installation using sysprep: http://www.sevenforums.com/sound-audio/280175-onboard-sound-issue-new-pc-build-2.html#post2308990. The problem was that the volume levels were off, and...
Sound & Audio
Problem with sound card
Have just done anew build and installed an Asus Xonar DG sound card in this afternoon -just like in my Sandy Bridge build. Now I have tried installing the driver but it goes half way and then stops with the message in the pic and I have no idea what this is about. Never happened on the...
Sound & Audio
problem with sound card
hi to all i recently updated my pc to asus p6x58d premium intel i7 950 corsair 2x3 gb ram triple channel 2000 mhz power 900 watt acbel gtx 295 vga 3 sound cards: 1.tc electronic konnekt 8 external sound card connect with pc via firewire(i must use it for music making) 2.creative xfi xtreme...
Sound & Audio
No sound after W7 install - Soundmax card
Hello I have a thinkcentre serial is 8171-CTO; I ran the Win7 upgrade advisor but after about 20 tries it told me over and over again I had no internet connection!1! Which I do as I had freshly downloaded the tool. Anyway, I decided to go for it anyway (doh) and although the OS etc installed...
Drivers
Weird sound card problem
I'm using an audigy 2 zs, just updated the sound card by downloading from creativelab. I have a problem with the card in windows 7 though: I like to get the treble all the way up, and the bass up a bit, it makes things sound alot nicer. But, everytime I do this, the voices of characters when I...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 00:40.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App