Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: No audio through HDMI

29 Jan 2010   #1

Windows 7 Home Premium 64-bit
 
 
No audio through HDMI

I just bought an HDMI cable to connect my laptop to my HDTV. The video looks great, but the audio won't play on the TV. While the video is playing on the TV, the audio plays from my laptop instead of through the HDMI to the TV like it should.

I've seen other people with similar problems, but for me, when I go to sound in the control panel and Playback devices, the only device listed is Speakers. There's no HDMI or SPDIF options or anything else. There are, however, in Device Manager, two sound devices and one of them is "Intel High Definition Audio HDMI". I've tried uninstalling and reinstalling the driver but nothing works.

Any help would be greatly appreciated!

(I'm running Windows 7 Home Premium 64-bit on an HP G60-443CL laptop.)

My System SpecsSystem Spec
.

29 Jan 2010   #2

Microsoft Community Contributor Award Recipient

Windows 8.1 Pro Preview with Media Center
 
 

Hello Tinieblas, welcome to the Seven Forums.

Check first that playback devices is not hiding the disabled devices. Read here how to do that. If disabled, enable it.

Kari
My System SpecsSystem Spec
29 Jan 2010   #3

Windows 7 Home Premium 64-bit
 
 

Still nothing...

I checked and it was set to not show disabled devices, but even when I told it to show disabled devices it's still not there. The only option is Speakers...

Any other ideas?

Thanks for the help!
My System SpecsSystem Spec
.


29 Jan 2010   #4

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Tinieblas View Post
Still nothing...

I checked and it was set to not show disabled devices, but even when I told it to show disabled devices it's still not there. The only option is Speakers...

Any other ideas?

Thanks for the help!
Did you install the latest drivers for your chipset and your graphics?
My System SpecsSystem Spec
29 Jan 2010   #5

Windows 7 Home Premium 64-bit
 
 

Yes, I've tried uninstalling, reinstalling, and updating all of the drivers... still nothing
My System SpecsSystem Spec
29 Jan 2010   #6

Windows 7 Home Premium 64-bit
 
 

SOLVED!!!

I installed the Vista 64bit driver for my graphics accelerator.

It yelled at me and said it wasn't compatible with my operating system, so I told it to run again using the recommending settings it opened and gave me a big warning that this was an older driver and I shouldn't use it. I told it to install anyways, and it works!

Hopefully they come out with a new Windows 7 driver that works, but for now it works and I'm happy!
My System SpecsSystem Spec
29 Jan 2010   #7

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by Tinieblas View Post
SOLVED!!!

I installed the Vista 64bit driver for my graphics accelerator.

It yelled at me and said it wasn't compatible with my operating system, so I told it to run again using the recommending settings it opened and gave me a big warning that this was an older driver and I shouldn't use it. I told it to install anyways, and it works!

Hopefully they come out with a new Windows 7 driver that works, but for now it works and I'm happy!
lol, glad you got it resolved
My System SpecsSystem Spec
07 Feb 2010   #8

windows 7
 
 
problem

I'm having this same problem, hp g60, windows 7 32bit, Intel(r) High Definition Audio HDMI driver is installed and working, the HDMI audio out worked for vista. After I upgraded it never worked. The video works great, but no audio in playback devices. There is also Conexant HighDefinition SmartAudio I downloaded that driver from hp.com and reinstalled that with no success.

Why does downgrading the grphx accelerator fix the problem>?
My System SpecsSystem Spec
08 Feb 2010   #9

windows 7
 
 

Went to intel.com they have a page that searches your computer and looks for outofdate drivers, it was indeed my gphx card that needed updating and finally got my HDMI audio out, THANK GOD. !! Thanks for all the help guys.
My System SpecsSystem Spec
12 Mar 2010   #10

Kubuntu Karmic Koala 64-bit
 
 

I have an HP (G60) laptop that uses the Mobile Intel 4 Series Express Chipset Family graphics driver/HDMI audio driver. (There is also a Conexant audio driver, but that is for the speakers, not the HDMI port).

During my upgrade to Windows 7 (the computer came with Vista, but HP offered a free upgrade), the Intel drivers were replaced by Microsoft drivers, which didn't support HDMI sound properly.

From the HP support site I downloaded the original Intel drivers and re-installed them (although it is the "graphics driver", it also has the HDMI audio driver). Everything (video and HDMI audio) then worked properly again.

Never upgrade to Microsoft-supplied drivers for hardware and beware automatic updates for hardware drivers.
My System SpecsSystem Spec
Reply

 No audio through HDMI





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:15 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33