Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative Sound Blaster

18 Nov 2008   #1
csa02221862

XP Pro, Vista Ultimate, Windows 7 Ultimate, WHS
 
 
Creative Sound Blaster

Well my Sound Blaster SB0460 X-FI Music Extreme wont work. Win 7 doesn't even see it. When I try to load the Vista drivers it said its not compatible with this operating system. Had the same STUPID problem with Vista until they released Vista specific drivers.

Rich


My System SpecsSystem Spec
.
18 Nov 2008   #2
mansrm81

Windows 7 Ultimate x64/ Windows Vista Ultimate x64
 
 

Try running the installer with the compatibility for vista RTM.
My System SpecsSystem Spec
18 Nov 2008   #3
csa02221862

XP Pro, Vista Ultimate, Windows 7 Ultimate, WHS
 
 

Tried that and it didn't work. Tried it again and it did! Probably fat fingered something.
My System SpecsSystem Spec
.

02 Jan 2009   #4
albert0373

XP
 
 

Having the same problem with my X-Fi Audio Extreme

How can I install the drivers for it when it doesn't even detect the card?

I have onboard and that installed fine but the sound quality is crappy.

Please remember that this is a public site and you'll need to confrom to the rules - Da mods.
My System SpecsSystem Spec
02 Jan 2009   #5
albert0373

XP
 
 

Found it appears actually in Device Manager, just wasn't getting prompts for installation.

Whenever I try to install it, it always crashes and I encounter a BSOD

Guess I have to wait this one out and try to figure out what's wrong..
My System SpecsSystem Spec
06 Jan 2009   #6
ze7en

Almost all
 
 

BSOD? have not had one yet on w7 and I did a lot of things that vista or xp would surely have done a blue snow job on me.

I did run into a seemingly locked up state, but was actually a priority wait state, it didn't even want to let me get into the task manager at first, but I got a break between lines and got in and killed the process in active wait and continued on.....


HOT AMAZING THING......

No Power Supply back-ups,,, running about 6 computers, all with different OS's and my high end dsl modem and high end dsl account......

The storms we had the other night, with several power breaks and brown outs that lasted 5 seconds or more, all my computers went off, EXCEPT the one I was testing Windows 7 on. It appeared to go off along with the others when all the lights went out, but as the others had their bios beeps trying to start back up I heard nothing from the w7 pc, and the first light in the house was one incandescent light, the second was the w7's monitor, the desktop was still on, the download had stopped but not disconnected, once the modem was back online the download continued, all the other pc's were still booting up, 4 of which are equall to the w7 test box, I didn't think much at first, but when I finished opening what I wanted on all the other pc's I came back to the w7 and the power went out again, and longer, and I was sitting there in the dark, for a second and thinking is this thing actually going to come back again, no not possible....... then it did.... it blew me away, and two more times it happened and still that w7 "thing" hung onto life...

Not sure at this point what to think, if this is great, or is it umm... Chucky ¿.... or re-animation...

Either way it is a 64bit spooky Q..... I was on the phone during all this with a friend who lost all his too, but this windows7 box I can not explain...
My System SpecsSystem Spec
07 Jan 2009   #7
SnapCount

Windows XP Pro SP3 / Windows 7RC 7100
 
 

Quote   Quote: Originally Posted by albert0373 View Post
Found it appears actually in Device Manager, just wasn't getting prompts for installation.

Whenever I try to install it, it always crashes and I encounter a BSOD

Guess I have to wait this one out and try to figure out what's wrong..
This is what i did to install my X-Fi XtreamGamer card.

Download the latest drivers from creative

Put in the install CD that came with your card and install as usual.

Once install is done and you have done a re-boot. Right click on the updated driver file and select Vista Compatibility and Run as Admin

After reboot windows will come back saying that its not a compatible version. Don't worry, just as long as the drivers were uninstalled. Do the same thing again with the updated driver file and it will install properly.
My System SpecsSystem Spec
11 Jan 2009   #8
bansh

Windows 7 Professional x64 (Build 7600)
 
 

For me it works too, but I'm not able to select an EQ from the Console. Im also not able to get into the Mixer Menu. Everytime i try that the Creative Console crashes.
My System SpecsSystem Spec
11 Jan 2009   #9
echrada

Windows 7 Ultimate x64
 
 

The latest drivers are here

Creative Worldwide Support > X-Fi XtremeMusic
My System SpecsSystem Spec
15 Jan 2009   #10
bluewater

windows7
 
 

First, you'll need to download from Creative the driver dated 10/25/07. Secondly, right click on properties & select compatibility. Change to XP. Install and follow instructions. Afterward, you can update the Drivers using the new driver dated 12/19/08. Change compatibility to run on VISTA
My System SpecsSystem Spec
Reply

 Creative Sound Blaster




Thread Tools




Similar help and support threads
Thread Forum
Creative Sound Blaster 2 Z5 - Mic Not Functioning
I was trying to get my mic to work with a sound card called "Creative Sound Blaster 2 Z5" I updated all the software and the mic is seen by the software. I attach what setting I have right now. The sound is coming out my system mobo to my speakers and mic. My mic is get power via USB and has audio...
Sound & Audio
Creative Sound Blaster 5.1 live
Hi hope someone can help i am very new to this forum, at this moment i running XP Pro I want going to upgrade To Win 7 but it not recognise my Creative Soundblaster 5.1 sound card which is working fine under XP with all that i use i have been on web site to try & find driver for it. someone posted...
Sound & Audio
Creative Sound Blaster Audigy 24bit Sound Card
I installed windows 7 a little while ago but i cant seem to get a driver that will recognize my sound card. the computer doesnt think its installed correctly but when i was using Xp it was just fine. ive tried another PCI slot but no such luck. all of the drivers i have tried tell me that they dont...
Drivers
creative sound blaster 5.1 vx
hei guys i just bought this sound card creative sound blaster 5.1 vx and bought a creative inspire 5.1 system now i have a windows 7 opertaing system and the sound card was not running so i went to the creative site and downloaded drivers from there and then installed them its installed and...
Sound & Audio
Creative Sound Blaster 5.1 Live!
Hello all. After 2 weeks of trying to get driver for my SB 5.1 live! sound card,i did nothing then tapping in place... Ive tryed everything ive remembered to but i still cant find any solution. I know its an old sound card,but drivers must be here somewhere... Im using Win7 v.7600 RTM 64-Bit...
Drivers
creative sound blaster audigy se drivers
i have just downloaded the ones that stormy showed and i also downloaded from the creative website itself. i have installed and reinstalled and restared my computer many times and still no luck what so ever. all it says is that there is no audio output device installed when actually i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 07:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App