Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: no sound on hdmi

10 Feb 2010   #1
fretworker

windows 7 ultimate
 
 
no sound on hdmi

Hello all, looking for help.

I have a dell studio 1735 that was just upgraded from vista to windows 7 ultimate. I have an hdmi on the left side opposite the headphone jack. I used to connect my phillips lcd to the computer via the hdmi and watch tv shows. Now i cannot get the sound to work on my tv. The video works great and the sound on the computer works also but its not changing to the tv like it did before.

I have updated all the drivers audio, etc on intel and completed all windows updates. I have confirmed its not the hdmi cable or the tv via different hdmi connections and my antenna. can anyone help? Thank you....


My System SpecsSystem Spec
.
11 Feb 2010   #2
WalkerA WinTeam

Windows 7 Home Premium (64-bit) *** Windows XP SP3 (32-bit), OSX 10.6
 
 

Hi fretworker,

I'm assuming your Dell Studio has Intel GMA 4500M graphics? Please correct me if not.

By going into Control Panel > All Control Panel Items > Sound, you will hopefully see the HDMI out uses a separate driver called something like "High Definition Audio Device" which is not listed on Dell.com. When you updated drivers, there's a good chance you missed this one (through no fault of your own).

1. Right-click on the HDMI output, select Properties, and make sure the device is enabled.

2. If it is, click Properties in the Controller Information area, switch to the Driver tab, and try to Update Driver.

3. If it's greyed out, go to Control Panel > All Control Panel Items > Device Manager. Expand 'Sound, video and game controllers', right-click "High Definition Audio Device" and select Update Driver Software. If it needs updating, update and report back here.

Let me know how everything goes...

Cheers,

Walker
Windows Outreach Team
My System SpecsSystem Spec
11 Feb 2010   #3
fretworker

windows 7 ultimate
 
 

Hello Walker,

Thanks for the info. I am not sure what graphics card I have. Can't remember how to get to it to see, do you know where I can view the type?

I went to the control panel, sound. Found (Speakers/headphones: IDT High Definition Audio CODEC)
and (Independent headphones: IDT High definition audio CODEC). I didn't see any HDMI out. Are one of these two what I am looking for? I did however go to device manager, sound and found 2 items: (IDT High definition audio CODEC) and (Intel High definition audio HDMI). I have been tring to update those two drivers thinking one is the problem but it says that they are up to date and functioning properly. restarted system 1 time then connected tv, still no sound. Restarted again with tv connected, still no sound. Any other ideas?

Thank you,

Fretworker
My System SpecsSystem Spec
.

03 Oct 2010   #4
Gilberto

Windows 7 Ultimate x32
 
 
Same problem

I'm in the exact same boat as you fretworker, but sorry I can't offer any help yet. I hope one of us or someone else can post a solution for this soon. Thanks
My System SpecsSystem Spec
03 Oct 2010   #5
sygnus21

Windows 10 Pro
 
 

Do realize this thread is 8 months old - (Feb 2, 2010)

Can you post what your problem is, with your system specs?

See this post - How To Ask For Help

Thanks
My System SpecsSystem Spec
03 Oct 2010   #6
Gilberto

Windows 7 Ultimate x32
 
 

Yes, I do realize that this post is that old, but I just got a VIZIO TV myself and tried to hook it up via HDMI. So I have the exact same problem that fretworker has and the same specs (Dell Studio1735, Windows 7 Ultimate x32, updated all the drivers, etc.) I've googled for quite sometime and this defines my problem best.

"I went to the control panel, sound. Found (Speakers/headphones: IDT High Definition Audio CODEC)
and (Independent headphones: IDT High definition audio CODEC). I didn't see any HDMI out. Are one of these two what I am looking for? I did however go to device manager, sound and found 2 items: (IDT High definition audio CODEC) and (Intel High definition audio HDMI). I have been tring to update those two drivers thinking one is the problem but it says that they are up to date and functioning properly. restarted system 1 time then connected tv, still no sound. Restarted again with tv connected, still no sound. Any other ideas?"

My graphics card is the Intel GMA (not sure if its 4500)

So, once again, I don't see that HDMI option on my sound playback (even with disable devices displayed)

Any help is greatly appreciated.

Thanks,

-G
My System SpecsSystem Spec
03 Oct 2010   #7
Gilberto

Windows 7 Ultimate x32
 
 

My apologies, this is actually my first time posting on a tech forum. Once again, any help is greatly appreciated and if any more info is required, please let me know.

-G
My System SpecsSystem Spec
03 Oct 2010   #8
sygnus21

Windows 10 Pro
 
 

OK, two things....

First, you need to make sure you have an HDMI cable hooked up to a suitable HDMI system, such as a monitor or reciever. Looks like you've done that.

Than, go to Control Panel, Sound, Playback tab, and make sure the HDMI output is set to default. That will ensure your HDMI is the default sound output for the system.



Let me know.
My System SpecsSystem Spec
03 Oct 2010   #9
Gilberto

Windows 7 Ultimate x32
 
 

I see, but that's the problem that I don't have the HDMI device shown as an output on my playback tab. Check out my screen shots:

So even though it doesn't show up on the playback devices(left), the device manager recognizes there is HDMI audio (right).

Thanks again for your reply and look foward to any more help.

-G


Attached Images
 
My System SpecsSystem Spec
03 Oct 2010   #10
Gilberto

Windows 7 Ultimate x32
 
 

I've also tried to update the Intel HDMI audio driver, but it's current.
My System SpecsSystem Spec
Reply

 no sound on hdmi




Thread Tools




Similar help and support threads
Thread Forum
No sound through HDMI
A few days ago, I plugged a HDMI cable into my new laptop and watched a few videos on my HDTV. No problems whatsoever. Since then though, every time I plug in the HDMI cable, the video comes through just fine, but there's no sound. I've found several threads with similar problems, both here and on...
Sound & Audio
Sound Control panel takes 2 minutes to open; HDMI sound inconsistent
Brand new Windows 7 Home Premium (6 bit) computer. When I click on the Sound control panel item, sometimes it takes 1-2 minutes to open. But that's kind of minor (although I'd like to know how to fix it), because sometimes the HDMI sound to my HDTV works fine, and sometimes it doesn't work at all....
Sound & Audio
NO SOUND TROUGH HDMI ON ACER AX3400-U3032 and No HDMI Icon in sound se
Had to replace motherboard from authorized acer parts dealer now I get no sound through HDMI port. I did through the original board until it got fried by electrical surge. Can any one help or send me a picture of the inside the same model to make sure all jumpers on the motherboard are in the...
Sound & Audio
No sound through speakers.Jack not being detected.HDMI sound only?
So I've got a problem,I changed my case 2 days ago and everything went great,all working as it should be.Up until an hour ago,when the lid got stuck in one of the little clips so after a quick bang it went in.But then I lost my picture on both monitors. So I went to investigate,I ended up...
Sound & Audio
no sound through tv via hdmi, sound plays through laptop speakers (idt
Yesterday I installed a new external hard drive - following the installation - my sound no longer played through my television (video is fine, HDMI connection) and sound now comes ONLY through the laptop speakers. The option for HDMI Audio doesn't appear in the 'sound' menus. I have 'checked'...
Sound & Audio
No sound via audio jacks, but sound via hdmi.
I recently done a new build, not with the same specs I have on here; i5 2500k p8z77-m pro sapphire radeon 6870 I cannot get any sound through the front+back headphone jacks, realtek doesnt detect any audio devices, however i can mess around with the settings to get windows to say i have...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App