Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Build 7057 - Realtek HDMI only getting 2.0

04 Apr 2009   #1

 
 
Build 7057 - Realtek HDMI only getting 2.0

Hi,

I have Windows 7 build 7057 installed. I just installed Realtek HD Audio Drivers 2.21 and I am finally able to get sound out of my HD 3300 integrated HDMI port. Now the problem is I am only getting 2.0 instead of 5.1.

When I click the Configure button on the HDMI jack in Sound Properties window, nothing shows up.

Is there where I set the speaker set-up?

Thanks.
Rishi

My System SpecsSystem Spec
.

04 Apr 2009   #2

 
 

Update: After multiple resets the configure button now displays a window. But now the problem is it only shows "Stereo" as an option for speaker setup, no 5.1 Setup option.

One other thing I noticed is the driver for the HDMI device still shows Microsoft driver even though I have installed the Realtek driver two times. I tried to a do a manual update of the driver using Device Manager but Windows says the latest one is installed.

Any ideas? I am assuming this is a driver issue not a Windows one.

Thanks again.
My System SpecsSystem Spec
04 Apr 2009   #3

Vista 32 SP1 and W7 7201 x64
 
 

Out of curiosity when have you ever been able to get more than 2 sound channels from your HDMI port..? I assumed that was the best you could get.?
I'm using an optical s/pdif to get 5.1.
My System SpecsSystem Spec
.


04 Apr 2009   #4

 
 

This is a new computer and I have only had Windows 7 installed on it. So no, only been able to get 2.0 on it.

I guess it might be worth installing Vista and seeing if the HDMI port hardware is working.

I was able to get 5.1 out of my optical port too but my receiver is retarded and it expects audio over HDMI if video is coming over it. No way to mix the optical port and HDMI video together.
My System SpecsSystem Spec
04 Apr 2009   #5

Vista 32 SP1 and W7 7201 x64
 
 

mmm in that case I think that you are stuffed. AFAIK HDMI from an ATI 3300 GPU will only support 2 channel sound over the HDMI port, but I'm not positive on that.

I used to use my 4870 HDMI port to carry the picture to my 50" Plasma and the sound, but it was only stereo, although it was supposed to support 5.1

I now use a dedicated HTPC and the NVidia GPU carries the video via HDMI to the TV and the sound is sent via optical s/pdif to my amp.

EDIT : Can't you just send the sound to the amp (optical or coax) and the HDMI to your TV as a separate signal..?
My System SpecsSystem Spec
04 Apr 2009   #6

 
 

I could try that actually. I just looked it up and all the Radeons do support 5.1 over HDMI so I know it should work.

I just figured out there is an additional ATI HDMI driver available from Realtek site, after installing that it kicked the Microsoft driver out and is now using a Realtek one but still no option for 5.1 sound. Even the Realtek manager does not have the option, kinda strange will look into it more.
My System SpecsSystem Spec
04 Apr 2009   #7

Vista 32 SP1 and W7 7201 x64
 
 

oops - I thought that you were already using the Realtek driver for the ATI card, I could have mentioned that.

I have been thinking about what I had written and as my amp does not have a HDMI input when I connected the HDMI cable from my 4870 to my TV the optical connection from the TV to the amp downsampled the audio from 5.1 to two channel stereo. So even though the HDMI cable might well have carried the 5.1 signal it was not delivered to my amp as that by the TV.
Using s/pdif, of course, resolves all of those issues.

BTW - if you right click on the orange Realtek speaker icon in the system tray and select "audio devices" have you selected the "Digital output device" and selected the appropriate settings within that (DD / DTS audio etc etc etc)...?
My System SpecsSystem Spec
04 Apr 2009   #8

 
 

Digital Output device is for the SPDIF. I really would like to get the HDMI cable working as I bought a 25 footer to go from my computer to the TV in the next room over.
My System SpecsSystem Spec
04 Apr 2009   #9

 
 

So I uninstalled the Realtek codec and forced install the ATI 9.3 HDMI audio driver. After installing it my Configure speakers option is still only Stereo.

But I was playing with Media Center, and chose the speaker setup option and if I try 5.1, it works and the receiver shows it is receiving 5.1 while playing high-def recordings. Which is exciting, I am able to get at least 5.1 out of Media Center.

Last step is to get Media Player Classic Home Cinema to start outputting 5.1 and I am satisfied.
My System SpecsSystem Spec
05 Apr 2009   #10

Vista 32 SP1 and W7 7201 x64
 
 

[IMG]http://thumbnails13.********.com/3179/3d3b8731788702.gif[/IMG]

full size image...

******** - Fast, Free Image Hosting and Photo Sharing

"Digital output device" or the top one is for HDMI.

The centre one (used on the PC I'm writing this) is for the speakers

The bottom one is for the s/pdif / coax.
My System SpecsSystem Spec
Reply

 Build 7057 - Realtek HDMI only getting 2.0




Thread Tools



Similar help and support threads for2: Build 7057 - Realtek HDMI only getting 2.0
Thread Forum
Realtek HDMI Output ATI HDMI Audio -Not Plugged In- Sound & Audio
Build 7057 Search Bug? General Discussion
Build 7057 desktop.ini Fix General Discussion
Windows Media Player 12.0.7057.0 Original Files from Windows 7 Build 7057 Customization
Build 7057 64 bit? General Discussion
Build 7057 desktop.ini ISO fix General Discussion
Build 7057 MTU issues Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33