Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Dell XPS M1330 - Windows 7 32bit - No Sound

19 Feb 2010   #1
phat187

Windows 7 Ultimate
 
 
Dell XPS M1330 - Windows 7 32bit - No Sound

Hi to all

I recently installed W7 on my Dell XPS and found that my sound does not work. I have read through some forums about this problem but no luck in finding a fix. The closest I got to any sound was getting the earphones to work, but once I install another driver that also stopped working.

I have used SIGMATEL STAC 92XX C-Major HD Audio Driver aswell as the driver and utilities cd that came with the pc but still no fix to the problem.

Please see the screen shot attached, it might help out.

Thanks




Attached Thumbnails
-xps-scr.png  
My System SpecsSystem Spec
19 Feb 2010   #2
pebbly

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

here is a link from dell for the 32bit drivers Drivers & Downloads
My System SpecsSystem Spec
23 Feb 2010   #3
phat187

Windows 7 Ultimate
 
 

Thanks for that Pebbly but it still does not solve my problem... any other idea's?
My System SpecsSystem Spec
23 Feb 2010   #4
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Did you try the Vista x32 drivers?
My System SpecsSystem Spec
24 Feb 2010   #5
fireberd

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Although there is no chipset drivers listed for the Win 7 32bit drivers on the Dell downloads there is in the Vista driver downloads. If you didn't install the chipset drivers do that and then the Win7 32 bit driver (or Vista driver). The correct and required install sequence on a Dell is (1) Install Windows (2) Install Dell Laptop System Software (3) Install chipset drivers (4) Install device drivers including sound, video, ethernet, etc.

I do a lot of support on the Dell users forum (mainly desktops) and the biggest problem we see with sound not working on an install is that users have skipped the chipset drivers. One of the prime things the chipset drivers do is define (identify) all the devices on the motherboard.
My System SpecsSystem Spec
25 Feb 2010   #6
phat187

Windows 7 Ultimate
 
 

Hey Guys,

Yeah I've tried all the Windows Vista Drivers, from the Dell Support site and from the Driver and Utilities Disk I got with the computer.

I just reformated the computer, tried starting from scratch, funniest thing happened thou... A week ago my SPACE,N and B keys stopped working, after the format I did this morning the Keys started working again, I mean WTH???. Anyways, after getting everthing installed and the drivers updated I still have no luck with the sound, but when I connect the computer HDMI to my TV the sound works, just not the earphones or the computer speakers.

Any other idea's are highly welcomed, Remote support would also be appreciated

Thanks
My System SpecsSystem Spec
01 Apr 2010   #7
phat187

Windows 7 Ultimate
 
 

Alright, ive just gone out to buy a new keyboard, new battery and went back to Windows Vista Home Premium. Everything is working now but i still have my sound issue and i havent found a fix.
My System SpecsSystem Spec
25 May 2010   #8
dwarycha

win 7 enterprise
 
 
win 7 sound fix on dell xps M1330

i was having issues with no sound after in preformed a clean install of Windows 7 32bit from vista sp2 on my dell XPS M1330 machine. After an hour of working on it, i figured it out. From the dell site i downloaded the vista audio driver, from there i right clicked on setup.exe and went to properties. Under the compatibility tab, set the driver to run in compatibility with Vista sp2 and apply. Then run the setup and restart. The sound will work. Hope this help everyone having the same problem.
My System SpecsSystem Spec
25 May 2010   #9
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

Quote   Quote: Originally Posted by phat187 View Post
Hi to all

I recently installed W7 on my Dell XPS and found that my sound does not work. I have read through some forums about this problem but no luck in finding a fix. The closest I got to any sound was getting the earphones to work, but once I install another driver that also stopped working.

I have used SIGMATEL STAC 92XX C-Major HD Audio Driver aswell as the driver and utilities cd that came with the pc but still no fix to the problem.

Please see the screen shot attached, it might help out.

Thanks
I have a Dr. Appt and just heading out but will have a solution for you when I return. Same issue with my DELL XPS Gen1 laptop with the Sigmatel but have resolved it and will post the correct driver for you when I get back, not on that machine and it's not on at the moment.
My System SpecsSystem Spec
25 May 2010   #10
fishnbanjo

Vista 64 Ultimate, Windows 7 64 Ultimate, Ubuntu 9.10
 
 

I'm back. These are the drivers I believe I used and note they are for Vista 32 and 64 bit so you should uninstall any drivers you have currently for the sound card, uninstall the card. Download CCleaner and DriveSweeper and run those to clean out anything to do with Sigmatel.

Run the expansion on the downloaded DELL drivers, get them at
Drivers and Downloads

Note they will load into a DELL folder. Reboot the PC and when it comes up with new hardware found it may just tell you drivers were not loaded, just go to the Device Manager and you will see the ? in yellow, select this and tell it to update driver and select let me choose and point it to the folder where the driver is, it should then see the Stack92 Sigmatel driver and load it. This all of course would be done in compatibility mode for Vista, let me know if I can help.
My System SpecsSystem Spec
Reply

 Dell XPS M1330 - Windows 7 32bit - No Sound




Thread Tools



Similar help and support threads for2: Dell XPS M1330 - Windows 7 32bit - No Sound
Thread Forum
Solved Can't Detect Second Monitor - Dell m1330 Windows 7 64bit General Discussion
Dell XPS M1330 Speakers not working Sound & Audio
BSOD on Dell XPS M1330 -- poss. culprit Intel wifi 3945 BSOD Help and Support
Dell M1330 boot fail Graphic Cards
Cannot detect Inbuilt Creative Webcam Dell xps m1330 Hardware & Devices
Cannot detect Inbuilt Webcam Dell xps m1330 Hardware & Devices
W7 RC 7100 fresh install Dell m1330 mouse/sleep HELP! General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:08 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App