Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound problem


25 Feb 2010   #1

Windows 7 Home Premium x64
 
 
Sound problem

Hey guys, I have a question.

My sound is a bit screwed. I want to have sound from my speakers but my pc classifies my socalled "Speakers" in the Sound window, as my Logitech USB headset. My speakers themselves are the Logitech 2.1 set (black standard, that everyone has or had edition). They are supposed to be plug and play but they don't cooperate. Just no sound from the speakers, only the headset.

Link to the sound window I mentioned. There you can see it.
==> http://i294.photobucket.com/albums/m...tion/sound.jpg

Thanks for the read and possible solutions!

My System SpecsSystem Spec
.

25 Feb 2010   #2
Microsoft MVP

Win 7 Ultimate x64
 
 

Ign1tion, welcome to the forums.

Looking at that screen shot it doesn't even show that you have a sound card installed. Is there anything showing in Device Manager with a yellow triangle beside it? If your sound card is at least being detected, it should show up as "unknown multi-media device" until the drivers for it are installed.

Assuming you are using onboard sound, if it isn't showing in Device Manager the next step is to double check in the bios that it is enabled.

P.S. Filling in your system specs would help as well.
My System SpecsSystem Spec
25 Feb 2010   #3

Windows 7 Home Premium x64
 
 

No, that's the weird part of the whole problem. No yellow flags, red flags, or any kind of flag for that matter. It all works. The pc just is confused basically. He thinks that my headset are my speakers.

Ps. Specs included now.
My System SpecsSystem Spec
.


25 Feb 2010   #4
Microsoft MVP

Win 7 Ultimate x64
 
 

Quote:
The pc just is confused basically. He thinks that my headset are my speakers.
Does it still show as USB headphones when they aren't connected?

Also might be a good idea to run this,

INF Update Utility - Primarily for Intel® 5, 4, 3, 900 Series Chipsets

and make sure it has the latest motherboard drivers installed. If they aren't fully updated/installed, that would be one reason why Windows isn't seeing the sound card. Also your motherboard uses the ADI1986A chip for its onboard sound, and finding drivers for it can be fun. There is this one thread here,

No Sound on Asus A8V-XE

where someone with the same onboard sound got it working using the Vista driver that is linked to in post #4.
My System SpecsSystem Spec
25 Feb 2010   #5

Windows 7 Home Premium x64
 
 

You're my hero! Thanks a lot. It worked .

Cheers lad!
My System SpecsSystem Spec
25 Feb 2010   #6
Microsoft MVP

Win 7 Ultimate x64
 
 

You're welcome.

Just in case for anyone else in the same boat, was it the chipset driver and sound driver, or just the sound driver that got it working?
My System SpecsSystem Spec
25 Feb 2010   #7

Windows 7 Home Premium x64
 
 

I have no idea to be honest. I executed both files right after each other and restarted the pc. But my guess would be the sound driver that is used for vista as well. At least it says it has that driver now as a 3rd option, besides the USB headset and the Digital Audio (S/PDIF).
My System SpecsSystem Spec
Reply

 Sound problem




Thread Tools



Similar help and support threads for2: Sound problem
Thread Forum
Sound problem perrsists even after new sound card Sound & Audio
Sound card/sound problem questions? Hardware & Devices
Sound Problem Sound & Audio
Solved Sound problem - need to 'scan for hardware changes' to get sound Hardware & Devices
Windows Media Player Problem - Sound/skipping problem. Music, Pictures & Video
sound problem Sound & Audio
sound problem Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:39 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33