Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: ZV6000 Audio x64 solved

View Poll Results: Did this solution work for you?
Yes, without any problems! Hooray! 5 71.43%
Yes, but only after restarting and hitting F8. 1 14.29%
No, error code 10. 1 14.29%
No, some other error code (plz post) 0 0%
Voters: 7. You may not vote on this poll

01 Mar 2010   #1

Windows 7 x64 Pro Retail
 
 
ZV6000 Audio x64 solved

For those of us who have been having a major head-ache with ZV6000 after updating to retail, or those of us who never had audio working on the x64 side ever, here is the final solution (provided below with edit for ZV6000):

Download the "Conexant AC97 Audio Driver for Microsoft Windows Vista (64-bit)" from http://h20000.www2.hp.com/bizsupport/TechSupport/SoftwareDescription.jsp?lang=en&cc=US&swItem=ob-51288-1

installing it regularly didn't work but you can make a trick.

1. first, try to install it normally with the driver. it will probably fail but it will be extracted in C:\swsetup\SP35558 by default

2. open the .inf file and locate

[Conexant.NTamd64]
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD,PCI\VEN_1002&DEV_4370&SUBSYS_308B103C
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD_DF,PCI\VEN_1002&DEV_4370&SUBSYS_308E103C

3. add this line to it
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD,<x>

<x> can be found by going to the device manager, open the unrecognized audio device's property page, select "Details" tab, and select "Hardware Ids" from the Property combo. One of the listed strings should be <x>. it was the top one in my case.
In my ZV6000, <x> was PCI\VEN_1002&DEV_4370&SUBSYS_3085103C&REV_01

so it eventually looked like:
[Conexant.NTamd64]
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD,PCI\VEN_1002&DEV_4370&SUBSYS_308B103C
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD_DF,PCI\VEN_1002&DEV_4370&SUBSYS_308E103C
%*WDM_AMCAUD.DeviceDesc%=WDM_AMCAUD,PCI\VEN_1002&DEV_4370&SUBSYS_3085103C&REV_01

4. now install the driver manually through device manager. It installed as "Conexant AC-Link Audio" which i find weird since it first was listed as "Conexant Realtec AC-97".

You should now have perfect audio. Note that for those updating from the various Realtec or ATI workarounds, the mute light also finally works again

If you are having trouble installing or it doesn't work after restart, remember that you need to "Disable driver signature enforcement" during boot (F8). You can also edit the boot using EasyBCD so that it will pop-up the menu for you and all you have to do is arrow up twice and select the option.

Cheers!

My System SpecsSystem Spec
07 Mar 2010   #2

Windows 7
 
 
Worked like a charm (audio on HP ZD8000)

I tried this solution on my HP Pavilion zd8000 and it worked perfectly.

To be able to find this post through a search engine if you also have audio problems on the HP Pavilion zd8000 i'll type some keywords...

HP Pavilion audio problem solution (AC audio)
My System SpecsSystem Spec
08 Mar 2010   #3

Windows 7 x64 Pro Retail
 
 
Yey!

Quote   Quote: Originally Posted by Bart Nijs View Post
I tried this solution on my HP Pavilion zd8000 and it worked perfectly.

To be able to find this post through a search engine if you also have audio problems on the HP Pavilion zd8000 i'll type some keywords...

HP Pavilion audio problem solution (AC audio)
That's great to hear Bart Nijs!

...and thanks for the extra keywords
My System SpecsSystem Spec
.


09 Apr 2010   #4

Windows 7 32 bit
 
 

Hi

But this solution can work for my HP Pavilion zv5000 (PJ887EA#ABZ) with ATI SB200 - AC'97 Audio Controller 32bit.. ?
My System SpecsSystem Spec
10 Apr 2010   #5

Windows 7 x64 Pro Retail
 
 
Regarding 32bit

Hi Hamnare,

Actually, from what I have tried, Windows Update installed the drivers automatically when i was testing Win Vista and Win 7 32bit. The solution described here is for 64bit windows 7.

But, I assume you have already tried Windows Update

Give this file a try: Conexant AC97 Audio Driver for Microsoft Vista (32-bit) - HP Business Support Center

It might work without any modifications so try that first, i.e. just install and there's a chance it'll work automatically.

If it does NOT work, try restarting your computer and hitting F8 until you get the Windows loader options and press up key twice to select "Disable driver signature enforcement" If audio works now, that's great! However, you'll have to press F8 every time you restart your compy (unfortunately i had to live with that during beta )

Alternatively, you could simply experiment. Try the solution that i posted previously with the file i have linked on this post.

In my opinion, the solution I posted below is the best work around, as long as you have a relatively close driver to base it on. Please try the driver i linked above with the solution i provided previously and let us know what happens. Good luck

Cheers!
My System SpecsSystem Spec
17 Apr 2010   #6

Windows 7 32 bit
 
 

Hi.

Unfortunally after the Conexant AC97 Audio Driver for Microsoft Vista (32-bit) - HP Business Support Center installation, the audio card no work and i tried the F8 option but nothing.

Now try the other solution

Yeppp!
I tried to chnage the inf file how you have told and work!
Wonderful

Thank very much
My System SpecsSystem Spec
19 Apr 2010   #7

Windows 7 x64 Pro Retail
 
 
Congratulations

Quote   Quote: Originally Posted by Hamnare View Post
Hi.

Unfortunally after the Conexant AC97 Audio Driver for Microsoft Vista (32-bit) - HP Business Support Center installation, the audio card no work and i tried the F8 option but nothing.

Now try the other solution

Yeppp!
I tried to chnage the inf file how you have told and work!
Wonderful

Thank very much
That's great to hear hamnare! If you have a moment, please reflect your success on the poll posted on this thread, that way people will have a quick way of assessing the success of this solution. Thanks!
My System SpecsSystem Spec
22 Apr 2010   #8

CommonOS (Linux Distro)
 
 

Thanks, this did the trick. I have everything working on my HP zd8230us except the modem, and who uses modems these days?
My System SpecsSystem Spec
23 Apr 2010   #9

Windows 7 x64 Pro Retail
 
 
Great!!!

Quote   Quote: Originally Posted by Wreck View Post
Thanks, this did the trick. I have everything working on my HP zd8230us except the modem, and who uses modems these days?
Great to hear Wreck. And I totally agree with the modem part, I usually have it disabled in dev man anyway. But, i'm also anal retentive so i *had to* find a driver

If you are interested, there is a conexant AC97 Soft Data Fax Modem with SmartCP that will do the trick. if i'm not mistaken you can actually grab that from the conexant site itself. If you can't find it and want it, let me know and I will post it.

Be sure to use the poll so that people can quickly get info they need

Thanks!
~salaadin
My System SpecsSystem Spec
23 Apr 2010   #10

Windows 7 Home Premium
 
 

Hey salaadin19,

Nice fix you've posted, well done!

Ap
My System SpecsSystem Spec
Reply

 ZV6000 Audio x64 solved





Thread Tools



Similar help and support threads for2: ZV6000 Audio x64 solved
Thread Forum
Boot Hang Solved; separately Sleep Problem Solved Performance & Maintenance
Audio Problem solved Sound & Audio
Need some help plz... (solved) Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33