Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No Audio


04 Mar 2010   #1

Microsoft Windows 7 Ultimate
 
 
No Audio

Hi I recently upgraded from XP to Windows 7 and everything is running fine except I have no audio.
In Control Panel it is telling me - "No Audio devices are installed"
In Devise Manager under sound, video and game controllers, I have Realtek AC'97 Audio with the yellow exclamation mark on it.
When i click on the driver details I have drivers listed -



When I try to update the driver i'm told - "The best driver software for your device is already installed. Windows has determined the driver software for your device is up to date. Realtek AC'97 Audio"

System details below -
Manufacturer ECS
Product 761GX-M754
Computer Type ACPI x86-based PC (Mobile)
Operating System Microsoft Windows 7 Ultimate
CPU Type Mobile AMD Athlon XP-M, 1600 MHz (8 x 200) 2800+
Motherboard Name ECS 761GX-M754 (3 PCI, 1 PCI-E x16, 2 DDR DIMM, Audio, Video, LAN)
Motherboard Chipset SiS 761GX, AMD Hammer
Version 1.0
BIOS Type AMI (01/11/06)
Audio Adapter Analog Devices AD1888 @ SiS 7012 Audio Device

Any help will be really appreciated as this is really annoying me now.
Thanks.


My System SpecsSystem Spec
.

04 Mar 2010   #2

Windows 8 Pro
 
 

Is this a clean install of windows 7?

Try reinstalling the drivers from this site.
Realtek
My System SpecsSystem Spec
04 Mar 2010   #3

Microsoft Windows 7 Ultimate
 
 

Yes it is a clean install and I've tried that link already.
My System SpecsSystem Spec
.


04 Mar 2010   #4

Microsoft Windows 7 Ultimate
 
 

Ok - tried that link again just incase and its still the same.
Windows has determined the driver software for your device is up to date.
My System SpecsSystem Spec
04 Mar 2010   #5

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Smudge1969 View Post
Ok - tried that link again just incase and its still the same. Windows has determined the driver software for your device is up to date.
Your system specs list this as the audio device:

"Audio Adapter Analog Devices AD1888 @ SiS 7012 Audio Device"

Why are you loading in Realtek drivers?

Look here.

SiS - Welcom to Silicon Integrated Systems Corporation.

Ap
My System SpecsSystem Spec
04 Mar 2010   #6

Microsoft Windows 7 Ultimate
 
 

I was loading Realtek because thats what's listed in Device Manager.


I tried this link you provided - SiS - Welcom to Silicon Integrated Systems Corporation.
Just getting this again -
My System SpecsSystem Spec
02 Apr 2010   #7

Windows 7 Pro 64 SP1
 
 

did you ever find a fix for this?
My System SpecsSystem Spec
02 Apr 2010   #8

Win7 RTM
 
 

I had too run windows update and the proper driver was their the same problem happened too me then in control panel -> sound
select Realtek Digital Output and select it as you default device and plug you cable into the green plugin slot in the rear of the pc
My System SpecsSystem Spec
02 Apr 2010   #9

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Have you installed the motherboard chipset drivers? If not, give that a try and then Vista/Win 7 sound drivers.
My System SpecsSystem Spec
02 Apr 2010   #10

Windows 7 Ultimate 32 Bit, Windows Developer Preview, Linux Mint 9 Gnome 32 Bit
 
 

Try downloading a new Realtek Driver from here:

Realtek

Choose from the list. I suggest you choose the one listed Vista, Windows7 Driver (32/64 bits) Driver only (ZIP file). I was able to fix my audio problem by installing this driver today!!!
My System SpecsSystem Spec
Reply

 No Audio




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:22 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33