Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Right channel suddenly stopped working

10 Mar 2010   #1
hyperjase

Windows 7 Ultimate x64
 
 
Right channel suddenly stopped working

Hi all,

I'm pretty sure this is a Win 7 issue as someone else I've spoken to at work has had pretty much the identical issue as I'm having now.

I had an issue with a USB printer, I kept getting a USB Device Not Recognised error, this was on my main pc, and also 2 different laptops, I was making sure it wasn't just my pc! Eventually after I completely unplugged my printer power, it came back on and the drivers installed with no problems.

But now this has given me another issue. Straight after that began working fine again, the right channel stopped working. If you turn the speakers up you can just about hear something, but it's so faint. I have checked my balance settings and they're all aligned correctly, so that isn't an issue. I've even reset my bios settings just in case. Nothing seems to work!

Any advice or help is gratefully appreciated!

Just for info: Mobo Asus P5K-Pro with Realtek onboard sound.

Cheers,

HJ


My System SpecsSystem Spec
.

10 Mar 2010   #2
Desslok

Windows 7
 
 

Jus to check, make sure the plugs are all in tight. Especially any headphone jack type plugs, those have 3 connectors and if it is slightly popped out you can lose a channel.
My System SpecsSystem Spec
10 Mar 2010   #3
hyperjase

Windows 7 Ultimate x64
 
 

Nope, checked that a few times, that doesn't hold the answer. You can definitely hear something but it's very very faint. Just updated to the latest drivers, no joy. I tried plugging the speaker out into the black which is rear left and right, on 5.1 mode they work fine as rear left/right.

Damn annoying this!! Just debating if Windows 7 is actually worth all this hassle!

I also have issues with my shift and 1 key, meaning its hard to get a ! (exclamation mark).

HJ
My System SpecsSystem Spec
.


10 Mar 2010   #4
Desslok

Windows 7
 
 

Ah you have the realtek onboard. Which drivers are you using for it?
My System SpecsSystem Spec
10 Mar 2010   #5
hyperjase

Windows 7 Ultimate x64
 
 

The very latest from the Realtek site, R2.43 dated 2010/2/25, prior to this it was using Microsoft's own and had the same issue, although prior to the whole issue I used both MS/Realtek and had no problems!
My System SpecsSystem Spec
10 Mar 2010   #6
hyperjase

Windows 7 Ultimate x64
 
 

Something odd has happened here, just checked Device Manager and for whatever reason TWO lots of HD audio show up??


Attached Thumbnails
-hda.jpg  
My System SpecsSystem Spec
10 Mar 2010   #7
Desslok

Windows 7
 
 

If I remember correctly, there is a Realtek driver and a Realtek HD audio driver. I remember having an issue with one of them and had to manually install the other to get it working right.

Go to Asus site and pick them up there, just enter your board and OS and it should take you to the right audio drivers.

http://support.asus.com/download/Dow...Language=en-us
My System SpecsSystem Spec
10 Mar 2010   #8
Aphelion

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by hyperjase View Post
Something odd has happened here, just checked Device Manager and for whatever reason TWO lots of HD audio show up??
Delete (Uninstall) the one you have outlined in Red, reboot the machine.

Ap
My System SpecsSystem Spec
11 Mar 2010   #9
hyperjase

Windows 7 Ultimate x64
 
 

Thanks for both lots of help, although neither did any good, with the drivers from the Asus site loaded it's still the same, the second HD Audio showing keeps reinstalling but seems to be general, not any specific make. Would this be the audio on the output from the Radeon 4870 x2? That has HDMI audio out?

I can definitely hear something from the right channel but it's almost as if it's faded down to 1.

Cheers

HJ
My System SpecsSystem Spec
11 Mar 2010   #10
hyperjase

Windows 7 Ultimate x64
 
 

Ok quick update, think I've figured out what it was, there's a digital audio output (SPDIF) on the mobo, this is the screen that shows what audio outputs I have.


Attached Images
 
My System SpecsSystem Spec
Reply

 Right channel suddenly stopped working




Thread Tools





Similar help and support threads
Thread Forum
Suddenly all USB ports stopped working on win 7
That day suddenly my PC's USB ports stopped working. I tried all USB ports with deferent kinds of drives(pendirve, mobile, modem) but computer is not responding. I tried reinstalling my windows 7 but remains same. I also tried Ubuntu, Mint, Hirens Boot CD etc but no OS finds my any kind of USB...
Hardware & Devices
Dual Channel Suddenly Stopped Working, Only Single Channel Remains
Hey everyone http://m.bestofmedia.com/sfp/images/design/usr/smilies/smile.gif I got a bit of a problem here, and I'm at a loss on what to do to fix it. Some background about the situation would be a good place to start. A few days ago I came home from work and found my PC in a "lights are...
Hardware & Devices
Internet suddenly stopped working
So just to preface I'm completely new to these forums and I'm at best only an intermediate level in terms of being tech savvy so I'm hoping that someone here will be able to help. I run Windows 7 64bit and my network adapter is a 'Realtek PCIe GBE Family Controller" Never had internet...
Network & Sharing
Sound Suddenly Stopped Working
Onboard Realtek HD audio on the Asus P6T board. I noticed last night when I tried to play something the sound wasn't working anymore. It hadn't been restarted in a week, so I'm not sure what could have caused that. I have ensured playback devices are enabled and I have set both the 5.1...
Sound & Audio
onboard lan suddenly stopped working.
i don't use the lan card to connect to the internet since i have a wireless adapter. i do however use it as a network bridge for connectivity for my xbox 360. so i was playing xbox live until suddenly i got disconnected. i checked my computer to see that it said the network cable was...
Network & Sharing
IE 32 bit suddenly stopped working
My wife has Win7 on her laptop. Last night IE 32 bit was working fine. Now when she clicks on the IE icon it does nothing. If i go into the start<all programs<IE 64 bit....then IE 64 bit works. What has happened and what should I do to fix it.
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:31.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App