Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Right channel suddenly stopped working


10 Mar 2010   #1

Windows 7 Ultimate x64
 
 
Right channel suddenly stopped working

Hi all,

I'm pretty sure this is a Win 7 issue as someone else I've spoken to at work has had pretty much the identical issue as I'm having now.

I had an issue with a USB printer, I kept getting a USB Device Not Recognised error, this was on my main pc, and also 2 different laptops, I was making sure it wasn't just my pc! Eventually after I completely unplugged my printer power, it came back on and the drivers installed with no problems.

But now this has given me another issue. Straight after that began working fine again, the right channel stopped working. If you turn the speakers up you can just about hear something, but it's so faint. I have checked my balance settings and they're all aligned correctly, so that isn't an issue. I've even reset my bios settings just in case. Nothing seems to work!

Any advice or help is gratefully appreciated!

Just for info: Mobo Asus P5K-Pro with Realtek onboard sound.

Cheers,

HJ

My System SpecsSystem Spec
.

10 Mar 2010   #2

Windows 7
 
 

Jus to check, make sure the plugs are all in tight. Especially any headphone jack type plugs, those have 3 connectors and if it is slightly popped out you can lose a channel.
My System SpecsSystem Spec
10 Mar 2010   #3

Windows 7 Ultimate x64
 
 

Nope, checked that a few times, that doesn't hold the answer. You can definitely hear something but it's very very faint. Just updated to the latest drivers, no joy. I tried plugging the speaker out into the black which is rear left and right, on 5.1 mode they work fine as rear left/right.

Damn annoying this!! Just debating if Windows 7 is actually worth all this hassle!

I also have issues with my shift and 1 key, meaning its hard to get a ! (exclamation mark).

HJ
My System SpecsSystem Spec
.


10 Mar 2010   #4

Windows 7
 
 

Ah you have the realtek onboard. Which drivers are you using for it?
My System SpecsSystem Spec
10 Mar 2010   #5

Windows 7 Ultimate x64
 
 

The very latest from the Realtek site, R2.43 dated 2010/2/25, prior to this it was using Microsoft's own and had the same issue, although prior to the whole issue I used both MS/Realtek and had no problems!
My System SpecsSystem Spec
10 Mar 2010   #6

Windows 7 Ultimate x64
 
 

Something odd has happened here, just checked Device Manager and for whatever reason TWO lots of HD audio show up??


Attached Thumbnails
Right channel suddenly stopped working-hda.jpg  
My System SpecsSystem Spec
10 Mar 2010   #7

Windows 7
 
 

If I remember correctly, there is a Realtek driver and a Realtek HD audio driver. I remember having an issue with one of them and had to manually install the other to get it working right.

Go to Asus site and pick them up there, just enter your board and OS and it should take you to the right audio drivers.

http://support.asus.com/download/Dow...Language=en-us
My System SpecsSystem Spec
10 Mar 2010   #8

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by hyperjase View Post
Something odd has happened here, just checked Device Manager and for whatever reason TWO lots of HD audio show up??
Delete (Uninstall) the one you have outlined in Red, reboot the machine.

Ap
My System SpecsSystem Spec
11 Mar 2010   #9

Windows 7 Ultimate x64
 
 

Thanks for both lots of help, although neither did any good, with the drivers from the Asus site loaded it's still the same, the second HD Audio showing keeps reinstalling but seems to be general, not any specific make. Would this be the audio on the output from the Radeon 4870 x2? That has HDMI audio out?

I can definitely hear something from the right channel but it's almost as if it's faded down to 1.

Cheers

HJ
My System SpecsSystem Spec
11 Mar 2010   #10

Windows 7 Ultimate x64
 
 

Ok quick update, think I've figured out what it was, there's a digital audio output (SPDIF) on the mobo, this is the screen that shows what audio outputs I have.


Attached Images
 
My System SpecsSystem Spec
Reply

 Right channel suddenly stopped working




Thread Tools



Similar help and support threads for2: Right channel suddenly stopped working
Thread Forum
Suddenly all USB ports stopped working on win 7 Hardware & Devices
Dual Channel Suddenly Stopped Working, Only Single Channel Remains Hardware & Devices
RSS Feeds suddenly stopped working in IE9 Browsers & Mail
Sound Suddenly Stopped Working Sound & Audio
onboard lan suddenly stopped working. Network & Sharing
Aero just suddenly stopped working. General Discussion
IE 32 bit suddenly stopped working Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:23 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33