Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Conexant driver: headphones jack and speakers problem

23 Mar 2010   #1

Windows 7 Proffesional
 
 
Conexant driver: headphones jack and speakers problem

Hi I have been browsing through the forums and have not yet found a solution to this problem, but a lot of people seem to be having several similar sound problems. I hope someone can help me solve this.

I have an HP Pavilion dv2 notebook. I had windows XP and upgraded to Windows 7. Everything works wonderful, except for the audio drivers. Windows automatically downloads Conexant HD Audio Driver.

But I have two problems with the audio:

The first is that speakers work fine when you turn the notebook on but the driver fails after resuming from sleep mode. If I restart the computer the drivers load again normally.

The second is that the headphones jack is not reconized... when I plug headphones in, sound comes out from both the headphones and the speakers. This is not a configuration problem as the computer does not even show a headphone set when i try to change playback devices. Only the speakers appear in the playback devices window.

I have tried disabling the automatic driver updates from windows 7, uninstalling the drivers windows provides, and installing different drivers from conexant. However none seem to run or install properly. I have even tried to reinstall the original xp audio drivers provided by hp and that doesn't work either. I have also explored every possible audio configuration in windows 7 and still no success.

I'm running out of ideas, and after reading so many posts from different audio cards and motherboards that have similar problems, I'm not even sure if this is entirely a driver problem or if it's also related to windows 7.

If someone knows the solution to this problem or has any ideas that might work, I'll apreciate them a lot. For the moment I'm seriously considering gettin USB headphones...


My System SpecsSystem Spec
.

27 Mar 2010   #2

Windows 7 Proffesional
 
 

I have finally solved the problem!!! This is what I did:

1. Disable automatic driver installation on windows 7

2. Restart

3. Uninstall the windows 7 automatically installed drivers.

4. Restart and VERIFY that the device does NOT automatically reinstall.

5. HP site provided the original drivers and an upgrade of the original drivers for Windows XP and for my specific model.

6. I installed the original drivers for Windows Xp and installation prompted restart. (At this point the problem had not yet been solved, the headphones still didn't work)

7. I installed the upgrade drivers for Windows XP and installation prompted restart.

8. After restart all problems were solved! The headphones worked properly, the speakers were disabled when headphones were plugged in, and the drivers loaded properly after resuming from sleep mode!

I hope this works for other people who have this same issue...

****I have just noticed that the second driver's link was the same as the first driver, but I have already corrected the error and both links seem to be working.*****
My System SpecsSystem Spec
24 Apr 2010   #3

seven
 
 

Hey dude!!!!
I can't do this!!!
I have the same problem, I did all your process but I haven't succeful
Can you contact me to help me please!!!!???
Please!!!
I'm turning cracy!!!
please!!!
My System SpecsSystem Spec
.


24 Apr 2010   #4

seven
 
 

my e-mail is kagua136@msn.com
please I really need your help!!!
My System SpecsSystem Spec
25 Apr 2010   #5

Windows 7 Proffesional
 
 

Bubba136: Could you first describe your problem a little bit more? what's your computer's audio card, and model? What drivers were you installing? What did you do, and what part of the process did you get stuck on?
My System SpecsSystem Spec
25 Apr 2010   #6

seven
 
 

Hi!!!

First I must thank you for answer to my post, also I wanna say that I speack spanish so I justify my writing.

Well, my lap-top is a Hp pavilion dv2135la, I had windows Vista and upgraded to Windows 7 but I had de same problem that you has.

I had the High Definition Audio (automatic windows's driver).

This is what I did:

1. Disable automatic driver installation on windows 7

2. Restart

3. Uninstall the windows 7 automatically installed drivers.

4. Restart and VERIFY that the device does NOT automatically reinstall.

5. HP site provided the original drivers and an upgrade of the drivers for Windows XP and for my specific model.

But when I try to install the original driver, simply doesn't work!!!
I don't know what happen.

What do you think??
I really appreciate your help
My System SpecsSystem Spec
26 Apr 2010   #7

Windows 7 Proffesional
 
 

Well what I did was I first installed the Controlador de Bus Microsoft Universal Audio Architecture (UAA) para audio de alta definición from here from here. And then I installed the Controlador de Audio de alta definición Conexant from here.
I restarted the computer after both installations.

I don't know if it is necessary for you to install both drivers, but that's what worked for me. You could try installing only the last one.

Are you completely sure that the automatic driver installation is disabled?

Is there any error message when you try to install these two drivers? Does installation complete?

If you feel more comfortable speaking spanish, I speak spanish too.

***I just noticed that on my original post the two links were repeated, I have corrected the error and I have pasted the correct link for the second driver, perhaps that will fix your problem. The corrected links are also the ones I put on this post.
My System SpecsSystem Spec
26 Apr 2010   #8

seven
 
 

Pues sigo agradeciendo tu ayuda!!!
y sigo teniendo problemas!!!
ya deshabilité la instalacion automatica de drivers de windos 7
ya desinstale el High Definition Audio (que es el driver automatico de windows)
En el momento de reiniciar mi pc me avisa que se está instalando el driver automatico pero no es posible terminar la instalacion debido a problemas con la con figuracion de instalaciones (entonces creo que esta bien deshabilitada la instalacion automatica de drivers)
Ya instale el Controlador de Bus Microsoft Universal Audio Architecture (UAA), hasta este momento todo marcha bien.
Pero en el momento de instalar el ultimo driver que me das, me dice que en la instalacion del driver hubo un fallo.
Es ahi el problema
De verdad que agradesco tu ayuda!!!
My System SpecsSystem Spec
27 Apr 2010   #9

Windows 7 Proffesional
 
 

Ok me parece que quizás no hayas deshabilitado la instalación automática de drivers de windows correctamente. Cuando la deshabilitas al reiniciar no te debe salir ese mensaje de que windows esta buscando un driver para instalar, simplemente debe iniciar la computadora y ya.

El procedimiento que yo segui fue gpedit.msc --> Administrative Templates / System / Device installation / Device installation Restrictions.

En esta ventana todas las opciones deben estar en "Not configured" excepto la última que es "Prevent installation of devices not described by other policy settings" la cual debe estar en "Disabled".

Si eso no te funciona, puedes intentar con estas instrucciones, no se si son las que seguiste, pero es importante que si este desactivado por completo.

¿Que te dice el error de la instalación? Tal vez valga la pena investigar ese error porque puede que este relacionado con otra cosa.

Si aún así no funciona, te recomendaría tratar de instalar otros drivers de HP para el mismo modelo pero para otro sistema operativo, quizás los drivers de Vista funcionen mejor. Yo trate con un montón antes de localizar los que me funcionaron.
My System SpecsSystem Spec
Reply

 Conexant driver: headphones jack and speakers problem




Thread Tools



Similar help and support threads for2: Conexant driver: headphones jack and speakers problem
Thread Forum
'Speakers: Not plugged in' issue. No sound from speakers/headphones? Sound & Audio
AC Conexant audio driver problem Sound & Audio
Headphones Problem - Front Jack Sound & Audio
Headphones & Speakers problem Sound & Audio
front jack, headphones not plugged in Sound & Audio
Conexant Hi Def SmartAudio HD2 Win7 x64 Driver Problem Sound & Audio
Realtek hd problem..headphones work as speakers.. Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:32 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33