Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: hdmi and surround sound


30 Mar 2010   #1

Windows 7 Professional x64
 
 
hdmi and surround sound

I have alot of trouble with getting surround to work through hdmi. My setup is the following - the Revo 3600 is connected through hdmi to my Denon AV-Receiver which sends the sound/picture to my Sony TV also through hdmi. But I have alot of trougle to get surround to work. When I look in the control panel and sound I see the Digital sound (hdmi) and this is set as default, but I can only select 2 speakers and is states that HDCP is not supported? How do I get this to work?


My System SpecsSystem Spec
.

30 Mar 2010   #2

Windows 7 Pro
 
 

I have the exact same issue. The issue came out of the blue after I had done a reinstall.
My System SpecsSystem Spec
30 Mar 2010   #3

W7 Ulti/64, XP Pro/32
 
 

HDCP has someting to do with the vid card. The newer cards all have this.
On mine there is a jumper wire that connects vid card to the mobos onboard spdif. From there you would connect a spdif cable from mobo panel to the reciever.
I think you will have to connect headphone jack/or sound jack from puter directly to sound jack in TV input. From there use the TV's sound output and connect to receiver, using TV speakers and stereo speakers. Just because you have an HDMI out, does not necessarially mean its sending sound signal. I connect my computer from vid card to TV. Thats DVI to HDMI. No sound signal thru HDMI. I use a 2 channel phone jack from mobo to HDMI inputs, sound input. Only a stereo signal! Sounds great when I add stereo and TV speakers.
My System SpecsSystem Spec
.


31 Mar 2010   #4

Windows 7 Professional x64
 
 

Well I solved it by installing new audio and graphics drivers from nvidia then I was able to set my system to 5.1 speakers. However it messed my movied up, so now I cant play movies from WMC - it crashes after 10 seconds. And some times when I try to play a mp3 from WMC I get som strange error and have to restart WMC before I can play any sound again.
My System SpecsSystem Spec
31 Mar 2010   #5

Windows 7 Pro
 
 

I have a ATI Radeon 4550 HD graphics card with HDMI out. It does support sound, it definitely used to output in 5.1 surround just fine. I'm currently running Windows 7 and last night I installed the latest Realtek drivers, then the Realtek HDMI drivers. I now have the option when I select my playback device for 5.1 surround but when I do the test.. my receiver still only shows a signal to output in stereo at 48hz. I then installed ffdshow, and well.. nothing still. It's getting quite frustrating.
My System SpecsSystem Spec
10 May 2010   #6

Windows 7 Pro
 
 

I have the exact same graphics card and issue.. I uninstalled Windows 7 and reinstalled Windows Vista.. and my issue is still there. Did you ever get it solved? If not, can anyone else here shed some light? This is driving me nuts!
My System SpecsSystem Spec
Reply

 hdmi and surround sound




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33