Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: OpenAL


10 Sep 2009   #11
Microsoft MVP

Win 7 Ultimate x64
 
 

What games are causing the problems?

Also if the option is there in the game, are you selecting hardware or software? If it is hardware, you need to set it to software as there is no hardware (EMU10K1/2 chip) on the card. The Audigy SE is a purely software based card as far as OpenAL goes.

My System SpecsSystem Spec
.

10 Sep 2009   #12

Windows 7 Professional
 
 

The games are Bioshock as soon as you install the new patch (enabling openal eax support) and Armed Assault every version.

Now i tried some different things! After removing the soundcard, everything is working fine. So i tried again the driver from daniel K and the native windows driver, but without sucess :-/
Also some more different creative driver but nothing is working. Did there something change in windows 7 (x64) since the RC in the eax sound system? Because in the RC it was definetly working with the drivers of daniel k and later on the creative drivers.

if the game would start, i could turn of the hardware sound, but there are no options to start the game with software sound.

But this problem is known for Bioshock, but without any tips to solve this problem except to unplug the soundcard:

http://forums.steampowered.com/forum...d.php?t=912584
My System SpecsSystem Spec
10 Sep 2009   #13

Vista Ult64, Win7600
 
 

Quote   Quote: Originally Posted by kyreon View Post
Ok tried everything, but nothing worked :-/
Thanks for all the help, if you have some further workarounds please let me know!
What did Radarsync find.?
My System SpecsSystem Spec
.


10 Sep 2009   #14

Windows 7 Professional
 
 

Sorry for not replying to the radarsync topic! But all drivers where uptodate except the chipset drivers and for this i downloaded the newest drivers so that afterwards everything was uptodate.
My System SpecsSystem Spec
10 Sep 2009   #15

Vista Ult64, Win7600
 
 

Ok ,did you Shut Down the PC and reboot it since you installed all the new drivers. if not ,do it now, Please.
And please fill out your system specs.
My System SpecsSystem Spec
10 Sep 2009   #16

Windows 7 Professional
 
 

I rebooted the system after every driver install.

Quote:
And please fill out your system specs.
done.
My System SpecsSystem Spec
11 Sep 2009   #17

Vista Ult64, Win7600
 
 

Hi, is this your motherboard, and if it is make sure you download everything that you have not downloaded off this site, here is the link to all that's needed for your motherboard, if it's not your motherboard let me know.

ASUSTeK Computer Inc.-Support-

You may have to fill out the series, model, etc again at the Asus site, sorry.
My System SpecsSystem Spec
11 Sep 2009   #18

Windows 7 Professional
 
 

That is exactly the problem! I tried already downloading these drivers, but it does not work cause there is no Windows 7 support. And the Vista64 drivers did not work :-(
So i manually looked around at the intel site to download the actual drivers and also the actual realtek drivers.

If the creative soundcard is removed everything works fine and with the soundcard only openal games which try to use eax will fail.
My System SpecsSystem Spec
16 Sep 2009   #19

Windows 7 Professional
 
 

Ok thanks to all helping me with this issue!

I've figured out what the problem is. My first driver i installed was the original creative driver and exactly this was all the time the problem.
Because it was only possible to remove everything of this driver from the system AND prevent a reinstallation of the driver after reboot after using Driver Sweeper.

So just go to the hardware manager, right click on the soundcard, select uninstall and remove driver data as well.
Afterwards go to the software settings and delete all three creative programs especially the "Audigy properties for windows 7 x64" because this is an OpenAl host system which is kind of crappy.
Now there are still many install data left and if you now reboot your system the driver is installed again afterwards.
So download "Driver Sweeper" and kill all the remaining registry entries and executable.
After a reboot only the default driver of windows will automatically installed and then you can install the Daniel_K driver package.
Without this "Creative OpenAL Host Manager" everything is runnign fine with EAX and OpenAL.

I'm really disappointed that Creative re-installs after a complete de-installation of the driver software without asking the complete software again. so it is kind of hard to figure out whats the problem.
My System SpecsSystem Spec
18 Jan 2013   #20

Windows 7 Ultimate 32bit
 
 

I know this is late and sorry for bumping this thread.

kyreon, not sure if stormy13 ment for you to copy the SysWOW64 to your game folder, I think stormy13 ment for you to make a backup of the SysWOW64, and rename all the files in there the same as your game sound files that are needed, which means rename all your SysWOW64 audio files to the exact ones in your game folder, not to copy the SysWOW64 files to the game folder, because as you said, your game files are working in the game folder, it is the folder named System32 that stormy13 said was the 64 bit version if I am wrong, and your pc tries to read from that folder, you need the ones from the SysWOW64 folder renamed, not copied, stormy13 just ment to backup your SysWOW64 files, but if I am wrong I am sorry, but he said to rename them to whatever was in the game's folder, not to copy to it, although maybe he ment for you to rename and copy but I don't think that is what he ment, which is what you did and that is why it didn't work.

I am glad you fixed your problem, I don't recommend using any driver updater program, sometimes they are malicious and even trying to modify the registry to remove those from startup after checking the settings and there not being one to do so, doesn't work, because one of my brothers had the same issue and it kept coming back in the startup and it would start with windows, I helped him by uninstalling it, he did admit he no longer needed that program.
I have used them before myself, many years ago and driver update programs can mess up your pc, because they can give you updated files that are not official for your motherboard etc and that can be a problem, same issue with registry repair programs, they can modify registry and screw up your system, even setting back old settings after they were updated and it thinks the old setting was lost, but the new registry setting matches the new drivers downloaded and a registry repair will think the opposite, thus it will harm your windows registry and cause issues, it will even put back old settings that were purposly removed from uninstallers, causing build up, and it will remove others that it finds not necessary, when they might be.

That is why I will never use driver update programs when I know how to update systems easily, it's not hard, just motherboard downloads, sound card, video card, lan, drivers etc, just make sure they are officialy from the website they came from, although nvidia.com provides the best updates for your geforce video cards.

20 years experience with most microsoft windows has given me alot, self taught, with autism, but I am more of a visual learner, which means I can be bad at some other things, but really good with computers, and games, well getting rusty with games, but will always enjoy them. I would recommend upgrading your creative sound blaster sound card, creative.com, also check out the australian creative website by changing region on the creative.com site, to find out there is a sound blaster ZxR that we here in the usa don't have on creative.com, just the sound blaster z, and the ZxR is the best sound card and sound output in the world as of the time of this message.

Sorry for such a late reply!!!
I didn't mean to revive the thread, sorry for the bump!

I am only here for a short time to check out some openAL things for windows 7 to see what updates I could find and came to this thread, had to registry to reply, don't forget to check carefully on what stormy13 said, I don't think he ment to copy the files from your SysWOW64 to your game folder, I think he ment to rename the SysWOW64 instead, and back them up is what he ment by copy. But if I am wrong I am sorry. I hope that helps!

Glad to know you found updates, I used to have a sound blaster audigy, got a sound blaster X-FI Xtreme Gamer Professional Series sound card back in 2009, and the new sound card I would like to be able to buy if it was in our country! I hope somehow I can still get it from the australian creative website, which again you can go to if you go to creative.com and change region near the top to find it in the products page on the australian creative website.

Again sorry for the extremely late bump! you can close/lock this thread if you want. =)
My System SpecsSystem Spec
Reply

 OpenAL




Thread Tools



Similar help and support threads for2: OpenAL
Thread Forum
What is OpenAL doing on the list of installed programs? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:21 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33