Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: My audio doesn't work on Windows 7 64 bit !

18 Apr 2010   #1
hemingway60

Windows 7 Professional 64 bit
 
 
My audio doesn't work on Windows 7 64 bit !

Hi guys,
I just formated my PC which had Windows 7 32 bit and intsalled Windows 7 64 bit. The problem is that everything works great except my audio. I installed the latest drivers from Intel's website but to no avail. I even tried downloading it from Realtek but also it didn't work. You see I was using my SB 5.1 on 32 bit but since there aren't any drivers for it on 64 bit I had no choice but to use the intergreted audio in my motherboard. What should I do?

Thank you.


My System SpecsSystem Spec
.
18 Apr 2010   #2
Crispy

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)
 
 

Take out the "Creative Sound Blaster 5.1"and stick with the Realtek onboard card.
My System SpecsSystem Spec
18 Apr 2010   #3
not so gray matter

W7 Ult. x64 | OS X
 
 

Take out Creative Sound Blaster and stick w/ Realtek is bad advice if you're looking for sound quality.

Here are the drivers for "Creative Sound Blaster 5.1"

Win XP http://support.creative.com/download...wnloadId=10297

See below for how to install in compatibility mode, select XP in drop down.

Here are the drivers for "Creative Sound Blaster 5.1 VX"

Win 7 32-BIT http://support.creative.com/download...wnloadId=10964
Win 7 64-BIT http://support.creative.com/download...wnloadId=10964

What's the exact model of your Sound Blaster card?

By the way, Sound Blaster cards sound 400% better than Realtek, so I highly recommend either finding a way to get the SB to work or getting a new SB/Omega/M-AUDIO card. Anything but Realtek, it's horrid from any audio perspective.

If you download the XP Drivers.
Install via Compatibility Mode (Right Click Install File > Properties > Compatibility > Install in Compatibility Mode > Select XP from drop down > OK
Install the drivers

If they don't work, buy a new sound card if you can (You can get a Audigy 5.1 Card for $35) or (not recommended) stick with Realtek.
My System SpecsSystem Spec
.

18 Apr 2010   #4
hemingway60

Windows 7 Professional 64 bit
 
 

I can't buy a new card. And I don't know where to get SB 5.1 (Not live! series) drivers that work on 64 bit OS. And realtek isn't even wroking?! I have the drivers for it but windows is not detecting anything

This is my card: http://asia.creative.com/products/pr...4&listby=usage
My System SpecsSystem Spec
18 Apr 2010   #5
not so gray matter

W7 Ult. x64 | OS X
 
 

Did you try installing the SB 5.1 XP drivers in compatibility mode?

If they didn't work, then try to troubleshoot the realtek card... Go to device manager and try to find your Realtek card.

You Realtek sound card should look something like this:
-dm.png

If you find the card, you can either attempt to update the drivers via Windows, or you can go to the Realtek website and download the latest HD Audio drivers and install them via their exe file.

EDIT: Apparently some people have had success using this card w/ the Sound Blaster Live! drivers. If the installation gives you an error the first time around, tell it to reinstall and it may work.
http://social.technet.microsoft.com/...-e2e04aca203a#


My System SpecsSystem Spec
18 Apr 2010   #6
hemingway60

Windows 7 Professional 64 bit
 
 

Everytime I click your links I get redirected to the choose your product page.
My System SpecsSystem Spec
18 Apr 2010   #7
not so gray matter

W7 Ult. x64 | OS X
 
 

Quote   Quote: Originally Posted by hemingway60 View Post
Everytime I click your links I get redirected to the choose your product page.
Well then you've got to choose your product. At the main product choice screen you'll see a link at the bottom which allows you to look at more options. Find Sound Blaster 5.1 in the list to get the Win XP drivers. Find Sound Blaster 5.1 VX to get the Win 7 VX drivers. Find Sound Blaster Live! in the list to try those, apparently some have had success.
My System SpecsSystem Spec
18 Apr 2010   #8
hemingway60

Windows 7 Professional 64 bit
 
 

Bump. The XP setup couldn't detect any card and the VX and live! drivers setups just crashes everytime. I guess realtek is my only choice but I can't get the damned thing to work Its really pissing me off. What's wrong with windows 7??? I have the 64 bit driver so why won't it recognize it??
My System SpecsSystem Spec
18 Apr 2010   #9
hemingway60

Windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by notsograymatter View Post
EDIT: Apparently some people have had success using this card w/ the Sound Blaster Live! drivers. If the installation gives you an error the first time around, tell it to reinstall and it may work.
Creative SB 5.1 Windows 7 RC
Didn't work. Realtek is my only hope now but windows doesn't recognize it.
My System SpecsSystem Spec
18 Apr 2010   #10
hemingway60

Windows 7 Professional 64 bit
 
 

Thanks for your help, topic can be locked now. Turned out that on board audio was disabled. I'm really really sorry for wasting your time guys.
My System SpecsSystem Spec
Reply

 My audio doesn't work on Windows 7 64 bit !




Thread Tools





Similar help and support threads
Thread Forum
VIA Audio Stereo Mix doesn't work
Hello Guys! Please excuse my english :p For the last few days i've been trying to solve my problem, I'm trying to record Stereo Mix sound, but it just doesn't work, my motherboard is a Gigabyte GA-Z77X-UD3H. I have enabled it but when I go to settings of the Stereo Mix the volume is...
Sound & Audio
Audio doesn't work during Skype.
So I thought I'd give Skype a go last night. Called a friend and while the picture was fine he couldn't hear me. I couldn't hear him either but I'm sure that something on his side as my laptop plays music just fine. Anyone have a checklist of sorts that I can use to trouble shoot my sound/mic...
Sound & Audio
Subwoofer doesn't work windows 7, realtec audio.
I'm trying to config my sound system and sub out only works in "test" actually now it doesn't work at all! the rest of my speakers work fine for the most part. I have tried everything I can think of and this is really getting to me, I use my computer for movies, netflix, music quite often. I'm...
Sound & Audio
Case's audio panel microphone doesn't work
I have recently custom built a PC using an ASUS M5A78L-M/USB3 motherboard in a CiT 2206 MIDI Case. I have downloaded VIA drivers from the motherboard website I linked above, but uninstalled the program that came with it (It didn't manage audio very well and prevented my speakers from working :/ ...
Sound & Audio
Front Audio Doesn't work - Windows 7
Hello, I just upgraded from windows XP to Windoes 7 & installed all the latest available motherboard drivers from intel. Everything is working fine but there is no audio via my front audio jack. Even Realteck Audio Manager is even not recognizing any pluggen in jack in the front audio...
Sound & Audio
My frontal audio panel doesn't work. Drivers?
Hello! I'm spanish so my english is not perfect, I'm sorry: I have a IV880-10 (viewed in CD) AsRock motherboard, "Intel core 2 cpu" , 4coredual-VSTA. When I had winXP, the front audio panel works perfectly but now with 7057 they won't work. I had installed the last audio codecs from...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App