Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: X-FI Fata1y Pro problems please help!


19 Apr 2010   #1

Windows 7 Home premium
 
 
X-FI Fata1y Pro problems please help!

Hello,
First of all forgive me if this is an issue already tackled here on the forums. I have such a busy schedule, i don't have time to search though.I've tried searching other places but my problem seems unique.

what you need to know About my setup:
OS-Windows 7 HP 64-bit
Sound card-Creative Sound Blaster x-fi Fatal1y pro {PCI express}
\ / Connected with Optical
5.1 Home theater receiver DTS/DD


My problem-
When I do anything with sound(Play a game with Dolby digital live, Listen to an MP3 file, Watch a MP4 video, watch a youtube video)on occasion, my receiver will try to switch to linear PCM and the sound will cut out for half a second and come back in with DD or DTS (whatever encoder I select in Creative control panel).I did not have this problem at all with windows XP, Everything worked perfectly. It seems to happen most on my MP4 videos I record with my digital camera.I've contacted creative. I uninstalled all packaged software along with drivers and downloaded all windows 7 crap for this card. It still does it.

I have two playback devices-
Speakers-Default device
Spdif out
(my on board audio is disabled in bios)

If I switch default to spdif-No sound will come out and My Receiver will not get any encoder signal.

My thoughts-
1. It has something to do with sampling rates not being set properly? i've used the test and it will do 44.1 khz to 48 khz both up to 24bits.or maybe something about exclusive control?
2.Its having trouble with stereo or mono sound being encoded to Dolby digital/DTS?

I've tried everything I can think of.
Any suggestions would be greatly appreicated.
Thanks in advance.

My System SpecsSystem Spec
.

20 Apr 2010   #2

W7 Ult. x64 | OS X
 
 

Can you use Stereo sound instead of Dolby/DTS? I'd suggest that you go through the running startup programs & processes in msconfig and disable half of them. Start the computer up and if the problem still exists, try disabling the other half. My thinking being that a program interaction is causing this.
My System SpecsSystem Spec
24 Apr 2010   #3

Windows 7 Home premium
 
 
Now no sound through spdif

Now i cannot get any sound through OPTICAL at all.

I uninstalled All drivers using Driver sweeper and tried all new drivers.Nothing.
I can get sound through analog speakers with new driver though.but no OPTICAL.
I can get sound and linear PCM to display through my onboard Realtek 883 using COAX out. It also has OPTICAL and nothing comes up when its plugged in.
I Downloaded AC3 filter. Under SPDIF status it says NO status. ANd when i run the test it says no support for any sample rate.

I cannot figure this out.
Some windows 7 update that screwed this up since my clean install because even the original drivers(pre windows7) worked then?
Maybe the OPTICAL cable is broken?
Linear PCM works and the DVD player still does Dolby digital on same connector so I don;t think my Reciever/AMP is broken?

please help.
My System SpecsSystem Spec
.


Reply

 X-FI Fata1y Pro problems please help!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:55 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33