Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with Realtek AC97


30 Apr 2010   #1

Windows 7
 
 
Problem with Realtek AC97

Back when I was just using Windows Vista, my computer recognized my sound card as Realtek AC97, which is what's built into my motherboard (ASUS M3A79-T Deluxe). However, when I started using Windows 7, all that Windows would show for my sound card is "High Definition Audio Device" for some reason.

I've downloaded and attempted to install both files mentioned for Realtek cards, one of which didn't seem to do anything, the other kept giving me problems due to the driver not being signed by Microsoft, over and over, despite how many times I clicked install anyway.

I've been ignoring the problem up until now, but it's giving me problems with my front mic jack, which I've not had any reason to use until recently. Going to the recording devices page will show the rear jack working as normal, but the front panel is "currently unavailable" even though it to is shown as working normally.

I hate the thought of registering on a forum for the sake of asking a question, that may have an answer that I haven't found, but this is kind of annoying me and I'd like it to be fixed if possible.

Thanks in advance.

My System SpecsSystem Spec
.

30 Apr 2010   #2

Windows 7 Ultimate x64
 
 

Do you have the front panel HD Audio connector connected to the motherboard or the AC97 connected? Have you tried swapping connectors?
My System SpecsSystem Spec
30 Apr 2010   #3

WIN7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by Zephe View Post
Back when I was just using Windows Vista, my computer recognized my sound card as Realtek AC97, which is what's built into my motherboard (ASUS M3A79-T Deluxe). However, when I started using Windows 7, all that Windows would show for my sound card is "High Definition Audio Device" for some reason.

I've downloaded and attempted to install both files mentioned for Realtek cards, one of which didn't seem to do anything, the other kept giving me problems due to the driver not being signed by Microsoft, over and over, despite how many times I clicked install anyway.

I've been ignoring the problem up until now, but it's giving me problems with my front mic jack, which I've not had any reason to use until recently. Going to the recording devices page will show the rear jack working as normal, but the front panel is "currently unavailable" even though it to is shown as working normally.

I hate the thought of registering on a forum for the sake of asking a question, that may have an answer that I haven't found, but this is kind of annoying me and I'd like it to be fixed if possible.

Thanks in advance.
Just skimmed a review for your M/board and you have an 8 channel HD (High Definition) sound chipset built in the motherboard!

Did you connect the wrong front connector on your case lead?
There are usually two plugs/connectors HD and AC97 (for really old motherboards such as socket 7)

As mpcrsc562 clocked above!
My System SpecsSystem Spec
.


30 Apr 2010   #4

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by Zephe View Post
I've been ignoring the problem up until now, but it's giving me problems with my front mic jack, which I've not had any reason to use until recently. Going to the recording devices page will show the rear jack working as normal, but the front panel is "currently unavailable" even though it to is shown as working normally.
Thanks in advance.
I guess it might help to know what the problem is.
Not working at all?

I would suggest going to the Realtek site and d'loading the latest 2.47 driver.
It's a two step install, the first install actually deletes the old drivers, the second try installs the new drivers.

You might try right clicking on the Microsoft speaker icon in the task bar, you'll find a lot of
of options available.


http://www.realtek.com.tw/downloads/...&getdown=false

Get either the zipped or exe.

Ap
My System SpecsSystem Spec
Reply

 Problem with Realtek AC97




Thread Tools



Similar help and support threads for2: Problem with Realtek AC97
Thread Forum
Realtek ac97 Win7 Problem Sound & Audio
Boston 735 USB speakers with Realtek AC97 Sound & Audio
Realtek AC97 Drivers Not installing Drivers
realtek ac97, onboard sound Sound & Audio
Fun Realtek AC97 installation issue Sound & Audio
Realtek AC97 lacks output Sound & Audio
Can't set Quadraphonic (4) speaker with RealTek AC97 Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:19 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33