Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Onboard Sound Not Recognised

06 May 2010   #1

Windows 7 Ultra
Onboard Sound Not Recognised

I've just upgraded to Windows 7 and it's not recognising the audio jacks on the motherboard. It shows the SPDIF socket as the only sound device and when I try to install the Realtek HD driver, the installation fails with a 0012 error.
It's an Abit A-S78H motherboard.
Can anyone advise how to get it recognise the onboard 5.1 sound?

My System SpecsSystem Spec
06 May 2010   #2
not so gray matter

W7 Ult. x64 | OS X

Are you attempting to install drivers from disc or hard drive?

If you're attempting to install from disc, you may want to attempt to install them from file instead...

Download these drivers.
My System SpecsSystem Spec
06 May 2010   #3

Windows 7 Ultra

I originally tried the drivers on the motherboard disc but they were out of date so I downloaded those drivers from the Realtek site and ran them from the hard drive with the same result. I disabled and uninstalled the SPDIF device and the drivers installed properly (so I thought) but when I rebooted Windows said there was no sound device attached, then reinstalled the SPDIF device automatically- there was no sign of the Realtek software which had supposedly been successfully installed.
My System SpecsSystem Spec

06 May 2010   #4

Windows 7/10 64 bit

Did you install the motherboard chipset drivers? On many systems, the motherboard chipset drivers define the devices on the motherboard and in those cases the chipset drivers must be installed before installing device drivers or devices will not be recognized.
My System SpecsSystem Spec
06 May 2010   #5

Windows 7 Ultra

I did use the motherboard drivers disc, used the Qinstall option which appeared to complete the installation but Win 7 only recognises the SPDIF device as the only sound device present. The 5.1 HD sound system built in to the motherboard worked perfectly under XP and registered as a separate sound device.
My System SpecsSystem Spec
06 May 2010   #6
Microsoft MVP

Win 7 Ultimate x64

First double check the the onboard is enabled in the bios, and if not using it and if you haven't already disable both the onboard video and the audio for the onboard video (which uses a Realtek chip, same as the onboard audio). Can't tell you where exactly as Abit doesn't have the manual for your motherboard available, but if it is anything like my Asus board with the same 780G/SB700 chipset then the video and accompanying audio setting should be under,

Advanced->Chipset->PCI Express Configuration

Then go here,

Drivers & Support | GAME.AMD.COM

click on "Motherboard/Integrated Video Drivers" then click on "Individual Drviers (Motherboard/Chipset)". Then select your version of Windows and from there download the South Bridge Driver. After installing that then try the Realtek driver again.
My System SpecsSystem Spec

 Onboard Sound Not Recognised

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
S/PDIF Optical out - No sound from receiver (onboard and sound card)
I've got an Asus Crosshair V Formula motherboard that I couldn't get any sound on my Onkyo HT-R550 receiver via the onboard optical output (Win 7 Ultimate 64 bit OS) I was planning on getting a nicer sound card anyway, so I bought the Asus Xonar Essence ST. Installed that sound card but alas, I...
Sound & Audio
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
Realtek onboard sound. No sound
I don't know how to title this too well but yeah. I have been using a USB headset for quite some time but I recently purchased some Audio Technica ADH-700's. I've plugged them in and woolah!.. Just kidding.. No sound at all :( I have an Avermedia Live Gamer HD Capture Card and with getting it...
Sound & Audio
RealTek OnBoard Sound Issue - No Sound
Hello everyone, My audio has seem to quit on me. I updated to the newest drivers for my mobo (biostar A870U3) from their download page and now I get no sound whatsoever from my speakers. I have tried uninstalling all of the sound devices from the device manager and letting windows reinstall...
Sound & Audio
onboard sound vs. Addon sound card
What would be the advantages/disadvantages of onboard sound vs a sound card? With a sound add on card are there headers for front panels connections.? Would I see/hear a big difference in the sound?
Sound & Audio
Enabling onboard sound with a sound card
Hi, I fly MS FSX and I want to be able to chat to ATC with my headphones and then hear the engine noises coming out of my speakers and sub-woofer. I have a soundcard and my motherboard has onboard sound. I can't find the bios setting to turn it on and I can't see any hint of it anywhere on the...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:44.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App