Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sound, video and game controller missing - Now what?

06 May 2010   #1
kokosbolle

win 7 64
 
 
Sound, video and game controller missing - Now what?

Hello and thank you already if you are reading this.

My problem is that:

-I cannot find Sound, video and game controller in device manager and have no sound.

Soundcard: Realtek ALC883

Here Is what I have done:
-Installed w7 64 today, C all clean.
-Downloaded and installed realtek drivers for my motherboard MSI K9VGM-V from here:
http://www.msi.com/index.php?func=downloaddetail&type=driver&maincat_no=1&prod_no=260
MSI says they are w7 compatible. The driver installs normally.

What I get:
-Typical red cross on speakers in systemtray
- No sound, video and game controller in device manager.

What I attempted:
-Tried to disable 'azalian' (or what it was called) in BIOS which is supposedly the 'sound control'. No change in w7, -set to auto again afterwards. CMOS was flashed recently.
-Tried to install various drivers among these: r2.48 HD audio w7 64 from realtek.
-Did of course try to search for PnP in device manager many times.

What I know:
The onboard sound card worked fine before when running on a vista64 install. Everything else on the computer is running smoothly after install.

Notes:
When uninstalling prior to attempting installation of alternative drivers, I receive the message: "unable to remove files" or similar. I have searched registry for 'realtek' but only find 'history files' from winrar. ...or something like that.

What I don't know:
On the MSI driver page there is listed a '4in1' driver? Is this something I need? I don't know what it is and it only has XP64 support so I did not install it.

-Again, thanks for reading and I really appreciate all input, also suggestions for alternative drivers, but I think the missing 'SVaG' controller is the issue (?)

Cheers, Kokos.


My System SpecsSystem Spec
.

06 May 2010   #2
not so gray matter

W7 Ult. x64 | OS X
 
 

I would just install the latest Realtek driver from their website. Their drivers can be finicky at times which is why I tell everyone I know that wants decent sound to get a dedicated card made by Sound Blaster, HT | OMEGA or M-AUDIO. Even if you're buying a cheaper one ($30-40) you'll still end up with way better sound than Realtek and you'll have less problems when it comes to drivers.

Anyway, if you don't want to replace the onboard sound you can just install the latest drivers from Realtek.com.tw and hopefully that will fix your problems.

Realtek
My System SpecsSystem Spec
07 May 2010   #3
kokosbolle

win 7 64
 
 
>notsograymatter

I have tried installing 'Vista_Win7_R248_x64.exe'. That is the newest on realtek.com.tw
No changes, sound, video and game controller still missing. Ideally I would get a proper soundcard, yes. But now I just wanna make this one work.

Kokos
My System SpecsSystem Spec
.


08 May 2010   #4
kokosbolle

win 7 64
 
 

Is there no one who can help me?
My System SpecsSystem Spec
08 May 2010   #5
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

kokosbolleit could be due to incomplete Via chipset drivers included with Windows 7, and that is why nothing is showing in Device Manager with regards to audio. The one thing I found on the Via forums with regards to the chipset on your motherboard (K8M890) is that there are no Windows 7 drivers other than whatever comes with Windows itself.

One thing you can try is to go here,

VIA Drivers Download - VIA Technologies, Inc.

work your way through the drop down boxes till you get to the Vista 64 bit "VIA Hyperion Pro Driver Package". You may have to install it in Compatibility Mode,

Compatibility Mode

If they install then have a look in Device Manager and see if there is anything showing for audio, and if there is then try installing the Realtek driver.
My System SpecsSystem Spec
08 May 2010   #6
kokosbolle

win 7 64
 
 
>stormy13

Thanks for suggestion and links. The hyperion 4in1 drivers installed succesfully. There were some issue with the pci network card trying to reinstall itself on each restart that now seems to be gone.

However, the SVaG controller did not resurface, so problems remains...

Reinstalled the R2.48 realtek drivers too.

BTW, when I click the sound icon in system tray it starts searching for hardware then I get the message "Problems found : hardware change may not have been detected." Is this a common message ?


kokos
My System SpecsSystem Spec
13 May 2010   #7
kokosbolle

win 7 64
 
 
"solved"

Came over an old PCI sound card. threw it in , worked fine.
My System SpecsSystem Spec
Reply

 Sound, video and game controller missing - Now what?




Thread Tools





Similar help and support threads
Thread Forum
Missing my Sound, Video, and Game Controller
Hello, I just got the "No Audio Device is installed" message for the second time, and my Sound, Video, and Game Controller section on my Device Manager pulled a Houdini on me. I can't remember what i did last time to fix it, but I've tried everything that people have suggested on multiple threads...
Sound & Audio
Sound, Video and game Controllers in device manager is missing,
no sound,(there is a white x surrounded by red color next to volume icon) troubleshooting results in message reading "hardware changes might not have been detected". Sound, Video and game Controllers in device manager is also missing, please help ! Model L655D-S5116 (toshiba satellite) I...
Sound & Audio
No audio device output installed, no sound, video game controller...
Normally using my laptop last night. When i opened it this morning. I have no sound and the deadly X red mark on my volume on my lower right screen is present. It is obvious that this problem (no audio output device installed) is very common to many. Reading through hundreds of threads saying i...
Sound & Audio
No sound, video game controller in device manager. No audio full stop.
I was rudely interrupted during a truly hilarious episode of Curb Your Enthusiasm to the cruel sound... of silence. I know this is an old problem, I've searched high and low for a fix for hours, but none seem to pertain to my specific set of circumstances. Any help would be great. Situation...
Sound & Audio
Missing Sound Video & Game Controller in Device Manager, no sound
Hi Its bit complicated.:D I have 5 year old Compaq Pressario V3611AU notebook with AMD Atholon X2 TK-55 processor. Was using Windows XP and everything working fine. Recently I upgraded RAM to 2GB & processor was changed to AMD Turion(tm) X2 TL-60 2.00Ghz. I installed windows 7 and everything...
Sound & Audio
No output device/ no sound video game controller
Please help!!!! I have that horrible problem of" No audio output device installed" and the red x over my sound icon, which means no sound. BUT I also have another problem. Many say to fix this problem with windows 7 by going to device manager and fixing it under the catagory of sound video and...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:43.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App