Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Audigy

13 May 2010   #1
malch

Win 7 64-bit
 
 
Audigy

I have a Dell XPS 420 with Windows 7 64-bit and an Audigy 2 sound card. All was fine under Windows XP.

Under Windows 7 I get random pops/crackles from the speakers every now and again. I don't have to be playing any music, or even touching the computer. It just pops from time to time. There doesn't appear to be any periodic regularity to it. Indeed, it will sometimes go for hours without a pop. Then several pops over the next few minutes.

It's really irritating; so much so that I'm nearly ready to pull the Audigy and live with the SigmaTel or whatever sound on the motherboard.

I've tried several Creative Drivers including SBAX_PCDRV_LB_2_18_0017.exe.

All of my other drivers are up to date. I have run the DPC Latency Checker diagnostic which doesn't show any spikes over 500 microseconds (seems to run at a pretty steady 250 microseconds).

Any suggestions?


My System SpecsSystem Spec
.
13 May 2010   #2
stormy13
Microsoft MVP

Win 7 Ultimate x64
 
 

No promises but if you haven't yet I would try this modded set,

SB Audigy Series Support Pack 3.8 (04/19/2010) - Creative Labs
My System SpecsSystem Spec
13 May 2010   #3
chev65

Windows 7 Ult, Windows 8.1 Pro,
 
 

If those don't work there are some Daniel K modded Vista drivers that work perfectly well in Windows 7. These have all the extra sound options and will work with audigy2 perfectly and I have tested them with Audigy2 and Audigy 2zs. This is a torrent but someone always seems to be hosting them.

Creative Soundblaster Audigy Series Vista Drivers [by daniel k] Torrent Download - Torrent Reactor NET
My System SpecsSystem Spec
.

13 May 2010   #4
malch

Win 7 64-bit
 
 

Thanks guys,

I have just installed the Daniel K drivers. Okay so far but I think it will be a day or two before I feel sure the pops are gone for good. If that doesn't cut it, I'll try the Support Pack 3.8. And if that fails too, I'll probably toss the Audigy because life is too short...
My System SpecsSystem Spec
13 May 2010   #5
malch

Win 7 64-bit
 
 

Oh well, the pops just keep on coming...

Deleted all of the Creative apps/drivers I could find, pulled the card, enabled the on-board audio in my BIOS and all is well. Anyone wanna buy a lightly used Audigy 2 going cheap? ;-)
My System SpecsSystem Spec
Reply

 Audigy




Thread Tools





Similar help and support threads
Thread Forum
Creative Audigy 5.1
My speakers partly working.. I checked and ran Audigy test ..result below: Any Idea how to fix that please.. Thanks
Sound & Audio
Creative Audigy
Audigy SE works but only with driver from Microsoft update and it not works in TV tuner. I'm tried many vista drivers/modified divers audigy to x-fi - always BSOD ! Any ideas or skills ?
Drivers
Audigy SE and Headphones
I've been having an odd problem with my Audigy SE card and my headphones. When I was using on-board sound, there would be a "headphone" device separate from the "speakers" device. With the Audigy SE, there is only a "speakers" device. This is problematic because every program I run thinks I'm...
Sound & Audio
SB Audigy
I've installed Windows 7 and everything is working great. I've managed to install the drivers for my Creative Sound Blaster Audigy, the device is working properly, and everything seems to be working. Only one problem: No sound comes out of my speakers. I've already triple-checked, and I know...
Sound & Audio
Need Help Please Audigy
Hey Guys im new to this forum and hopefully can get some help as I have spent the last few days trying to figuer this out and no luck. I have a SB Audigy card and i have resently installed windows 7 and i have installed the drivers for the card from creative and windows update (both seem to be...
Sound & Audio
Creative Audigy help
Been trying to fix this for the past few hours. I've got a Creative SB Audigy 2 ZS card installed with the latest drivers from Creative. I'm also using Logitech Z-5500 5.1 speakers. The thing is, there's only audio out of the R and L speakers.. Normally I wouldn't care, but another issue has...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App