Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 RC and ALC889A onboard sound?

04 May 2009   #1

Windows Se7en
Windows 7 RC and ALC889A onboard sound?


I just wanted to ask if anybody solved the no sound problem with a ALC889A (or similar) on a Windows 7 install?

I already tried a lot of things.

-I have installed the Realtek High Definition Audio Driver 2.22, and some older ones.
-I have installed the Realtek AC'97 in various versions. It appears in the installed programs list, but doesn't change anything in the Hardware Manger.
-I have run the Windows Update for the Realtek driver. Now it installs the version, when there is no other. That number has been changing with the High Definition Audio Drivers.
(others were: and

Still no sound.

What can I do?

Please help! If anybody fixed this issue, please tell me how to do it.

I have a Gigabyte P35-DS3 mainboard by the way.

My System SpecsSystem Spec

06 Jun 2009   #2

Windows 7 Ultimate

I have the same problem with my software bugging when I install the driver. I have a GIGABYTE GA-P35-DS4 with.
I have tried everything, installed first rev. 2.0 then 2.1 at this page.
At first when I installed the driver, the sound worked for some days, but now no sound, which is weird. I'm not sure which one to use, because they look the same.

I can refer you to the Realtek HD no sound - Windows 7 RC x64 thread here, see if you can figure it out. If so, please write what you did to make it work
My System SpecsSystem Spec
09 Jun 2009   #3

Windows 7 Ultimate

Progressing news. As we speak, I'm sitting and hearing music on my media player using a ALC889A. Yeah I'm the same from before.
The sound only comes out from the right speaker, but better than nothing.
- What I did was to firstly uninstall the sound drivers manually(probably automated installed by windows 7)
- the computer then had to reboot
- Then I installed the latest rev. 2.1 and rebooted again.
- And voila.
The sound is okay but you can hear flickery sound in a low frequence whenever you do something on the desktop. When I watch youtube the sound scratches a lot.
The software still detects the wrong inputs I'm using:

That's all I have to offer, hope you can use it.
My System SpecsSystem Spec

10 Jun 2009   #4

Windows7 Build 7600

Download the win7 updated drivers from the realtek website instead..

Using them for my alc899a on my P35DS3P mobo...... No problems
My System SpecsSystem Spec
08 Apr 2010   #5

Windows 7 Ultimate

Tried.. didn't work. Must be a physical error or smthn
My System SpecsSystem Spec
08 Jun 2010   #6

Windows 7 64bit

I've got a very similar problem with the ALC892 onboard sound with my Asus M4A89GTD Pro. First, sound was dreadful with scratches and very muffled, now with the 2.48 (, the sound is ALMOST unnoticeable; the volume is so low and I have everything turned up to see if it was even working.
My System SpecsSystem Spec

 Windows 7 RC and ALC889A onboard sound?

Thread Tools

Similar help and support threads
Thread Forum
XPS720 Sound Failure Windows 7, onboard audio
Hi i am currently running a XPS 720 with Windows 7. I have had Windows 7 on the machine for years and only recently have experienced sound problems. Audio Does not play, or play a test tone. Audio also doesnt work with my USB Gigaware Headset(basicaly its own external soundcard). I...
Sound & Audio
Distortion sound using onboard realtek sound card on windows 7ultimate
Hello,i recently upgrade my system from xp to windows7,i use the same realtek driver and get distortions!I try severall drivers,disable all enhancements/levels on speakers properties with no result(2.1speakers-),i configure them in stereo mode,i reduce the default format to 44100 16bits(cd...
Sound & Audio
New windows 7 prem. 32 bit on new HD. No sound from onboard device.
I have a dual boot system with XP home on another hard drive and I am able to get sound from that operating system. It is VIA vt1708b chipset on an Asus m3a78 model motherboard. XP has no problem playing sound as stated but when I switch to windows 7 I get nothing. I have tried the drivers from...
Sound & Audio
No sound in windows 7, onboard soundcard.
Hi guys, I'm experiencing trouble with the sound. At the moment I cant get any sound out of my computer. I use the onboard soundcard VIAź VT1828S 8. I think there might be some driver related issues? What I've done: - Installed a fresh install of windows on different harddrive to make sure...
Sound & Audio
Realtek ALC889A no sound in windows
Hello, Win7, 64bit, realtek ALC889A integrated sound on GA-X48T-DQ6, Realtek driver r265 In the realteak audio driver manager, I can hear the test sounds. But no sound is played when surfing youtube or playing mp3 in windows media player. Please assist. Kind regards.
Sound & Audio
Low sound issues w/ Realtek HD Audio (ALC889A)
So, first of all let me state that everything else is working great. Windows7 is truly a remarkable OS. The only thing that doesn't work as it should, is the sound. I'm using Logitech's X-530 5.1 system. When compared to XP, the sound is just... Too low. I tried a couple of things, various...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 19:15.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App