Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Creative X-Fi Xtreme Audio

05 May 2009   #1
Delta1Zulu

Windows 7 RC1 Build 7100
 
 
Creative X-Fi Xtreme Audio

Does anyone know where i can download drivers for this card for the Windows 7 RC1? ive tried the Beta drivers off Creative and had no joy, the ones that came out when the "leaked" RC1 was out and im gettin majorly cheesed off.... ive got everythig else set up how i want except the fact ive no sound


My System SpecsSystem Spec
.

06 May 2009   #2
hotbowler

Windows 7 64 bit
 
 

I downloaded the Beta driver from Creative Labs for my X-Fi Xtreme Audio and have had only one problem with it. It does not recognize my CD drive. I have noticed that some default settings are set at mute and I've had to change those and the volume control is set pretty low. I went to the speaker control icon on the system tray and clicked on mixe3r to bring up the menu box to make my changes. I've also notified Creative Labs of the problem with the cd drive. Don't if this helps, just thought I would let you know of my experience with this.
My System SpecsSystem Spec
06 May 2009   #3
samu

windows
 
 

My System SpecsSystem Spec
.


06 May 2009   #4
lonzie

Windows 7 32bit
 
 

I just installed this today, I tried the vista x64 drivers as I'm on 64bit version and they failed with some weird error, so I downloaded the Win7 beta drivers and they installed first time no issues.

One issue I did have that was annoying was my sound kept going up and down and all over the place on any heavy bits, like anything bassy was messed up on my music, I checked the settings and my sound was set to 7.1 as default, I changed this to stereo and it was all good :] Enjoying my music again lol.
My System SpecsSystem Spec
06 May 2009   #5
Delta1Zulu

Windows 7 RC1 Build 7100
 
 

Well thanks for the replies everyone but still no joy... ive tried the 32bit drivers and still no sound.. ive tried Vista Drivers ive tried the Crystal modded drivers ive even tried the basic drivers and still no sound
My System SpecsSystem Spec
07 May 2009   #6
XGUNTHERC

Windows 7 Ultimate Edition x64
 
 

What driver did you try? i have the X-Fi ExtremeGamer.. it can't be much different than the extrememusic. I have the Win 7 Creative BETA drivers. the 2.18.0013 or whatever. and they work perfectly well.

On the site when your searching for your product. follow the info for the XtremeGamer, and install whatever driver it says to. and see if that works. I'm having no issues with my X-Fi.
My System SpecsSystem Spec
07 May 2009   #7
Delta1Zulu

Windows 7 RC1 Build 7100
 
 

It Dont... it says exactly what i thought it would... "Setup cannot find this product on your system blah blah blah....." cos the Xtreme Audio is just a re-branded Audigy SE chipset not a true X-Fi chipset... it explains why the X-Fi BETA drivers dont include it... and ive tried the Audigy SE drivers and they dont work....
My System SpecsSystem Spec
07 May 2009   #8
penn

7-7100
 
 

Had problems with my creative X-fi Extreme as well.

Follow the link to get the new creative beta driver for windows 7 and install it (remove old drivers first)

Creative Worldwide Support

It should do the trick
My System SpecsSystem Spec
08 May 2009   #9
Delta1Zulu

Windows 7 RC1 Build 7100
 
 

Ive tried that driver... that was the 1st one i tried...
My System SpecsSystem Spec
08 May 2009   #10
penn

7-7100
 
 

it's working fine for me - sound card was bought about 6 weeks ago - but drivers on the cd installation caused win 7 to crash - had to reinstall win 7 from an image that I made - used this new beta driver from the creative site and it's working perfect now
My System SpecsSystem Spec
Reply

 Creative X-Fi Xtreme Audio




Thread Tools





Similar help and support threads
Thread Forum
Creative X-Fi Xtreme Audio plays no sound
Hi, I installed my soundcard, everything works perfect. I installed drivers and i get no trouble at device manager. After I plug my headphones in and try to play music, i get no sound. At the sound options in windows i see the soundcard and it looks like it works, because the green bar goes up...
Sound & Audio
Creative X-fi Xtreme Audio
Bought this card today. Because it said support for vista, I thought it would work in Windows 7 as well. Installed the card and I had immediately sound. Then I went to the creative site to install the drivers because I had only control over the volume. There was no EAX, no bass control, nothing....
Sound & Audio
Sound Blaster X-Fi Xtreme Audio / Creative.com
Ok, so I read the stickied topic about the X-Fi Xtreme Audio driver, as I think this maybe a part of my computers less-than stable condition after recent Fresh Installs of Windows 7 Home Premium 64bit. I got 2 things... 1) When I install Drivers off my CD, I get a SpiRunE.dll error about a...
Sound & Audio
Creative X-Fi Xtreme Audio Driver Problems
I recently installed Windows 7 on my computer and downloaded the new .90 driver for my "Creative Sound Blaster X-Fi Xtreme Audio" PCI. I can't seem to switch between the recording device "Microphone"(front Jack) and "Line-In"(Back). Also I tried downloading the driver package that includes the...
Sound & Audio
Creative Soundblaster X-Fi Xtreme Audio
Hello. I'm running Windows 7 build 7600, and seem to have a sound card driver issue. Sound is successfully comming out, but it is screwed up, it fades in and out and has terrible quality (driver from clean install). I am using this sound card, have looked around the forum and have come across a...
Drivers
Creative X-Fi Xtreme Audio x64
Hello, my Windows 7 x64 (7100) found after a clean install new optional updates which included drivers for my soundblaster X-Fi Xtreme Audio. I also used the drivers I got with the cd and installed them on my system. Everything is working now except a few options. I get sound in 5.1, but when I...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:57.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App