Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Need help installing my sound card

26 May 2010   #1

windows 7 Home Premium 64-bit(6.1, Build 7600)
 
 
Problem Resolved! Close Thread.

PROBLEM RESOLVED! CLOSE THREAD!

Hi.
Well i decided to use my old sound card that was on my XP computer and put it into my Windows 7 computer. The problem is when i tried to install it, i get this error:

My computer detected that my sound card is a Sound Blaster X-Fi Xtreme Audio so i tried to download the most recent one that supported windows 7. I havent used this sound card in 2-3 years and i dont have the disk to do a regular installment. When i dont put this sound card into my computer, there is sound that is ATI High Definition Audio Device. When i put the sound card into my computer, there is no sound at all. Can anyone help me on installing this sound card? Once again its a Sound Blaster X-Fi Xtreme Audio (thats what my computer detected it as).

My System SpecsSystem Spec
.

26 May 2010   #2

Windows 7 Ultimate 64bit
 
 

Hiya and welcome to the forums. Have you had a looky here pal .... Creative X-Fi Xtreme Audio win7
My System SpecsSystem Spec
26 May 2010   #3

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

This Creative Worldwide Support > PCI Express X-Fi Xtreme Audio is what I see on the Creative site as the driver for your card. Is this the one you've tried?

However, when you first started Windows 7, after installing the card, did Windows find the new hardware and search for drivers? If not, that would say that the card is not being detected and probably why you are getting the error you are getting. Also check the Device Manager to see if it's been detected, and what error is shown.
My System SpecsSystem Spec
.


26 May 2010   #4

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by mienboix2 View Post
Hi.
Well i decided to use my old sound card that was on my XP computer and put it into my Windows 7 computer. The problem is when i tried to install it, i get this error:

My computer detected that my sound card is a Sound Blaster X-Fi Xtreme Audio so i tried to download the most recent one that supported windows 7. I havent used this sound card in 2-3 years and i dont have the disk to do a regular installment. When i dont put this sound card into my computer, there is sound that is ATI High Definition Audio Device. When i put the sound card into my computer, there is no sound at all. Can anyone help me on installing this sound card? Once again its a Sound Blaster X-Fi Xtreme Audio (thats what my computer detected it as).
When you installed the driver, did you install it in compatibility mode?
(right click the installer>properties>compatibility>choose OS)

Ken
My System SpecsSystem Spec
26 May 2010   #5

Windows 7 Ultimate 64 - OEM Service Pack 1
 
 

Did you turn off the on board sound card in the Bios ? I had this problem in a previous rig turned it off in the bios and it installed after that.


Steve
My System SpecsSystem Spec
26 May 2010   #6

windows 7 Home Premium 64-bit(6.1, Build 7600)
 
 

@PooMan UK: yeah. thats the driver i downloaded but it wont let me install. I keep getting the same error.
@fireberd: yeah. I also tried those. Still got the same error.
@zigzag3143: i tried to install it in compatibility mode. Still get the same error.
@steve-pressman: i just turned off the onboard sound card in the Bios, but i still get the same error.

My System SpecsSystem Spec
26 May 2010   #7

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by mienboix2 View Post
@PooMan UK: yeah. thats the driver i downloaded but it wont let me install. I keep getting the same error.
@fireberd: yeah. I also tried those. Still got the same error.
@zigzag3143: i tried to install it in compatibility mode. Still get the same error.
@steve-pressman: i just turned off the onboard sound card in the Bios, but i still get the same error.

I agree that it's probably not being detected, could well be a hardware incompatibility as in a direct address or IRQ error. At this point I don't -think- any driver will make a difference.

Is that a PCIe card? Do you have another slot to try it in?

Ap
My System SpecsSystem Spec
26 May 2010   #8

windows 7 Home Premium 64-bit(6.1, Build 7600)
 
 

Quote   Quote: Originally Posted by Aphelion View Post
Quote   Quote: Originally Posted by mienboix2 View Post
@PooMan UK: yeah. thats the driver i downloaded but it wont let me install. I keep getting the same error.
@fireberd: yeah. I also tried those. Still got the same error.
@zigzag3143: i tried to install it in compatibility mode. Still get the same error.
@steve-pressman: i just turned off the onboard sound card in the Bios, but i still get the same error.

I agree that it's probably not being detected, could well be a hardware incompatibility as in a direct address or IRQ error. At this point I don't -think- any driver will make a difference.

Is that a PCIe card? Do you have another slot to try it in?

Ap
Its a PCI card. My motherboard only has 1 slot to try it =/. How can i check to see what kind of soundcards are compatible with my motherboard?
My System SpecsSystem Spec
26 May 2010   #9

Windows 7 Home Premium
 
 

Quote   Quote: Originally Posted by mienboix2 View Post
Its a PCI card. My motherboard only has 1 slot to try it =/. How can i check to see what kind of soundcards are compatible with my motherboard?

When you first installed it, did Win-7 give any indication at all that it was recognized?

Ap

p.s. do you have any other PCI slots used by other hardware?
My System SpecsSystem Spec
26 May 2010   #10

Windows 7 Home Premium
 
 

Creative Sound Blaster X-Fi Xtreme Audio driver 1.04.0090



This is the driver you tired, correct?

Ap
My System SpecsSystem Spec
Reply

 Need help installing my sound card





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:35 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33