Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No HDMI audio out with Windows 7

13 Dec 2009   #21

Windows Se7en Ultimate Beta x86 Build 7057

Quote   Quote: Originally Posted by andrew1986 View Post
Great, after downloading the intel driver, i now have lost the picture on the input tv screen. It is fine on the laptop but bearly readable on the tv, really white..... The only plus is i now have the sound for the hdmi. I have since downloaded the graphics driver from dell, and it said that it was an older version than the one installed (the intel site one), hoping it would fix the tv problem but didn't.. this is really frustrating as i'm and too good with computers.
does anyone have any ideas????
But it WORKS! My HDMI sound is back but the screen on my laptop in barely readable which is opposite of your case. I'm getting a heavy reddish hue on my laptop screen but I don't care. I own a Inspiron 11z.

I think this all can be traced to Windows Update as I remember selecting an optional update for my Intel Graphics and Realtek Audio couple weeks back which probably borked the HDMI out. I'll play around with the graphics drivers to see if I can get the anomaly straighted out.

Much thanks to Kivanc for the tip btw.

EDIT: Got the Red glare issue fixed. Right click desktop>select graphic properties>pulls up the new Intel Graphics Control App>Goto Color Enhancement and select restore to default.

For some reason the new driver set mine to a high red gain on the built in display. Hope this helps.

My System SpecsSystem Spec
19 Dec 2009   #22

Windows 7

I'm still having this frustrating no sound problem even though I've set my HDMI playback device "Digital Output Device (S/PDIF and HDMI)" as the default device and updated everything possible. Has anyone got an idea of where to go from here?
My System SpecsSystem Spec
19 Dec 2009   #23

Windows 7 Pro & Vista Home Premium

Do you have a home theater receiver?
My System SpecsSystem Spec

19 Dec 2009   #24

Windows 7

no, just my HDTV... otherwise I'd just run sound from the laptop's 3.5mm RCA jack. But at this point, im thinking that might be the way to go.
My System SpecsSystem Spec
19 Dec 2009   #25

Windows 7

wow, the minute I say I've updated everything Intel puts out a new video driver update... or at least one that i hadn't noticed before and it's fixed the problem. sweet.
My System SpecsSystem Spec
25 Dec 2009   #26

Windows 7

To the extent this helps anyone - I also had the same problem discussed in this thread (I have a Sony Vaio VGN-FZ21Z, with a sigmatel high defintion audio and Nvidia Ge FOrce 8600M GS), and unfortunately none of the solutions worked for me.

HOWEVER... I recently tried again and this time got the HDMI audio to work... what i did was uninstall IDT audio from my list of programmes, and then restart the computer ! naturally windows reinstalled a high definition driver and this driver allows my now to hear audio through my hdmi!!!

This was purely discovered by accident (as I was going to try to stop windows installing a generic driver and try to install an updated IDT audio file - but as windows 7 was too quick for me to stop it - I stumbled accros this 'solution').

I hope this helps others with the same configuration... and Happy holidays

UPDATE 28/12/09 - With this new generic driver I now no longer can use the builtin microphone on my computer... very annoying - the webcam works (in MSn but not skype?) but the microphone doesnt work (in any programme) - any suggestion would be warmly welcomed!
My System SpecsSystem Spec
27 Dec 2009   #27

Windows 7

Woooooooo hooooooo! it's working on my VAIO too thank man!!!!!!
My System SpecsSystem Spec
28 Dec 2009   #28

Windows 7 Ultimate 64

Just an FYI, I came here looking for a solution for my Pavilion dv3t. I had Vista 64 and upgraded to Win7 64 and lost audio through HDMI. After spending a little time fumbling with stuff, I upgraded the IDT driver to latest, went to device manager, uninstalled the display driver, and when windows started back up it re-installed the drivers and now everything works fine. Worked for me, so I just thought I'd let everyone know.
My System SpecsSystem Spec
28 Dec 2009   #29

Windows 7

I have a Vaio anda now they detect the HDMI audio but no sound pass to the TV, i put a music to play and in the mixer show that the music is playing but i dont hear nothing. When i disconnect the HDMI cable the TV was still the main audio device. What i do to the cable work?
My System SpecsSystem Spec
02 Jan 2010   #30

windows 7
WORKING at last!!! woop

Ok, I never write on forums but I decided today was the day after trying hours to sort out no sound through hdmi and eventually got it sorted by piecing together bits of what people have said across various forums

The problem I was having was I could not change the hdmi output to default as it was showing it was not plugged in when it was! So, I went into device manager and in actions at the top there is an option to show hidden files (in view)

Once I had done, staying on device manager, I went down to sound and doubled clicked it which showed up a atmi audio hdmi option. Right click and then disable it. Wait a few seconds and then enable it again. Now go back into sound settings where the device is showing as not plugged in and it should now show as ready..... right click on it and set as default.... Close media player or itunes down and then reopen and play something... after a few seconds it should come through!!!!

Hope this helps... and as sad as it sounds, after trying for hours im well chuffed its working.... !
My System SpecsSystem Spec

 No HDMI audio out with Windows 7

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
No 5.1 audio configuration over HDMI Windows 7
I am currently on windows 7 with a ati radeon hd 3600 graphics/audio card. When I plug it in to my home theatre through HDMI there is only a 2.0 sound configuration, there is no 5.1. My home theatre is a sony ht-sf470. It is 3 months old and it is capable of dts-hd 5.1. How can I configure the HDMI...
Sound & Audio
Realtek HDMI Output ATI HDMI Audio -Not Plugged In-
I'm trying to hook up my TV with my computer, and for the most part it's working. The video goes through and I get how to control it and everything. The only thing not working is the sound. I'm using an HDMI to HDMI cable, and like I said the video is fine. Also, when the cable is plugged into...
Sound & Audio
HDMI audio problem when connecting LCD TV to PC via HDMI
hi all, I have my media center PC connected to a Sansung LCD TV through an HDMI cable. Everything works fine; the PC detects TV and both audio and video travel through the HDMI cable from PC to TV The problem happens when I turn the TV OFF and ON. In this case, the video is back but not the...
Sound & Audio
No HDMI Audio in Windows 7
I have been through the threads on this forum regarding Windows 7 HDMI audio problems, but they seem to involve HDMI audio devices that can't be selected. I am connected to an HDTV via HDMI, and HDMI is set as the default audio device in my PC's Sound control panel (Sound CP.jpg, attached). But I...
Sound & Audio
Windows 7 - HDMI out no audio - Intel HDMI audio
Hey everyone, I recently upgraded to Windows 7 (Build 7100) from Vista (32 bit) and am having trouble getting audio from my HDMI out port. I am using the Mobile Intel 965 Express Chipset and have upgraded to the latest available driver but still no luck. I have attached a screen shot of my...
Sound & Audio
Windows 7 64 bit HDMI Audio Problem
I have just built an i5 rig and can't get the audio to work over the HDMI, I have seen many posts but none of the solutions seem to work for me. I have: 1) Realtek ALC888 onboard audio - R240 drivers. 2) A 9600GT with DVI to HDMI adapter - 195.62 drivers. (Tried the 181 drivers as well)...
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:07.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App