Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Cm6501 Problem

23 Aug 2009   #11

Windows 7 Ultimate x64

Have the exact same problem on same MB. Nothing helped yet

My System SpecsSystem Spec
01 Sep 2009   #12

Windows Seven

Quote   Quote: Originally Posted by gridlok View Post
Get the driver from here C-Media CM6501 Like USB Audio driver software details from C Media , it works fine, Sound configuration and all. At least for me
nice virus
try to do your best next time
My System SpecsSystem Spec
29 Nov 2009   #13

Windows 7 Ultimate 64bit
same problem

Hi I've also got the Asus M2N-SLI mobo and after installing windows 7 ultimate it identified the pnp audio device. I have 5.1 surround logitech speakers so ran the mobo disk in compatibility mode to install the Cmedia CM6501 audio drivers, it installs fine and windows then detects the 5.1 channels but i cannot open the control panel and the sound all goes through one jack. Tried a few other drivers as well as the vista ones from the asus website, no fix any solutions?
My System SpecsSystem Spec

30 Nov 2009   #14

Windows 7 Ultimate x64

I bought a new sound card, extern Realtek don't know which one but everything is perfect now, even after installing fresh win7 final version
My System SpecsSystem Spec
01 Dec 2009   #15

Windows 7 Ultimate 64bit
sound card

Quote   Quote: Originally Posted by Flake View Post
I bought a new sound card, extern Realtek don't know which one but everything is perfect now, even after installing fresh win7 final version
Yeah would like to not have to buy a new sound card, hopefully proper working drivers will come out soon
My System SpecsSystem Spec
02 Dec 2009   #16

Windows 7 Ultimate x64

Quote   Quote: Originally Posted by Aeterna View Post
Yeah would like to not have to buy a new sound card, hopefully proper working drivers will come out soon
I waited for 5 months and than decide to buy it, hope you'll solve the problem without buying new s.c.

My System SpecsSystem Spec
13 Dec 2009   #17


I finally found solve for this problem (not working all of speakers on cm6501 with win 7). There are no working drivers for win 7 at all, but on my mobo (asus m2ne-sli) it's all about connecting with jumper pins 5 + 6 and 9 + 10 on motherboard's front panel audio connector. Nothing have to be installed. Do it like on screen, I guess it should work also with other motherboards.

My System SpecsSystem Spec
22 Feb 2010   #18
Computer Guy

Windows 7 64 Bit

Solution for M2N-SLI CM-6501 Skipping or Crashing

I know its been a few months since someone posted but i finally found a solution for the sound on this board.

First I upgraded the bios from Bios 201 to Bios 1002 to fix a graphics glitch then the sound issue started. No drivers worked for me. So i downgraded to bios 701. Disable Cool and Quite. This fixed the sound and video.

Should be listed as USB audio Device in device manager. If not uninstall it and reboot. If that doesn't fix it, do a driver upgrade and select manual, have disk and choose USB Audio Device.

Not finished yet if you want surround sound. Now goto control panel - Sound. Select the sound device, configure choose 7.1 surround, next till you finish.

Now your sound should be perfect.

Good Luck
My System SpecsSystem Spec
23 Feb 2010   #19

7600 х64

Thanks for the post. I solved this problem by buying a new audio card for aprox 40$.
My System SpecsSystem Spec
09 Mar 2010   #20

Windows 7 Ultimate
How I fix the CM-6501 vs Windows 7 problems...

That's it. It works as and with 5.1 sound card and speakers, bass enhacement on too. How? I'm sure that you're asking that. Let's go!

First. I downloaded the drivers that our friend Tuibm posted in his first reply. With this and the cm6501 sound configurarion on I only had stereo (front speakers) ok, even with 5.1 or 7.1 activated.

Second. I unplugged the black jack (surround speakers) from the black conector on de motherboard and plugged it back on the gray conector. In the user's guide it says that conector was to Side speakers so I tried it and works.

Third. It's only one thing more. In the Windows Sound Panel (You must see Speakers and bellow C-Media CM6501 Like Sound Device or something simillar) I set the speakers as Stereo. I don't know why but with 5.1 or 7.1 in this configurarion panel the Subwoofer didn't work but in stereo mode runs like hell.

I hope this will be helpfull to you. It's easy... If it doesn't works for you, don't give up. The Fix is always somewhere.
My System SpecsSystem Spec

 Cm6501 Problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Computer is crashing.Problem signature: Problem Event Name: BlueScreen
Hi, My computer, Dell optiplex 760 Windows 7 Professional 32-bit, is crashing. The crashes often happen when i'm playing this game, League of legends, but it also crashes at random points while on a social media or gaming websites. How to fix? Help please.
BSOD Help and Support
Blurry Text problem, EDID and registry editing problem on an AMD card.
EDIT:I have found a solution, using a DVI to HDMI cable on an amd card will fix this problem, this thread can now die, hopefully someone else will find it if they have this problem. Basically, i know what the problem is, but not how to rectify it. My tv (Sceptre X235BV-FHD, a rebranded sony...
Graphic Cards
problem event name startup repair offline - slightly different problem
Hi, Hoping somebody can help with this problem which despite trawling through these very helpful forums & tutorials, I have been unable to resolve. I have tried to include all the information possible although I am relatively new to this field so my terminology is probably not completely...
General Discussion
"A problem occurred while trying to open this message. A problem occur
HI, I'm new to the forum. When I receive mail in WLM, if I open it right away. problem. If I leave a message unopened then shut down and reboot I can't open the message. I get the error message... "A problem occurred while trying to open this message. A problem occurred. Please try...
Browsers & Mail
Laptop Windows 7 Problem/Software/Hardware? Keyboard problem
Okay, right now I'm currently trying to find out whats wrong with a keyboard that is on a laptop, after the computer starts there are some script errors, I don't know exactly what they are but I ran combo fix without safe mode and restarted the scripts went away...and it started working after...
Hardware & Devices
Problem Reports and Solutions - Change Problem Reporting Settings
How to Change "Problem Reporting Settings" in Windows 7 and Windows 8 Sending problem reports to Microsoft helps Windows 7 and Windows 8 to check and identify problems and notify you about any found solutions. This tutorial will show you how to change the Problem Reporting Settings in...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:51.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App