Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help! No sound from laptop speakers, headphones yes!


24 Jul 2010   #1

Wondows 7
 
 
Help! No sound from laptop speakers, headphones yes!

Any help is greatly appreciated. I have a sony vaio VGN-NW310f laptop with Windows 7. Up until 2 days ago everything was perfect, but suddenly I am getting no sound from the speakers. If I plug in headphones I get sound, but if I unplug headphones, nothing! Well, the computer acts like the sound is working, but I hear nothing.
Right now speaker properties shows I have "High Definition Audio Device" by Microsoft. I know that I had realtek speakers before, but in my attempt to "fix" my problem, I clicked "roll back driver" and somehow lost the realtek and now have the microsoft speakers. I guess it doesn't really matter which speakers I have as long as they work!
Any idea how to get sound again!?
Thanks

My System SpecsSystem Spec
.

24 Jul 2010   #2

Windows 7, 64 bit Home SP1, Win 8.1.1 Pro 64 bit
 
 

Use the System Restore and restore the PC back to a date when it did work correctly. System Restore can be accessed from Start/Programs/Accessories/System Tools. System Restore will not delete any user data or e-mails. As noted select a restore date that is back when it did work correctly.
My System SpecsSystem Spec
26 Jul 2010   #3

Wondows 7
 
 

Hi! I appreciate the advice...I tried the restore and I have "realtek" speakers again......but I still can't hear any sound! Any other suggestions?
Thanks
My System SpecsSystem Spec
.


26 Jul 2010   #4

Windows 7 Home Premium 64bit
 
 

Go to control panel/sound and do your set up there by selecting a default. Under Sounds tab look at bottom and see if box with Play windows startup sound is checked. Also under Communications make sure Mute all sounds is without the dot in it.
My System SpecsSystem Spec
26 Jul 2010   #5

Windows 7 Pro
 
 

There is also the possibility that the contacts for the headphones are stuck. That is a common problem.

If you can open the case you can check the contacts. You can also try wiggling the headphone jack around while plugged in to see if that releases it.
My System SpecsSystem Spec
05 Apr 2012   #6

 
 
TanXs NilsE

after hours of installing and re installing
i just "tried wiggling the headphone" and its works!!!
so i can sleep now
THANKS NilsE
My System SpecsSystem Spec
26 Jul 2013   #7

Vista Home
 
 

idop: Thank you sooooo much! I had the same EXACT problem and after trying everything along with formatting and reinstalling twice, I saw your post and thought, "What's the chance that wiggling the headphone would work for me?!?" I tried it and IT WORKED!!!! ha ha ha ha ha :::::happy dance:::: I was just about ready to give up. Thanks for taking the time to post. Thanks to you I can sleep, too! It's 1am. I'm done!!
My System SpecsSystem Spec
Reply

 Help! No sound from laptop speakers, headphones yes!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:47 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33