Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Avast acting weird!!help..

22 May 2011   #1
rigz

windows 7 32 bit build 7600
 
 
Avast acting weird!!help..

this morning a friend of mine ask for help because he..just notice their antivirus w/c was Avast (home edition)..because they dont have internet connections,was acting weird :

il upload the pictures later Please check it out..

when he checked his Avast virus chest his some unused>nvidia files sumthing like that (3dvision.exe) were put to virus chest,theme generators and even some adobe reader components (.exe)...i scanned them one by one..and the result is --no virus-- then i tried to restore it,but it cant. .and when i open its folder directory.the avast will beep and beep..and will say "virus has been detected"..more than 30 times. .

What is wrong with this ??!


My System SpecsSystem Spec
.

22 May 2011   #2
gregrocker
Microsoft MVP

 
 

Download, install, update and run a full scan with Malwarebytes.

If nothing is found, you can uninstall Avast and replace it with comparable Microsoft Security Essentials, then Run a full scan with it.
My System SpecsSystem Spec
22 May 2011   #3
rigz

windows 7 32 bit build 7600
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Download, install, update and run a full scan with Malwarebytes.

If nothing is found, you can uninstall Avast and replace it with comparable Microsoft Security Essentials, then Run a full scan with it.
but how can i restore the files back??it seems its not working..
My System SpecsSystem Spec
.


22 May 2011   #4
marsmimar

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

You might want to look through this Avast tutorial about restoring files to make sure you're following the correct steps. In the search box type in restore files from virus chest.

https://support.avast.com/index.php
My System SpecsSystem Spec
22 May 2011   #5
rigz

windows 7 32 bit build 7600
 
 

Now look at this photos!! im still going on about your suggestions :


Attached Thumbnails
Avast acting weird!!help..-weird-1.jpg   Avast acting weird!!help..-weird-2.jpg   Avast acting weird!!help..-weird-3.jpg  
My System SpecsSystem Spec
22 May 2011   #6
rigz

windows 7 32 bit build 7600
 
 

you can see those are obviously not virus..or malware,trojan,worms etc. .i scanned them all one by one..
My System SpecsSystem Spec
22 May 2011   #7
marsmimar

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Quote   Quote: Originally Posted by rigz View Post
you can see those are obviously not virus..or malware,trojan,worms etc. .i scanned them all one by one..
As gregrocker said earlier, I'd also suggest uninstalling Avast. Something might have corrupted the program. You could go into control panel > programs and features to uninstall but I prefer Revo Uninstaller. It does a better job of removing program leftovers. There are two versions of Revo - free and a 30 day trial. The free should work just fine.

Download Revo Uninstaller Freeware - Free and Full Download - Uninstall software, remove programs, solve uninstall problems

Once Avast is uninstalled I'd follow with gregrocker's additional suggestions. Install Microsoft Security Essentials so there's a security suite on the machine. Download, install, update and run Malwarebytes full scan. If no malware is detected you could either keep MSE or uninstall and go back to Avast and see if it's working correctly.
My System SpecsSystem Spec
22 May 2011   #8
Oaken

Windows 7
 
 

Respectfully, I'd suggest you will be better off using Avast's own removal tool rather than any third party solution...

aswClear
My System SpecsSystem Spec
24 May 2011   #9
damien76

Win7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by OakenG View Post
Respectfully, I'd suggest you will be better off using Avast's own removal tool rather than any third party solution...

aswClear
--also contains directions to be executed in SafeMode.

or, for better exposure post "also" in the avast forums. The developers there would love to hear this one plus you can learn more "how to use avast". As for the files(encountered some nvidia/adobe files wanting to make a hook through .dll's --which seems to be corrupted), will be lost "if" you cannot recover it properly prior uninstall. A re-installation of the main nVidia driver package and the Adobe package looms.

Your screenshots are blank except the "German Sheperd Dog Licking Screen Cleaner.exe" which is clearly a Win32FileInfector there as detected by avast. Can also be an FP. So you better check it via VT/Jotti/Filterbit.

Quote:
theme generators and even some adobe reader components (.exe)...i scanned them one by one..and the result is --no virus-- then i tried to restore it,but it cant. .and when i open its folder directory.the avast will beep and beep..and will say "virus has been detected"..more than 30 times. .
Where is the scan result or image/screenshot that says, that the files are "clean" and "--no virus--" as you state? That "German Sheperd Dog Licking Screen Cleaner.exe" may be a variant of those 2007 dog-licking-screensaver with embedded trojan affecting display functions(may have very well corrupted the nVidia driver package and Adobe Flash). Kinda/seems like rootkit behavior there and Avast is trying to block it(having a hard time also it seems). MBAM scan will be nice(as gregrocker suggested).

You can send the samples(including the "German Sheperd Dog Licking Screen Cleaner.exe" ) to avast for verification and some copies to VirusTotal/Jotti/Filterbit.

By any chance did you happen to click "Add the file to the scan exclusion list" in the pop-up for the "--no virus--" files you stated?



It's on you what steps you will take. Goodluck.
My System SpecsSystem Spec
24 May 2011   #10
Wallonn7

Windows 7 Ultimate x64 SP1
 
 

Try to repair it before uninstalling it. See below.




Attached Images
Avast acting weird!!help..-capturar.jpg 
My System SpecsSystem Spec
Reply

 Avast acting weird!!help..




Thread Tools





Similar help and support threads
Thread Forum
Nvidia GTX 660 acting weird!
PC SPECS: CORSAIR CX 600 PSU GIGABYTE GTX 660 8GB DDR3 CORSAIR RAM GIGABYTE GA-B75M-D3H REV 1.0 So guys basically what's happening is my GPU Won't "boot" and I get no signal on screen if I leave the pc off for a long time. Whenever I cold boot the pc I have to wait for around 5 minutes and...
Graphic Cards
tab key acting weird
Hello, If this is the wrong forum, please move to the appropriate one! I have Windows 7 installed, IE8, Office 2007 etc. Recently I've noticed that the tab key isn't doing what it should be doing - i.e. tabbing between cells in a form, or web page. When you press the tab key, the form...
General Discussion
Laptop Acting Weird . Please help!
Recently my 1 year old laptop started acting really weird ! At the time of Booting my laptop gives a beep..beep..beep sound I found a way to get past it by pressing ENTER key while there is underscore (_) character on screen, then directly choose "Start Windows Normally" Option My laptop...
BSOD Help and Support
Really weird acting...
Ive got a problem with my windows 7 computer. Ive had it for about six months now and its working OK. Although now all of the sudden it started like... Acting weird... I was able to click on some places but i couldnt exit my web browser, neither change to another tab as it deleted the one i...
BSOD Help and Support
PC Acting really weird.
Hi, I have some sort of problem here, and I am hoping you could help me. Sometimes, MY PC just freezes and I have to shake the Chassis to make it unfreeze again. What problem is this? Any help appreciated.
Hardware & Devices
browser acting weird
hi. i have this weird problem: the browser (ff) just jumps back on the startup page no matter what im doing. and another browser just starts without any action i take. even if no any browser in use. me playing and suddenly firefox just going to run. any suggestion what happening?
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:09.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App