Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Security Essentials Install error 0x80070643


23 Aug 2011   #1
Benjiken

Windows 7 Home Premium 64bit
 
 
Security Essentials Install error 0x80070643

Error code 0x80070643 comes up whenever I try installing Microsoft Security Essentials. I had Security Essentials installed earlier but after I used the .net cleanup tool (since I had a problem with .net) it shut down and wouldn't start back up again, so I uninstalled it.

I have also tried installing AVG Internet Security but it comes up with AVG error 0xC0070643 with error message: General internal error.

I think my computer had .net framework 3.5.1 installed before but it won't install either. I got .net framework 4 to install but it didn't help and wouldn't uninstall or repair and the updates wouldn't install for it either (windows update error 66A and 643).

Please help me


My System SpecsSystem Spec
23 Aug 2011   #2
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

It appears that remnants of the first Essentials is still present. Try downloading ccleaner, run it, boot and then try to install again.
http://www.piriform.com/CCLEANER
If that does not work, with system restore, go back to before the uninstall. Then download revo and uninstall. Then try to install again.
System Restore
My System SpecsSystem Spec
23 Aug 2011   #3
Benjiken

Windows 7 Home Premium 64bit
 
 

The ccleaner didn't pick up anything.
I can't go back before I uninstalled it because the restore was too old and dissapeared.
My System SpecsSystem Spec
24 Aug 2011   #4
Corrine

Windows 7 & Windows Vista Ultimate
 
 

Hi, Benjiken. Welcome to Seven Forums.

MSE is one of the programs that requires .NET Framework to work. Unfortunately, there are times when .NET can be problematic. Since Error code 643 generally means that the update failed, let's start with the easy route with a Microsoft Fix it solution and see if that solves the problem.

Go to You receive error 0x80070643, error code 0x643 or updates may be re-offered when you try to install .NET Framework updates when using Windows Update or Microsoft Updates and scroll down the page to Method 1, Microsoft Fix it 50123. Follow the instructions there. If not requested to do so after running Microsoft Fix it 50123, restart your computer.

Following that, check that Windows updates. Install any .NET Framework updates separately from any other offered updates and restart the computer again.

Edit Note: If you receive error messages, please note carefully what they are and provide that information in your next reply.
My System SpecsSystem Spec
26 Aug 2011   #5
Benjiken

Windows 7 Home Premium 64bit
 
 

I tried that and then I tried reinstalling .NET framework 3.5 with service pack 1 and .NET framework 4 client profile which were both installed before. So .NET 3.5.1 seemed to install ok but when I installed .NET 4 it crashed about halfway though with a "fatal error during installation.

I attached a summary of what the log said.


Attached Thumbnails
-net4_log.jpg  
My System SpecsSystem Spec
27 Aug 2011   #6
Corrine

Windows 7 & Windows Vista Ultimate
 
 

Darn! I just managed to lose the reply it took me some time to construct for you, Benjiken. Guess I need to start over. Solving .NET Framework issues can be a real hassle.

First, clean Temp Files. In order to be thorough, I suggest using the following tool:

Download TFC to your desktop
  • Open the file and close any other windows.
  • It will close all programs itself when run, make sure to let it run uninterrupted.
  • Click the Start button to begin the process. The program should not take long to finish its job
  • Once its finished it should reboot your machine, if not, do this yourself to ensure a complete clean


Next, download the standalone installer for .NET Framework 4.0 from Download Details - Microsoft Download Center - Microsoft .NET Framework 4 (Standalone Installer)

Right-click the downloaded installer and "Run as Administrator".

~~~~~~~~~~~~~~~~~~~~~~~~

If the above does not work, it is time to follow the suggestions provided by MSFT Aaron Stebner. Note that many of the linked articles have old dates. Aaron has updated them regularly though, including information for .NET Framework 4.

I suggest starting with the .NET Framework Setup Verification Tool User's Guide - Aaron Stebner's WebLog - Site Home - MSDN Blogs, using the command line switch: netfx_setupverifier.exe /q:a /c:"setupverifier.exe /a"

From there, if the Troubleshooting Guide doesn't help, see Updated: what to do if other .NET Framework setup troubleshooting steps do not help - Aaron Stebner's WebLog - Site Home - MSDN Blogs.

If you need to reinstall .NET Framework, see Mailbag: Should I re-install the versions of the .NET Framework in a specific order? - Aaron Stebner's WebLog - Site Home - MSDN Blogs.

Please let us know how you make out.
My System SpecsSystem Spec
30 Aug 2011   #7
Benjiken

Windows 7 Home Premium 64bit
 
 

Where am I supposed to type in the command line switch: netfx_setupverifier.exe /q:a /c:"setupverifier.exe /a"

I tried it in the command line but it just said:
Quote:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Benji>netfx_setupverifier.exe /q:a /c:"setupverifier.exe /a"
'netfx_setupverifier.exe' is not recognized as an internal or external command,
operable program or batch file.

C:\Users\Benji>
My System SpecsSystem Spec
30 Aug 2011   #8
Corrine

Windows 7 & Windows Vista Ultimate
 
 

Hi, Benjiken.

You need to run the cmd prompt as Administrator. Click the start Orb and type cmd. When the search show cmd, right-click cmd and select "run as Administrator. Approve the UAC prompt.
My System SpecsSystem Spec
12 Oct 2011   #9
Benjiken

Windows 7 Home Premium 64bit
 
 

My system works now!
This is how I did it.

I kind of gave up on fixing my system for a while then I tried what this tread said
windows installer service could not be accessed

It didn't work but then I decided to compare the registry key msiserver to the one on my netbook.

All I had to do to get installers such as Java or AVG anti-virus working again was to edit the "ImagePath" within msiserver.

I changed it from reading C:\Windows\SysWOW64\msiexec.exe /V to reading C:\Windows\System32\msiexec.exe /V

msi.exec.exe didn't exist in the sysWOW64 folder but it did in the System32 folder like my notebook.
My System SpecsSystem Spec
12 Oct 2011   #10
Corrine

Windows 7 & Windows Vista Ultimate
 
 

Hi, Benjiken.

Thanks for getting back to us with your solution. I'll request the Moderators to mark your topic solved.
My System SpecsSystem Spec
Reply

 Security Essentials Install error 0x80070643




Thread Tools



Similar help and support threads for2: Security Essentials Install error 0x80070643
Thread Forum
Cannot install IE10 on Windows 7 64 bit. Error Code 0x80070643 Windows Updates & Activation
IE10 fails to install, error 0x80070643 Windows Updates & Activation
Error 0x80070643 Service pack 1 install failure Windows Updates & Activation
Microsoft Security Essentials Error Code 0x80070643 Software
Solved Cannot install Security Essentials - error 656 System Security
MS Security Essential Install error 0x80070643 Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:28 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App