Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows Firewall will not start

28 Oct 2011   #1

Windows 7 Home Premium 64bit
 
 
Windows Firewall will not start

(Windows 7 Home Premium 64bit)

I have literally tried everything. Including the various Fixit's and nothing seems to work.

Infact, one of the Fixit's, namely one that has 'malware' in the title (something like... MicrosoftFixit.malware.Run or something to that effect, it was downloaded from the Microsoft site), had an option to fix the firewall as well as fix group policies. Because of the group policy "fix", it pretty much destroyed my computer by making me unable to start up most files by giving me a "data of this type is not supported" error on nearly every single file I was trying to run. exe's, .reg's, etc. Only thing I was pretty much able to run was Firefox and that was it.

I also tried two others that were also supposed to try and fix the firewall and no luck. After that one Fixit destroyed everything, I am no longer using them for anything. So please don't direct me to them as none of them is fixing my specific firewall issue and instead, makes things worse.

Luckily, I already had the Administrator account enabled so I booted up into it to try and bypass that specific error. Tried to install a gaming-relating program called "Raptr", and it ran into that same error. I gave in and did a system restore to the earliest point I had (I only have around.. 10 entries saved or so in it at a time, I don't know how to increase that if it's even possible) and that error is now gone and my normal user account is back to normal.

However, I still can not run Windows Firewall and I have done everything including double checking services that it requires, virus and malware scans (I run Malwarebytes and Avast) and nothing has popped up. I need the firewall running in order to install Rosetta Stone, and it was that program that made me realize that the firewall was disabled, and I don't know how long it's been disabled nor do I have a system restore point early enough to see when it was enabled in the first place.

I have done various registry "fixes" and rebooted for settings to take effect, and nothing has worked (and yes, I did export the file before messing with settings to put everything back to how it was before I started playing with it). I don't have discs to reinstall Windows either (and due to financial reasons, I don't even have the money to buy any as everything goes to bills, and before anyone asks, this computer was a gift, not out of my own pocket).

I have also ran sfc /scannow and it checked out fine and did not encounter any problems. I ran it around 4 different times, and each result was the same. The message I get is "Windows Resource Protection did not find any integrity violations".

The Windows Firewall Authorization Driver is also running and set to "Demand". Windows Defender is also up and running and has had no problems with running as far as I know.

I have googled everywhere and have not found a working fix, nor does the various Fixit programs do any good for my case. I no longer have any trust in them because of the hell I went through with not being able to run any files, so I refuse to use them from now on (never even fixed my firewall issue anyways...)

Providing images to all the various firewall-related bits.


When I click the button, all I get is a spinning blue circle and it stops eventually, and nothing happens.


If I click on turn on now, it gives me the error to the right. If I choose to turn on manually, it just sends me back to what I have in the first image posted.


This is when I try to start the service...


This as well...

I have provided as much information as I could possibly muster, as I am desperate to try and get this problem fixed. So hopefully someone can help with the information I've been able to gather....


edit: Looked in the event viewer and this is what I get:

Audit Failure: The Windows Firewall service was unable to retrieve the security policy from the local storage. Windows Firewall will continue to enforce the current policy.

Error Code: 2147942413


Audit Failure: Windows Firewall was unable to parse the new security policy. Windows Firewall will continue to enforce the current policy.

Error Code: 2147942413


Audit Success: The Windows Firewall service was stopped.

All in order from the earliest entry.

My System SpecsSystem Spec
.

28 Oct 2011   #2

Windows 7 Home Premium x64 SP1
 
 

Hi and welcome to the forums! I'm sorry you're having problems and I know how frustrating they can be. While I don't have an exact fix for you, I have read some very positive reviews regarding the following tool. It has a "repair firewall" option in the custom list, and might very well be worth a try. Good luck!

|MG| Tweaking.com - Windows Repair 1.4.3 Download
My System SpecsSystem Spec
29 Oct 2011   #3

Windows 7 Home Premium 64bit
 
 

I wish it worked.... it was one of the options I've already tried. :/

There just has to be a way to fix this without requiring a clean install with a disc that isn't in my posession. Seems like I can fix nearly everything but any firewall issues. Back when a roommate started to have a folder glitch on her Vista (kept opening every folder in a seperate window despite having settings to tell it not to), it took me 2 months to find an exact fix, but I fixed it. The cause? Installing IE8... removed it, did a command line thing, and the problem was fixed.

But when it comes to the Firewalls... it's almost like you're forced to do a clean install to get it back in working order. So frustrating...
My System SpecsSystem Spec
.


29 Oct 2011   #4

Windows 7 HP / Ultimate x64
 
 

Have you tried running System File Checker using your Windows 7 install disc?

It's worth a shot.
My System SpecsSystem Spec
29 Oct 2011   #5

Windows 7 Home Premium 64bit
 
 

I don't have a disc. I already stated that in my post. My computer never came with any discs.

If someone wants to give me $100 (or however much it costs now for Windows 7 Home Premium 64bit) to buy an installation disc, I'd be happy to get one! But until then... no can do. :/
My System SpecsSystem Spec
29 Oct 2011   #6

Windows 7 Home Premium x64 SP1
 
 

Not a fix, but have you thought about installing a free 3rd party firewall like Comodo to see if it will install and work correctly?
My System SpecsSystem Spec
29 Oct 2011   #7

Windows 7 Home Premium 64bit
 
 

Sadly, I already have it installed. Rosetta Stone requires the Windows Firewall because it uses a netsh script towards the end of installation to add an exception to the firewall. And without Windows Firewall, it just rolls back the installation and gives you an error that it can't install. It's a pretty stupid thing, really.

The error I get is "A program run as part of the setup did not finish as expected" and this is what I get in the Event Viewer:

"Action FE_Add_V3_Inbound, location: C:\Windows\SysWOW64\, command: "C:\Windows\SysWOW64\netsh.exe" advfirewall firewall add rule name="Rosetta Stone Version 3 Application" dir=in program="C:\Program Files (x86)\Rosetta Stone\Rosetta Stone Version 3\RosettaStoneVersion3.exe" action=allow"

I'm desperate to get this firewall running, because without it, I can't install this program that apparently requires it. Poor design on their part... but it'd be nice if the firewall would cooperate to whatever fixes are out there. :/
My System SpecsSystem Spec
29 Oct 2011   #8
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

My System SpecsSystem Spec
29 Oct 2011   #9

Windows 7 Home Premium 64bit
 
 

If only that article was a little more descriptive and easier to understand. That's where I found out about the driver and double checked that it was running and set to demand and all.

But, in the one paragraph:

"If it does not help then run Group Policy Result Tool to check if there is a firewall policy blocking it. Type gpresult -z in Search Bar, rt click on the result and run it as Administrator. Check under Resultant Set Of Policies For Computer, esp under Security Options."

How they did it was wrong (or at least it was for me), as it wouldn't run that way. It had to be typed in cmd.exe after running that as admin. However, I don't know what I'm supposed to be looking for in there exactly. Or what I'm supposed to do if something pops up or how to fix it. I have a small learning disability so unless it's explained in further details, I can't do much.

All I get with running that is "INFO: The user does not have RSOP data."

What should I do? Like I said, the article doesn't really delve much into things...
My System SpecsSystem Spec
29 Oct 2011   #10
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

When you bought your computer, did it come with McAfee or Norton/Symantec already on it?
Did you uninstall the original Anti-virus?
My System SpecsSystem Spec
Reply

 Windows Firewall will not start





Thread Tools



Similar help and support threads for2: Windows Firewall will not start
Thread Forum
Solved Unable to start Windows Firewall System Security
Can't start Windows Firewall service. System Security
Windows Firewall will not start at all. System Security
Solved Windows Firewall service won't start System Security
Solved Windows 7 firewall service will not start. Event ID 7024 Network & Sharing
Cannot start windows firewall service System Security
Cannot Start Windows 7 Firewall (Challenging) System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:22 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33