Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: device manager menu opens an closes constantly

18 Dec 2011   #1
normansoifer

Windows 7 Home Premium (x64)
 
 
device manager menu opens an closes constantly

device manager menu opens an closes constantly.

windows 7 64bit


My System SpecsSystem Spec
.
19 Dec 2011   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Welcome to Seven Forums normansoifer. More info please. You start the PC, and it works fine except the device manager opens then closes, and this repeats? Does this happen randomly, or it opens, closes, opens, closes over and over repeatedly?

Do you have a restore point from before this began? I'd start there. If no help, boot to safe mode and see if it occurs there. A Guy
My System SpecsSystem Spec
29 Dec 2011   #3
normansoifer

Windows 7 Home Premium (x64)
 
 

Hello Guy,



Thank you for your advice. Let me tell you the whole story.



I couldn't view and download photos from a SanDisk memory card using a SanDisk ImageMate card reader as I usually do. I opened the device manager and the menu opened and closed continuously, blinking about every second nonstop. I found nothing with Malwarebites, and also found no Rootkits. A 2.5 hr long search by Avast Antivirus turned up some trojan horses that I think are copies of the same viruses . HTML:Iframe - ov (trj) Threat severity High and C:\AppData\Local\Windows\...\wbk XXXX.tmp where XXXX = four different letters or numbers for each copy. The trojans were placed in the chest. But the device manager menu just kept on blinkeng. I consulted Seven Forums and got your advice.



I don't have a restore point from before this began.



I booted to safe mode as you suggested and the problem continued. I started disconnecting devices and when I removed the SanDisk ImageMate memory card from the card reader, the menu starting blinking slower, closing for about a half second every 10 seconds. When I removed the SanDisk ImageMate card reader, the menu stopped blinking and stayed open as it should whether or not I was in safe mode. I tested the card reader and card on a different computer and the photos could be displayed and downloaded normally. The card and card reader evidently are working OK. Also the card displays the photo normally in my camera.

I don't see any other problems except I can't use the card and card reader on my computer. I think I may be able to download the pictures directly from the camera with an USB cable. What do you recommend I do?



Norman
My System SpecsSystem Spec
.

Reply

 device manager menu opens an closes constantly




Thread Tools




Similar help and support threads
Thread Forum
Device manager suddenly scanning for new devices constantly
Last night, device manager started scanning for new devices constantly on a random time interval. I looked at all the error logs available but there was nothing reported (no hardware error, no disconnect, no application error, etc.). No device appears in error and every time DM tries to update, the...
General Discussion
Internet Explorer opens and closes in 1s
My IE does not run at all. I have tried 3 times uninstalling and re-installing both from windows add on components and by downloading the setup file from microsoft file, however the problem persists. Also downloaded some ie fix tools (Repair Internet Explorer & one found here...
Browsers & Mail
IE 11 opens with blank screen, after a few seconds closes
When I click on the Internet Explorer button a blank screen appears with the blue revolving circle in it and after a few seconds the blank window closes. I am connected to the network as I am still receiving mail. Does anyone have any ideas as to why IE is not working?
Browsers & Mail
Microsoft Security Essentials Closes as soon it opens...
When I try to run Microsoft Security Essentials it opens but close instantly after. I have that little white flag with a red X on the bottom right of my screen. It says that I have to turn on Windows Security center service, but when I try to do so by clicking on the message, a window appears...
System Security
IE9 opens for a split second, then immediately closes.
Thought this would be a good place to ask this...if not, feel free to point me in the right direction. I've had this problem ever since the first betas, thinking that it would eventually work or "be fixed"--but even the release candidate and now the final has the same issue. When I install...
Browsers & Mail
Everything opens, closes and minimises in slow-motion!
FIXED
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App