Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Path to .exe is not a valid Windows application (worm virus??)

17 Jul 2012   #1
ascomputers

Windows 7 Professional / Windows 8 Pro
 
 
Path to .exe is not a valid Windows application (worm virus??)

Received a laptop the other day with the following error

Path to .exe is not a valid Windows application - error message.

All files seem to have disappeared (showing in remove programs but not under start folder) and i cannot run any programs. I've even tried running regedit to have a look at the registry thinking that it may be a worm thats causing the problem but again i get the error message.

Can anyone advise on how i go about getting an anti-virus and malwarebytes to run on the system (tried connecting through a USB but with no luck).

All help is greatly appreciated.

details.
samsung laptop
windows 7 (64bit)

thanks
andrew


My System SpecsSystem Spec
.

17 Jul 2012   #2
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Can you browse files in explorer?
Rightclick on exe file and select "open"
Same for bat files
Same for cmd files

Post results
My System SpecsSystem Spec
17 Jul 2012   #3
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Can you start Elevated Command Prompt ?
And run regedit for example for there?
My System SpecsSystem Spec
.


17 Jul 2012   #4
ascomputers

Windows 7 Professional / Windows 8 Pro
 
 

hi Kaktussoft. Unable to run explorer. unable to run elevated command prompt

:-(
My System SpecsSystem Spec
17 Jul 2012   #5
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

My System SpecsSystem Spec
17 Jul 2012   #6
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by ascomputers View Post
hi Kaktussoft. Unable to run explorer. unable to run elevated command prompt

:-(
explorer is running, otherwise you don't see desktop.

No icons on desktop? Is there anything you can start?
My System SpecsSystem Spec
17 Jul 2012   #7
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

winflag+e starts explorer? If so, browse to txt, xls or doc file. Doubleclik on them. notepad, word, excel opens?
My System SpecsSystem Spec
17 Jul 2012   #8
ascomputers

Windows 7 Professional / Windows 8 Pro
 
 

desktop icons are present but nothing under start/programs.

run icon showing under accessories but again still get error message when i try to run regedit or autoexec.bat
My System SpecsSystem Spec
17 Jul 2012   #9
ascomputers

Windows 7 Professional / Windows 8 Pro
 
 

nothing runs apps wise. i just keep getting the Path to .exe is not a valid which would suggest that the registry has been changed.
My System SpecsSystem Spec
17 Jul 2012   #10
C-11

Windows 7 Professional SP1 64-bit
 
 

Copy below and paste in Notepad and save as FixExe.reg
Code:
Windows Registry Editor Version 5.00

[-HKEY_CURRENT_USER\Software\Classes\.exe\shell\open\command]

[-HKEY_CURRENT_USER\Software\Classes\secfile\shell\open\command]

[-HKEY_CLASSES_ROOT\.exe\shell\open\command]

[HKEY_CLASSES_ROOT\.exe]
@="exefile"
"Content Type"="application/x-msdownload"

[-HKEY_CLASSES_ROOT\secfile]
Right click on FixExe.reg and Merge.

Then try to open Malwarebytes, update it an scan.
===========
How to restore Start menu and files hidden/deleted by a virus - Smartest Computing
My System SpecsSystem Spec
Reply

 Path to .exe is not a valid Windows application (worm virus??)




Thread Tools





Similar help and support threads
Thread Forum
directory path in application save not found in windows explorer
I have an application that has a default path for config files, if you go to save or load a config file it comes up with it by default. However, I can't find it just showing in a win explorer directory tree or win explorer searching for it!!!! how could this happen? how can I find the real file...
General Discussion
I think I have a virus or a worm in my system
I am lately getting a lot of "Undelivered Mail Returned to Sender" from the Mail Delivery System and in the same email "Why is this message in Spam? It seems to be a fake "bounce" reply to a message that you didn't actually send." I am also been bombarded by a bunch of unwanted popups again. ...
Browsers & Mail
Avoiding '<application name> is not a valid Win32 application' error.
OK, this is admittedly a strange one... I have used an old (probably a 16-bit) application as my time synchronizer this I've used for quite some time. Its name is TimeRC, and is a great synchronizer as it tracks moon phases along with the time (from selectable, multiple potential time servers)....
General Discussion
WebDAV / Add a network location / path not valid error
Hi, I can connect to my WebDAV folder on my online server by BitKinex for example, but when I want to add a Network Location to the explorer it fails with the error message that the path is not valid ... but it is valid though. http://files.2he.com/uploads2/Capture.JPG Any help solving this...
Network & Sharing
Recovering from a virus or worm
Ok so I think I may have had a zombie computer virus or worm or something, more info on that here http://www.sevenforums.com/system-security/89259-i-think-i-may-have-worm-virus.html and I had to do a custom install to get my computer back to normal, but when I did the custom install I didn't format...
BSOD Help and Support
I Think I May Have A Worm or Virus
Hey I've been getting ICMP flood errors lately, and now today hardly any of the services on my machine work like Windows Audio and I can't enable the audio services, etc... And the services keep getting disabled like security center and stuff. And I can only choose Windows Classic and the High...
System Security

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App