Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't Install Firewall Error:1601

17 Dec 2013   #1

Windows 7 Home Premium 32bit
 
 
Can't Install Firewall Error:1601

Hey guys. To give you some history, I had a dual boot with Linux. I forgot to change the MRB and after restarting, ended up having to fix that manually.

Then my license for Zone Alarm expired and I don't have the money for that so went with Comodo. I Un-installed Zone Alarm and tried to install Comodo. Then I kept getting an error message: "Error 1601: The Windows Installer Service can't be accessed. This could happen if it is corrupt or wasn't properly installed. Please check your files and try again."

So I checked the file (msiexec.exe), it was there. Went into Regedit and made sure the file path was right. Then I re-registered the file. Still the same error. So I thought perhaps the firewall that I was trying to install was either incompatible or just bad. So I messed with some compatibility options for the program and after no luck with any of them, deleted it.

Then I tried to install Outpost. This time instead of getting a 1601 error, it tells me in can't install the Microsoft C++ visual run-time libraries.

So this is my problem. I CAN un-install stuff. I haven't tried to install anything else just yet, but I CAN'T install any firewalls at the moment.

And before anyone suggests it, yes, I already downloaded and ran Microsofts fix-it tool for installing / un-installing problems. That had no effect at all. I also tried doing the big disk check (5 steps not 3) and got nothing. I ran sfc /scannow. Nothing. And as I said before, I already ran the cmd and fixed the msiexec.exe file. I am now out of options and have no clue where to go from here but I need a firewall!!!

Help Please!

Chef Chris


My System SpecsSystem Spec
.

17 Dec 2013   #2

Windows 7 ultimate x64
 
 

Hey, Welcome to Sevenforums.

The error messages usually appear after failed installation of MSI Package or Disabled "Windows Installer" service. Here are some suggestions:
1. Try to re-register related files
a. On the "Start" menu, click "Run:.
b. In the "Open" box, type "msiexec /unreg", and then press ENTER.
c. On the "Start" menu, click "Run".
d. In the "Open" box, type "msiexec /regserver", and then press ENTER.

Or you can get Windows installer from here
My System SpecsSystem Spec
19 Dec 2013   #3

Windows 7 Home Premium 32bit
 
 

So I tried that and it did nothing. Still have the same problem. Before I did this though, I ended up having another problem. Norton stopped working as well. But the error message I get with Norton is "MSVBVM60.Dell file is missing or corrupt. Check the file location and try again." Not sure if this needs its own post or not. The file is there but when I went to go replace it with the original copy of the file, it told me that the system32 folder needed permission to replace the old one. I pushed ok and it gave me the same message. I'm the only user and am listed as system admin. This whole situation is very aggravating.
My System SpecsSystem Spec
.


19 Dec 2013   #4

Windows 7 ultimate x64
 
 

Here are the steps to modify ownership and permissions of folders and files:
1. Right-click the file or folder, click Properties, and then click the Security tab.
2. Click Advanced, and then click the Owner tab.
3. Click Edit, and then do one of the following:
To change the owner to a user or group that is not listed, click Other users and groups and, in Enter the object name to select (examples), type the name of the user or group, and then click OK.
To change the owner to a user or group that is listed, in the Change owner to box, click the new owner.
4. If you want to take ownership of the contents of the folder, select the Replace owner on sub containers and objects check box.
5. Click OK, and then click Yes when you receive the following message:
You do not have permission to read the contents of directory folder name. Do you want to replace the directory permissions with permissions granting you Full Control?
All permissions will be replaced if you click Yes.

Note folder name is the name of the folder that you want to take ownership of.
6. Click OK, and then reapply the permissions and security settings that you want for the folder and its contents.
My System SpecsSystem Spec
19 Dec 2013   #5

Windows 7 Home Premium 32bit
 
 

Thanks archer. I was able to replace the dll file and I got Norton working again. Still having an issue with the msiexec exe file tho. And its all programs I can't install not just the firewall. When I tried to install adobe acrobat, I got a message that the file was too large for the destination file system and I know for a fact I have enough room on there. Still got the same error for Comoros which reads: error 1601. The windows installer service could not be accessed. This can occur if the windows installer is not correctly installed.
My System SpecsSystem Spec
19 Dec 2013   #6

Windows 7 Home Premium 32bit
 
 

Another possibly related thing.. is it possible that for some reason its recognizing my 20gig partition as the main disc and could that be affecting all of this?
My System SpecsSystem Spec
19 Dec 2013   #7

Windows 7 Home Premium 32bit
 
 

Here's more info. Tried to install Microsoft security essentials cause at this point I figure something is better than nothing. Got an error on that too. This time a windows error. 0x8004ff01
My System SpecsSystem Spec
19 Dec 2013   #8

Windows 7 ultimate x64
 
 

Again, this error is due to Windows installer not functioning. Did you update Windows Installer? I provided the link is post # 2

Do a selective startup.

for that. Got to run, type msconfig

On the General tab, click Selective Startup, and then clear the Load Startup Items check box.

On the Services tab, select the Hide All Microsoft Services check box, and then clear all the check boxes for the services that remain in the list.

Click OK, and then click Restart to restart the computer.
Try to install Microsoft Security Essentials again.
My System SpecsSystem Spec
20 Dec 2013   #9

Windows 7 Home Premium 32bit
 
 

So I went to the link, again, thinking I missed something the first time. But I did not. The link you gave me is for the redistributable of version 4.5, an older version than what was originally released with my OS (Win 7 Home). I tried (and failed of course) to download and install the older version. So I am back to square one. Then I putzed through the Microsoft website and found their fix it tool. I downloaded it and cant run it. A cmd prompt window pops up and goes away quicker than I can read the whole thing. But after doing it a few times in a row, I got this: "Program is too big to fit in memory." I had almost 700Mb of memory at the time so I'm really not sure what the hell is going on with that. I did a memory test and it turned up no problems. I also checked my task manager and aside from the normal things running, nothing out of order. I also tried this using msconfig to start up without all the other stuff running and got the same thing.
I am about to start pulling my hair out. None of this would have happened had I just kept up with ZoneAlarm and paid the extra bucks. I say this because it wasn't until I uninstalled it that all this started to happen.
My System SpecsSystem Spec
20 Dec 2013   #10

Windows 7 ultimate x64
 
 

For "too big file in memory. This can be caused by an executable injector like virut, which corrupts the file and when removed causes problems like this. have you recently had a virus problem?

this can also be caused by some rogue anti virus applications.

one way to test is to create a new text file. rename the file from (for example) test.txt to test.exe and then try to run it. if the system tells you it is too big to fit into memory, you are in big trouble. if it tells you it is not a valid win32 application, there may be some recourse.
My System SpecsSystem Spec
Reply

 Can't Install Firewall Error:1601




Thread Tools



Similar help and support threads for2: Can't Install Firewall Error:1601
Thread Forum
Windows Installer error 1601 and 1607! Software
Solved Private Firewall install BSOD System Security
Solved Can i install Comodo firewall if.... System Security
Error Codes When Trying To Install MSE and Win7 Firewall System Security
cant install the best firewall ;/ Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33