Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Access to Hard Drive is Denied


25 Oct 2009   #1
Canowyrms

Windows 7 Ultimate x86 OEM
 
 
Access to Hard Drive is Denied

Hi guys, let me first introduce myself as Canowyrms. Im of course new to the community, but not so new to the computer world. I have been working with computers for about five or so years now. I am quite experienced, but there is always something new to learn with technology now-a-days.

I am having a problem with accessing one of my hard drives. Now I know that this has been posted on the forum before, but this is the second installation of Win7 that I have done. I installed an RC version and this issue occurred, which is why I switched back to XP. Now that Win7 has actually been released, I decided to give the full release a try and see how that worked.

Well, the issue has happened again. Every time I try to access my 500GB Seagate (yeah, seagate...) drive, I get an error saying Access is Denied. The funny thing about that, is the fact that in Windows XP, a Slax LiveCD, a Backtrack 3 LiveCD, and any other operating system in general, I can access the drive with absolutely NO problems, without even having to take ownership. That brings me to my next point. I have gone into Administrator tools and looked in the Disk Management section. The drive is listed as operating, healthy, active, etc. If I right click that drive, I can view its properties perfectly fine (whereas if I right click and go into properties in the "Computer" screen, I get NO data.). I have even gone as far as to changing the "Owner" of the drive to my user account, with full access priveliges and whatnot. That did not work.

I have, in desperation, changed the SATA connection on the motherboard. I have 4 ports, and 3 of them are being used at any given time in terms of hard drives, so I changed which one the hard drive is plugged into. That did not help. Even further in desperation, I rigged myself what you could call an external device. I had an old external enclosure that I no longer had need for, so I even plugged the hard drive into that, and nothing changed.

I have just completed an Anti-Virus scan using Comodo Internet Security, and nothing turned up. Not on any one of my drives (excluding key generators that ALL anti-virus programs lable as malware.).

Like I said, I have tried many alternatives, I have tried changing the ownership of the drive, I have tried different connections, I have tried everything I can think of and I have no access to it. That drive is something that I NEED access to as it contains vital data from back-ups of my important files. Also as I said, this is a recurring issue, and I can not come to a conclusion as to why this is happening.

Please let me know if there is anything else I can try. Thank you in advance for taking your time and reading this through.

-Canowyrms


My System SpecsSystem Spec
25 Oct 2009   #2
Uber Philf

W7 RTM Ultimate x64
 
 

Hello and welcome to the forums.

I'm not sure, seing as your experienced with computers, but have you had a look at the jumpers on the drives to make sure they are set correctly?
My System SpecsSystem Spec
25 Oct 2009   #3
Canowyrms

Windows 7 Ultimate x86 OEM
 
 

Well like I said, it has worked with each and every other OS I have tried running perfectly with absolutely no issues.
If I can find any extra jumpers sitting around I will power down and give it a try. I dont think any of my 3 SATA drives have the jumpers.

Edit:
Alright, I rediscovered that SATA drives use jumpers to limit their bandwidth.
I also finished doing some cable routing for the hell of it.
My System SpecsSystem Spec
25 Oct 2009   #4
Uber Philf

W7 RTM Ultimate x64
 
 

Hmm, ok, just the thought that could be the problem, ive always had problems with drive access when the jumpers are set incorrectly. It is a little odd that it works with other operating systems.
My System SpecsSystem Spec
25 Oct 2009   #5
Canowyrms

Windows 7 Ultimate x86 OEM
 
 

Well I just came to rediscover that SATA drives only use jumpers to limit their bandwidth. No jumpers are on any of my SATA drives.

Any other solutions to try?
My System SpecsSystem Spec
25 Oct 2009   #6
torrentg

7600.20510 x86
 
 

Since you are trying anything, perhaps assign it a different drive letter in disk management. Then try to access as normal.

Whatever drive letter you are using after, try this from command prompt:

chkdsk /f C:

Where C is the drive letter assigned.

Worst case scenario if that doesn't work: Access the drive with another OS. Copy whatever you need from it to another place. Then low level format the drive. It should work as a new HDD after.

http://www.ariolic.com/activesmart/l...el-format.html
My System SpecsSystem Spec
25 Oct 2009   #7
Canowyrms

Windows 7 Ultimate x86 OEM
 
 

I actually did try assigning the drive a different drive letter. I forgot to mention that, but thanks for that anyway.
What purpose would running checkdisk be if I already know that my drive is in perfect working condition?
My System SpecsSystem Spec
25 Oct 2009   #8
torrentg

7600.20510 x86
 
 

Since you can't access anything, perhaps it's not in perfect working condition?

There's no harm in running the command and then you could be sure that Win 7 itself doesn't find any errors.

That would be enough for me to call it a day, copy what I need off it, and low level it if it doesn't.

Edit: Another thought came to mind. Is this an NTFS formatted drive?
Anyway, you can try taking ownership like this. Elevated command prompt. takeown /f C:
Of course change C to whatever drive letter it is.
When you try to access data normally under Windows Explorer, are there any errors or just shows up as empty drive in Win 7?
My System SpecsSystem Spec
26 Oct 2009   #9
Canowyrms

Windows 7 Ultimate x86 OEM
 
 

It is, because I was using this drive not even 24 hours ago. I formatted my 160gb drive to put Seven on it, coming from XP. I will give it a try though.
I would assume I just open up cmd.exe and type in the command you listed?

Yes, all of my drives are formatted with the NTFS file system.

Edit:
Also, I mentioned above that this same issue occurred in the RC release I tried out.

Edit 2:
I tried the command prompt alternative. It says it was successful, but still denies me access when I try going to it through Windows Explorer. In the "Computer" window, it shows that a drive is connected, but absolutely no information on it. When I right click and go into properties it says I am using 0 bytes of 0 bytes.

Edit 3:
I ran the chkdsk command and everything came up clean.
My System SpecsSystem Spec
26 Oct 2009   #10
Canowyrms

Windows 7 Ultimate x86 OEM
 
 

Sorry for the double post.
I am currently *trying* to do the low level format. I just spent the last few hours backing the drive up. Since I cant access the drive through Seven, its giving me a Format Error for every single offset, and it can not be stopped until it "finishes"

I still dont see how this will let me access the drive in Seven though..
My System SpecsSystem Spec
Reply

 Access to Hard Drive is Denied




Thread Tools



Similar help and support threads for2: Access to Hard Drive is Denied
Thread Forum
Solved Access Denied To My External Hard Drive Why ??? Hardware & Devices
External Hard Drive (F is not accessable Access is denied) General Discussion
hard drive "access denied" General Discussion
Access Denied and Can't Take Ownership on Network Hard Drive General Discussion
Denied Access to D:\ drive General Discussion
Access Denied To C: Drive Network & Sharing
Access Denied to Windows Drive. General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App