Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Advanced SystemCare by Iobit(?)`

21 Jul 2014   #1
babboo

Windows 7 Home premium 64 bit
 
 
Advanced SystemCare by Iobit(?)`

hello all, I was just wondering if anybody here has used it, i installed on other pc,but dont want to commit to full network without some references, I did see a endorsement by PC mag there but could be Photo Shopped too lol.Just wondering about any reviewers here


My System SpecsSystem Spec
.
21 Jul 2014   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I have seen enough on this form to recommend not using it.
Many that have used it had to do Clean Installs to rid of it and it's ability to call home to China.
I personally don't recommend anything from IObit.

Hang around their will be more members give opinions.

Some sites will recommend anything they get paid to recommend.
My System SpecsSystem Spec
21 Jul 2014   #3
babboo

Windows 7 Home premium 64 bit
 
 

good enuf for me > uninstall thx :P
My System SpecsSystem Spec
.

21 Jul 2014   #4
Yard Dog

Win 7 Home Premium SP1 32 bit
 
 

Yes. and a few years ago, Iobit was caught stealing the database of Malwarebytes Antimalware .. and a big issue ensued over that . I refuse to use anything made by IOBIT
My System SpecsSystem Spec
Reply

 Advanced SystemCare by Iobit(?)`




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
After Advanced SystemCare 6 Windows doesnot suspend
Hi I just run Advanced SystemCare 6 to optimize my computer and after restart, I check that my computer doesnot suspend :huh: I checked suspend setting and they are as before. When I go to START >> Suspend it tries to suspend and go back to login screen.... Any idea how can I reset these...
General Discussion
BSOD after using Advanced SystemCare Free (Unmountable_Boot_Volume)
Wont boot into safe mode or original windows OS disc (which worked previously). I'm Using UBCD, never had a hard disk problem, never had memory problems. Disk is accessible using G-parted and all files are still there. The only thing i have noticed once the error started is that the label on my...
BSOD Help and Support
Advanced SystemCare and 64 bit W7 Ultimate
Hello to all, I have read several thread that discuss the need and possible destruction by the use of registry cleaners. CCleaner seems to be tops with those that believe it is acceptable. What is the belief about the above commercial program. It is quite a bit more intense than CCleaner,...
Software
Advanced SystemCare Help
not sure if i post this here but i downloaded Advanced SystemCare and installed it. The program is working but its missing the icon so on the taskbar it shows a windows file icon instead of the Advanced SystemCare icon. i checked properties and clicked change icon but the icon shows there. anyone...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App