Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Preventing the Microsoft Antimalware Service to start automatically

23 Oct 2014   #1
balubeto

Windows 7
 
 
Preventing the Microsoft Antimalware Service to start automatically

Hi

From the Command Prompt, what would be the proper procedure to prevent the Microsoft Antimalware Service (the latest version) to start automatically during startup of Windows 7 SP1?

Thanks

Bye


My System SpecsSystem Spec
.
23 Oct 2014   #2
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi and welcome to SevenForums,
Do you have MSE Microsoft security essentials installed ?
Or is this related to windows defender ?
Which security suite do you use ?
Filling in your system spec's page would help :/
Cheers.
My System SpecsSystem Spec
23 Oct 2014   #3
balubeto

Windows 7
 
 

Quote   Quote: Originally Posted by ThrashZone View Post
Hi and welcome to SevenForums,
Do you have MSE Microsoft security essentials installed ?
Or is this related to windows defender ?
Which security suite do you use ?
Filling in your system spec's page would help :/
Cheers.
I turned off Windows Defender and Windows Firewall and I have no antivirus installed.

I installed the latest version of MSE but I would like to start it manually. So, how do I do this?

Thanks

Bye
My System SpecsSystem Spec
.

23 Oct 2014   #4
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Why do you want to start it manually?
My System SpecsSystem Spec
24 Oct 2014   #5
balubeto

Windows 7
 
 

Quote   Quote: Originally Posted by Jacee View Post
Why do you want to start it manually?
Because I do not want any antivirus from starting automatically.

So, how do I do this?

Thanks

Bye
My System SpecsSystem Spec
24 Oct 2014   #6
balubeto

Windows 7
 
 

Hi

How do I disable the latest version of Microsoft Security Essentials on startup of Windows 7 SP1?

Thanks

Bye
My System SpecsSystem Spec
26 Oct 2014   #7
balubeto

Windows 7
 
 

To try to disable MSE when Windows starts, I created this bat file:

Code:
@echo off
taskkill /im msseces.exe /f /t
taskkill /im MsMpEng.exe /f /t
net stop MsMpSvc
sc config "MsMpSvc" start= disabled
Next, I created a scheduled task

Code:
<?xml version="1.0" encoding="UTF-16"?>
<Task version="1.3" xmlns="http://schemas.microsoft.com/windows/2004/02/mit/task">
  <RegistrationInfo>
    <Date>2014-10-26T11:08:46.4219135</Date>
    <Author>Pippo\Balubeto</Author>
  </RegistrationInfo>
  <Triggers>
    <BootTrigger>
      <Enabled>true</Enabled>
    </BootTrigger>
  </Triggers>
  <Principals>
    <Principal id="Author">
      <UserId>S-1-5-18</UserId>
      <RunLevel>HighestAvailable</RunLevel>
    </Principal>
  </Principals>
  <Settings>
    <MultipleInstancesPolicy>IgnoreNew</MultipleInstancesPolicy>
    <DisallowStartIfOnBatteries>false</DisallowStartIfOnBatteries>
    <StopIfGoingOnBatteries>true</StopIfGoingOnBatteries>
    <AllowHardTerminate>true</AllowHardTerminate>
    <StartWhenAvailable>false</StartWhenAvailable>
    <RunOnlyIfNetworkAvailable>false</RunOnlyIfNetworkAvailable>
    <IdleSettings>
      <StopOnIdleEnd>true</StopOnIdleEnd>
      <RestartOnIdle>false</RestartOnIdle>
    </IdleSettings>
    <AllowStartOnDemand>true</AllowStartOnDemand>
    <Enabled>true</Enabled>
    <Hidden>false</Hidden>
    <RunOnlyIfIdle>false</RunOnlyIfIdle>
    <DisallowStartOnRemoteAppSession>false</DisallowStartOnRemoteAppSession>
    <UseUnifiedSchedulingEngine>false</UseUnifiedSchedulingEngine>
    <WakeToRun>false</WakeToRun>
    <ExecutionTimeLimit>P3D</ExecutionTimeLimit>
    <Priority>7</Priority>
  </Settings>
  <Actions Context="Author">
    <Exec>
      <Command>D:\Users\Public\Documents\balubeto\MSE_disabled.bat</Command>
    </Exec>
  </Actions>
</Task>
so that it goes running with the System's rights when the system starts up.

When, however, I rebooted the system, the MSE service is still active. How come?

Where did I do wrong?

Thanks

Bye
My System SpecsSystem Spec
26 Oct 2014   #8
Alejandro85

Windows 7 Ultimate x64
 
 

You may try disabling the real-time scanning if you really want to disable it from startup and re-enabling it when you want it to run, but disabling again before shutdown.

You can't simply disable the antivirus killing its processes because antiviruses use a kernel-mode driver, which Windows don't provides an interface for disabling (you can do it with third party software however). This driver is also responsible for preventing you from killing its user-mode processes as you want.

What I don't really get is the reason for doing all this.
My System SpecsSystem Spec
26 Oct 2014   #9
marsmimar

Microsoft Community Contributor Award Recipient

 
 

Same here. I don't understand why you wouldn't want your AV to run at boot. You're leaving your computer completely open to malware. IMHO
My System SpecsSystem Spec
26 Oct 2014   #10
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I keep checking in on this thread and I'm still wondering why one would want to do such a thing.
Just a guess but it might be interfering with a torrent program.
My System SpecsSystem Spec
Reply

 Preventing the Microsoft Antimalware Service to start automatically




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Microsoft Antimalware Error
I get this error in the event logs every time I boot, cold or warm. Can anyone help interpret? No other obvious problems, except MSE seems to take a while to come all the way up.... the icon in notifications changing from "red" error to "green" ok check mark. Tried re-installing MSE, no help. ...
System Security
how to start a service automatically on windows 7 Logoff then Logon
Hi all, I have created a service for my application, which is running on Windows7 and windows xp. Problem:- When ever I logoff my system and Logon again the service is automatic starting in windows XP but it is not automatically start on windows 7.What it's root cause.I am not getting...
Software
Antimalware Service Executable: hogging my resources at startup
Well, the thread says it all. Upon loging into Windows (either after powering on the PC or just using a restart), I can clearly see that the Gadgets take a long time to display on the desktop, even though, of course, the sidebar.exe process is loaded immediately. About a minute or two into the...
System Security
WLAN Autoconfig Service won't start automatically
I wiped the stupid Windows 7 Starter that came with my netbook and installed Windows 7 Professional and ever since the WLAN Autoconfig Service refuses to start on boot despite it being set to Automatic. It also won't start manually either through "services.msc" or "net start". The only way I can...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:59.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App