Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Back to Avast...? MSE issues

31 Mar 2015   #11
jonnyhillow

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Imo and from my experience on this site there is no question in my mind that Seven forums recommends MSE more than any other anti virus by far .

Years ago when i thought i maybe having issues i was ALWAYS told to scrap the AV i had and install MSE which was annoying because after doing so the issues i was having was proven to not have anything to do with the AV .

The people that would do that i don't see at Seven forums anymore , the current group are excellent helpers.

Nothing wrong with MSE at all but if your a high risk user i would choose another security option , just my opinion of course , if your a knowledgeable surfer then MSE and something like Mbam is plenty.


My System SpecsSystem Spec
.
31 Mar 2015   #12
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Just to be clear,
MSE would be best if used with mbam Premium
If mbam Premium wasn't there I doubt MSE would be used for myself anyway

After Panda's computer bricking update "which was my second choice" I have to reevaluate my 2nd recommend
My System SpecsSystem Spec
Reply

 Back to Avast...? MSE issues




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
I uninstalled Windows 8 back to Windows 7 on a New Laptop Issues
Yes I did it. I bought a new laptop from Best Buy and had the W7 Disk and it worked. The only problem I am having is in Device Manager, "Unknown device" The USB Ports? The right USB port works well, but the 2 on the left do not work. I tried everything. Does anyone know how I can get them to work...
General Discussion
Hard Drive and Back Up issues
SO my computer was running slow and then i closed it and when I went to open and start up my computer and these screens popped up: . so then i finally tried to fix it and it i got it to go to The Hp Recovery Manager and i tried to back up my files but it kept saying that it was an error. but...
BSOD Help and Support
Back/Forward button theming issues & an Aero Peek question
Hello. I've been trying to replace the back/forward buttons in explorer, both by using pre-made DLL's and/or apply the theming myself using ResHack and using same procedure that's described in a tutorial i found here. The main problem with this is that every "Open file/folder" dialog will...
Customization
Bitlocker Issues - Gimme back my space!
Hey guys, So I recently had to give my laptop in for repairs, and before I did so, I had encrypted one work partition using Bitlocker (Win 7 Ultimate x64). Unfortunately for me, those idiots formatted my system and installed Vista on it (came with the laptop). When I got it back, I saw that my...
System Security
Can I use Avast with Norton 2010?Is Avast is light AV?
I m using Norton 2010 but thinking to take Extra security. So should i use Avast with it or MSE ???? Which one will be lighter & better ???????
System Security
Software Issues Caused Me To Roll Back
After using an RC of Windows 7 Business and loving it I have had to re-install Vista (UGH!). I use a program from Webex called QB Remote Access for remote access to Quickbooks and they haven't been able to make it 7 compatible...yet. Hopefully by the 23rd of October they will because Windows 7 is...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App