Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Opinions on Mbam's Anti Exploit program.

02 Apr 2015   #41
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by Golden View Post
Thanks David!

Looks like it wants me to buy a licence to activate it for Comodo Dragon ....or mayb its already activated? Whats the padlocks meaning?

Mmm....I think its already active? The GUI is a bit confusing....too many activate buttons.

Attachment 354848
Open the MBAE General tab and look at the "Shielded Applications" count.
Open and close the Comodo Dragon browser, and see if the count changes.
Right now I only have IE, and the count changes when i open and close it...MBAE seems to show it's protected...when i have IE open

Yea, the Activate buttons should state what they are for, such as "Activate License" and "Activate Shield" ... I won't comment on the GUI ...

Opinions on Mbam's Anti Exploit program.-mbae_settings_04.png




My System SpecsSystem Spec
.
02 Apr 2015   #42
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

Quote   Quote: Originally Posted by Lady Fitzgerald View Post
Curious. I can right click, left click, and wheel click on it and it just sets there and laughs at me.
I have no idea what "it" is, but I assume you refer to the Shields > Activate button?
The behavior appears to have been changed between version 1.05 and version 1.06, as explained HERE.
Without knowing what version you are running and/or a screen shot, I cannot say for sure what you are seeing.

And please see this earlier reply and this other one.

Under 1.05, the Shields > Activate button *is* grayed out on my boxes under Win7/64.
Under 1.06, the Shields > Activate button is enabled (on DavidE's Win10 TP box), but clicking on the button to activate a Premium shield while running the Free version will generate a dialog asking you to purchase the Premium version.

That seems to be the expected, new behavior in version 1.06 Free.

Sorry, but that's the best I can try to explain.

If you were to post your inquiry HERE, I'm certain that the MBAE Product Manager would be able to definitively and promptly answer your question.

Thank you,
My System SpecsSystem Spec
02 Apr 2015   #43
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by Lady Fitzgerald View Post
Quote   Quote: Originally Posted by DavidE View Post
Quote   Quote: Originally Posted by Lady Fitzgerald View Post
I have several of the programs listed by MBAE free as being protected (IE, Adobe Acrobat, M$ Word, M$ Excel, M$ PowerPoint, WMP, and VLC Player) but the General tab shows only one Shielded application; according to the logs, that is IE. The option to activate a shield is grayed out. Is this normal?
I just installed MBAE free on a WTP Build 10049 VM.
I can click on activate and get a message showing the Premium version is needed.

Attachment 354839
Curious. I can right click, left click, and wheel click on it and it just sets there and laughs at me.
What version of MBAE are you using ?
I'm using the latest v 1.06.
I never used a previous version, so i can't comment on how they work.
My System SpecsSystem Spec
.

02 Apr 2015   #44
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

Quote   Quote: Originally Posted by DavidE View Post
Open the MBAE General tab and look at the "Shielded Applications" count.
Open and close the Comodo Dragon browser, and see if the count changes.
There has been a longstanding, known bug with the "Shielded Applications" count.
I do not see it listed as fixed in the 1.06 changelog.
So I do not know if it is fixed or not.

AFAIK The best way to see if the browser (or any application) is shielded is to look for the locked padlock next to its name in the list under the "Shields" tab.

But, as I've said before, @pbust would be able to answer the question quickly and accurately HERE

Thank you,
My System SpecsSystem Spec
02 Apr 2015   #45
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

Quote:
Yea, the Activate buttons should state what they are for, such as "Activate License" and "Activate Shield" ... I won't comment on the GUI ...
At the risk of flagellating a deceased equine:

MBAE product comments and suggestions really need to be posted HERE

MBAE Product bugs/issues/problems/conflicts really need to be reported HERE

The MBAE team is very responsive and receptive to user feedback, but, alas, they cannot monitor the entire world wide intertubes for "trouble" reports and complaints.

Thank you,
My System SpecsSystem Spec
02 Apr 2015   #46
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by MoxieMomma View Post
Quote   Quote: Originally Posted by DavidE View Post
Open the MBAE General tab and look at the "Shielded Applications" count.
Open and close the Comodo Dragon browser, and see if the count changes.
There has been a longstanding, known bug with the "Shielded Applications" count.
I do not see it listed as fixed in the 1.06 changelog.
So I do not know if it is fixed or not.

AFAIK The best way to see if the browser (or any application) is shielded is to look for the locked padlock next to its name in the list under the "Shields" tab.

But, as I've said before, @pbust would be able to answer the question quickly and accurately HERE

Thank you,
Ah, thanks for those tips
You are the expert here, so keep us informed
My System SpecsSystem Spec
02 Apr 2015   #47
MoxieMomma

OEM Windows 7 Ult (x64) SP1
 
 

^^ Thanks for your kind words. But, no, I am no expert <LOL>. I am just another homer user. ^^

I should reiterate that there is another new behavior in 1.06.

When the user opens a shielded application, there will be a popup notification from the system tray (unless the user disables that notification feature in the Settings tab).

The rationale for the change from "silent" logging is explained HERE.

So, it is another way of knowing that a particular application is shielded, besides looking for the locked padlock next to the application in the Shields list.

Thank you,
My System SpecsSystem Spec
02 Apr 2015   #48
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by MoxieMomma View Post
Quote:
Yea, the Activate buttons should state what they are for, such as "Activate License" and "Activate Shield" ... I won't comment on the GUI ...
At the risk of flagellating a deceased equine:

MBAE product comments and suggestions really need to be posted HERE

MBAE Product bugs/issues/problems/conflicts really need to be reported HERE

The MBAE team is very responsive and receptive to user feedback, but, alas, they cannot monitor the entire world wide intertubes for "trouble" reports and complaints.

Thank you,
I have asked questions, made comments, reported issues on the MBAM forums.
There are issues that were reported long ago, and have not been fixed ...

If you want to work with them on these questions that's fine.
I've been there and done that with MBAM ...

imho they do what they want, usability is not their forte, and that's all i want to say about this.
My System SpecsSystem Spec
02 Apr 2015   #49
ignatzatsonic

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, 64-bit
 
 

I have free 1.06.

I use Palemoon.

It's shield is activated and shows a locked padlock.

Good and as expected to that point.

However, when I highlight the Palemoon shield and attempt to deactivate it, I get the pop-up below, which tells me that deactivation requires a premium license.

Expected behavior?

Or is English not my first language?


Attached Thumbnails
Opinions on Mbam's Anti Exploit program.-untitled-1.jpg  
My System SpecsSystem Spec
02 Apr 2015   #50
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Quote   Quote: Originally Posted by ignatzatsonic View Post
I have free 1.06.

I use Palemoon.

It's shield is activated and shows a locked padlock.

Good and as expected to that point.

However, when I highlight the Palemoon shield and attempt to deactivate it, I get the pop-up below, which tells me that deactivation requires a premium license.

Expected behavior?

Or is English not my first language?
I just installed Pale Moon in WTP, English language, ...
I see the same thing, i can't deactivate without a premium license ...
Is it a bug, or intentional to lock a user into ALL the default settings ????
My System SpecsSystem Spec
Closed Thread

 Opinions on Mbam's Anti Exploit program.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Malwarebytes Anti-Exploit 1.05.1.1014
New Features: Engine (DLL) code re-write to improve stability and compatibility. Added mitigations DEP Enformcement, Anti-HeapSpraying and BottomUp ASLR. Added new Layer0 "Application Hardening" protections. Added Layer1 new generic ROP protection mitigations. Added Layer1 new StackPivoting...
System Security
Malwwarebytes anti-exploit and A/V advice
I have just started using windows again, and am considering using malwarebytes anti-exploit along side my A/V program. I was wondering if this was advisable or if anyone had any advice?
System Security
Malwarebytes Anti-Exploit 1.04.1.1012
https://forums.malwarebytes.org/index.php?/topic/156507-malwarebytes-anti-exploit-10411012/ https://www.malwarebytes.org/antiexploit/ A Guy
System Security
Malwarebytes Anti-Exploit 1.03.1.1220 (Out of Beta)
Added new protection techniques for "Operating System Security Bypass Protection" Layer Added new protection techniques for "Application Behavior Protection" Layer Added ability to enable or disable pre-determined shields Added ability to manage (add/delete) custom shields Added visual...
System Security
Malwarebytes Anti-exploit 0.09.5.0250 Preview
https://forums.malwarebytes.org/index.php?showtopic=139353 Some personal observations. This program has worked silently in the background for me. But each time it has expired, it resulted in no browsers launching. The process was launched, but no browser GUI appeared. After I figured it out the...
System Security
Malwarebytes Anti-Exploit 0.09.4.2000
New Features: Compatibility with Windows 8.1. Fixed problem with log entries deleted after every reboot. Fixed missing line separators in the mbae-default.log logfile. Source A Guy
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App