Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Avira Antivirus and UAC Prompts

23 Nov 2015   #1
SevenOfNine

Windows 7 64-bit
 
 
Avira Antivirus and UAC Prompts

Asking this for a friend: Does anyone here use Avira Antivirus? When you perform a scan using Avira's Windows Explorer shell extension (context menu), do you get a UAC prompt each time?


My System SpecsSystem Spec
.
23 Nov 2015   #2
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Yes, I use Avira Internet Security and no UAC prompts. Run the program as Administrator.
My System SpecsSystem Spec
23 Nov 2015   #3
Alejandro85

Windows 7 Ultimate x64
 
 

It's clearly a bug, a known one in fact.
I cannot find any official reference right now, but forums all around are complaining about that, and it seems to have little official word on the matter.

I used to use Avira some time ago and have experienced that too. It happens with any on-demand scan, be it on the shell extension or on the main interface. It was introduced in version 14 (13 and earlier run just fine even by standard users). BTW, it was precisely this critical flaw what drive me away Avira finally
I have no idea of a workaroud, or even if it's at all possible, other than rolling back to a previous version.
My System SpecsSystem Spec
.

23 Nov 2015   #4
SevenOfNine

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by Jacee View Post
Yes, I use Avira Internet Security and no UAC prompts. Run the program as Administrator.
I followed the instructions in https://technet.microsoft.com/magazine/ff431742.aspx and modified their system by making the following change to Avira Launcher:
  • To apply the setting to all users on the computer and regardless of which shortcut is used to start the application, click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, select the Run This Program As An Administrator check box, and then click OK twice.
The UAC prompt still appear every time they perform any scan from the context menu in Windows Explorer (or any file manager).

Interestingly, that changed the behavior of their Avira system tray icon quite a bit.

I then performed the same action on the shortcut to "Start Avira Antivirus" (which runs avcenter.exe). No effect on UAC prompts after doing that.

After each step, I rebooted their system.

It didn't shock me that it didn't work, since neither of those shortcuts actually is responsible for loading Avira Antivirus when the system starts. On the other hand, the change in behavior of the system tray icon is very interesting.

Is there a technique you used that works?
My System SpecsSystem Spec
23 Nov 2015   #5
SevenOfNine

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by Alejandro85 View Post
It's clearly a bug, a known one in fact.
I cannot find any official reference right now, but forums all around are complaining about that, and it seems to have little official word on the matter.

I used to use Avira some time ago and have experienced that too. It happens with any on-demand scan, be it on the shell extension or on the main interface. It was introduced in version 14 (13 and earlier run just fine even by standard users). BTW, it was precisely this critical flaw what drive me away Avira finally
I have no idea of a workaroud, or even if it's at all possible, other than rolling back to a previous version.
Why wouldn't they fix such a major detraction from their tool? No one online has found a fix?
My System SpecsSystem Spec
24 Nov 2015   #6
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Is this Avira 'free' or paid for?
My System SpecsSystem Spec
24 Nov 2015   #7
SevenOfNine

Windows 7 64-bit
 
 

Quote   Quote: Originally Posted by Jacee View Post
Is this Avira 'free' or paid for?
It is their free antivirus product. Although since the paid product is the same software, just with some added features, I would guess it has the same implementation.

I'm unclear if everyone deals with this issue, or if there is something wrong with my friend's installation.

Your post seems to indicate that it is not normal, but Alejandro85's post indicates just the opposite.

Since millions of people use Avira, I would think a fair number of people on this forum use it. Not sure why so few people are chiming in. Maybe people don't know what UAC is?
My System SpecsSystem Spec
30 Nov 2015   #8
Alejandro85

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by SevenOfNine View Post
Why wouldn't they fix such a major detraction from their tool? No one online has found a fix?
I have no idea really. But it's a long standing bug and apparently they have no intentions of fixing it, it's neither something you can change with a setting, seems that it's within the inner workings of the AV engine that imposes that only admins can scan files. I agree that it's utterly wrong to impose such ridiculous restriction, but other that going back to version 13 (when this bug didn't existed yet) I have no idea how to change it.


Quote   Quote: Originally Posted by SevenOfNine View Post
I'm unclear if everyone deals with this issue, or if there is something wrong with my friend's installation.
Many people have already stumped against this bug. A quick Google search reveals the following:
https://answers.avira.com/es/questio...n-a-scan-15380
https://www.reddit.com/r/24hoursuppo...dmin_accounts/
Standard User needs Administrator password for starting antivirus - Microsoft Community
https://answers.avira.com/en/questio...ll-files-17460
windows 7 - Does Avira Antivirus require responding to a UAC prompt for EACH manual scan? - Super User

The very same question in different places and the answer is always the same "we don't know and Avira doesn't responds to complains". Some of those posts are quite dated too, months, if not a year old. Again, a widely known bug.
Maybe Jacee didn't find it herself because she's using an outdated version (that hasn't been hit by the bug)? Or she has UAC disabled or in auto-allow mode?


Quote   Quote: Originally Posted by SevenOfNine View Post
Maybe people don't know what UAC is?
Or most likely they have it disabled Another common complain chilling "I'm admin I want to do anything!!!!".
What people don't know is what security is to begin with. I find it shocking, although not surprising how many threads on the security subforum here talk about antiviruses, but very few ask about security!
But that's another history.
My System SpecsSystem Spec
Reply

 Avira Antivirus and UAC Prompts




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Avira Antivirus Pro: Line through Last Updated on tooltip
I'm on a Win7 Home Premium x64 SP1 Toshiba Satellite, running Avira Antivirus Pro 14.0.6.552. As of two days ago, when I hover my mouse cursor over the system tray icon, the Last Updated information is crossed out. I've checked Avira's event logs and it shows all updates as successful. I...
System Security
Avira Antivirus NOT detected by Windows ?
Hey everyone, I've been using Avira ever since I got my laptop which was 2 years ago. For some reason, Windows no longer detects Avira and is giving me the message : Windows did not find antivirus software on this computer. Is there a way to 'reset' the Windows antivirus detection so I...
System Security
Windows 7 Avira Free Antivirus saying System not secure
Hey guys,I'm new here,my sis laptop is giving problem,it's saying that System not secured. Please help me.
System Security
Problem on antivirus(avira)
The antivirus pop out this"the adapter wireless etwork connection ICMP is flooded" what it means ?Is my pc has been attack by virus? What should i do?
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:10.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App