Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Permissions all messed up!


18 Apr 2009   #1

 
 
Permissions all messed up!

Installed 7077. Have 2 USB drives attached. Everything all right. Files all accessable. Join homegroup, and permissions all messed up!

The drive didn't even show as having a partition except in computer management. Had to take ownership of drive to see file list again, but I couldn't open files anymore. Now, I have to go to each file and open the security properties, remove the ones listed there, and then click the "inherit" option and click through the Okays. That'll finally make them useable.

ARGH.

My System SpecsSystem Spec
.

18 Apr 2009   #2

 

I had that with my second HD when I did a clean install - if you take ownership of the drive, then change the permissions of the drive and check the little box underneath that say s something like "Make this change for all sub folders too" then it makes it a lot easier...
My System SpecsSystem Spec
18 Apr 2009   #3

 
 

Tried that. Kept giving "Permission Denied" on the changes to subitems.
My System SpecsSystem Spec
.


18 Apr 2009   #4

 

That means you have different folders owned by different SIDs. Do the main folders in each drive, and see who they are all set to - in my case I had 3 different SIDs associated, my old Vista account, my old Win 7 account and in some cases System (thanks to Media Player libraries - grrrrr)

Once you get all the bogus ones out of the way you'll be able to do it from the drive level.

I just tried the drive level first and made a not e of which folders it could not do, making it easier on me rather than traversing the entire tree structure...
My System SpecsSystem Spec
18 Apr 2009   #5

 
 

I originally made the owner the Administrator group. Deciding to give it another try, I made the owner the actual user account I was logged in with (remoted in with actually). That seems to have fixed it.

And great job on the fast response! Now, where's that rep button for you?

Blah, says I have to spread it around before giving you more. Well, just know you deserve it!
My System SpecsSystem Spec
18 Apr 2009   #6

 

Lol - it's all good, FF
My System SpecsSystem Spec
19 Apr 2009   #7

 
 

Okay, I gave HomeGroup a shot, and I don't like how it works. Some files stay "in use" and therefore locked. Some files "move" over to the other drive but never actually get deleted from source. Sometimes it accepts the homegroup permissions, and sometimes not. HomeGroup does not work. So I uninstalled.

And permissions got all messed up again. LOL!
My System SpecsSystem Spec
19 Apr 2009   #8

 

Yeah, when I created a home group back on 7000 or 7048, I got weird errors b/c it created secondary folders for Documents, Downloads, etc. that I had shared instead go sharing my normal ones located on the separate physical drive. When I removed the HG it went stupid and reset all my links and such to the original locations and I had to go back and fix that myself....

And, come to think of it, my system never had permissions problems until I first used the HG - so I suppose that may have been in fact what cause all my problems too....
My System SpecsSystem Spec
Reply

 Permissions all messed up!




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:32 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33