Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: UxStyleCore stopped working after latest Windows Update

15 Dec 2011   #1
obones

Windows 7 Pro x64
 
 
UxStyleCore stopped working after latest Windows Update

Hello all,

Last Tuesday came a set of updates via Windows Update and since then my custom style displays as Windows Classic and not Aero.
I can use any other official Aero based theme, but using an unsigned theme no longer works.
Has anyone seen this?
What would be your recommendations ?

I tried removing the updates via the appropriate list, but that put my windows in a non bootable state that I could only get out by restoring to a saved state that includes the updates.

Thanks in advance


My System SpecsSystem Spec
.

15 Dec 2011   #2
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Switch to the default aero theme then
Click on the Start Button type in Services In the search box and then click on Services
Name:  1.png
Views: 5
Size:  44.0 KB


Scroll down until you see unsigned themes select it in click on the Stop text and let it stop after that click on Start text and see if that works. Your screen may blink when you do this.
-4.pngName:  stop.PNG
Views: 3
Size:  10.7 KB-5.png



Jerry


My System SpecsSystem Spec
16 Dec 2011   #3
obones

Windows 7 Pro x64
 
 

Thanks for that, but I'm quite sure I have tried it already.
Well, maybe not with "going back to default aero theme", so I'll try again.
That said, I already tried uninstalling and reinstalling UxStyleCore, to no avail.

Weird thing is that this already happened in the past after windows update, after the first reboot. But a second reboot and I was back to normal. It's just this time that it no longer works.

The situation with regards to Aero themes is as follows :

My theme -> broken
Default Aero theme -> broken
Any other Aero theme -> working

Thanks for your help, I'll try your suggestion
My System SpecsSystem Spec
.


16 Dec 2011   #4
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Windows update's should not turn off UxStyleCore I have never had one update do that I have had to do as I suggested above a few times but not because of an update.
Now you are saying the default Aero theme is broken but you can use other Aero themes I don't see how the other Aero themes(The ones that came from Microsoft) are tied to the default Aero theme they all work off of 1 aero.msstyles
Try turning it on and off in services first.
Then tried to troubleshoot Aero
Click on start button in the search box type Aero and look for Find and fix problems with transparency and check for problems
Name:  s.png
Views: 1
Size:  51.1 KBName:  Aero.png
Views: 1
Size:  23.8 KB

Jerry


My System SpecsSystem Spec
16 Dec 2011   #5
obones

Windows 7 Pro x64
 
 

For the default Aero theme, I had modified aero.theme to use another .msstyles file. After putting back the original value, it works again.
I tried using the aero fixer, it did not find anything.
But now that I have fixed aero.theme, my own theme gets back Aero enabled but without using my own aero_obones2.msstyles despite the .theme file specifying this:

[VisualStyles]
Path=%ResourceDir%\Themes\Aero\Aero_obones2.msstyles

And the above msstyles file is located right there.

I'm quite lost here, but I very much appreciate your help and patience.
My System SpecsSystem Spec
16 Dec 2011   #6
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Take a screenshot of C:\Windows\Resources\Themes and C:\Windows\Resources\Themes\Aero in full screen and post them.
Screenshot with Paint
Screenshots and Files - Upload and Post in Seven Forums
How to Use the Snipping Tool in Vista - Vista Forums
Like this
-screenshot-12_16_2011-4_13_52-pm.png-screenshot-12_16_2011-4_14_15-pm.png
Jerry


My System SpecsSystem Spec
18 Dec 2011   #7
obones

Windows 7 Pro x64
 
 

There you go:

[IMG]http://obones.********/aero/themes.png[/IMG]

[IMG]http://obones.********/aero/themes_aero.png[/IMG]

My custom theme file (olivier.theme) is stored in my user profile's directory :

[IMG]http://obones.********/aero/themes_user.png[/IMG]

Thanks again for your help
Regards
My System SpecsSystem Spec
18 Dec 2011   #8
obones

Windows 7 Pro x64
 
 

Seems I cannot post direct links, so here are the attachments


Attached Thumbnails
-themes.png   -themes_aero.png   -themes_user.png  
My System SpecsSystem Spec
18 Dec 2011   #9
Bongo

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

You need to remove these and make into themes look at post #38 Start menu color change ?? it will show you how.
-themes_aero.png

These do not belong there
-themes_user.png

Jerry


My System SpecsSystem Spec
09 Jan 2012   #10
obones

Windows 7 Pro x64
 
 

Sorry for the delay, but I'm glad to say that this worked a charm, I'm now back with my own theme.
I don't know why my setup worked before and stopped after the latest windows update, but following your indications made it work again.

Many thanks.
My System SpecsSystem Spec
Reply

 UxStyleCore stopped working after latest Windows Update




Thread Tools





Similar help and support threads
Thread Forum
XP Mode stopped working after windows 7 update
I have windows 7 pro installed on a Dell Inspiron 620. Since I had some programs and hardware I needed to continue using, I installed XP Mode which has worked perfectly for the past 2 years. A couple of nights ago, when I left XP mode running, some windows updates were installed and the computer...
Virtualization
IE and skype stopped working chrome and FF ok after windows update
I have had issues since last patch Tuesday: When I try to start Skype nothing seems to happen (no window opens). Also IE does not want to connect to anything. If I go to the options IE10 all except file and safety are greyed out. I have tried resetting through the internet options in the...
Browsers & Mail
Ethernet stopped working after Windows Update
Hi guys, this is my first post so let me know if I missed anything or need to include more descriptions about my computer/problem. After the last windows update my wired internet stopped working. I tried right clicking in the device manager to update the drivers when connected to WiFi which...
Network & Sharing
Problems With Latest Windows Update - Some Functions Not Working
Yesterday when I turned off my laptop it said it was installing a windows update 1 of 1 and do not shut down computer. After about 15 minutes or so it was still not installed and since I'm having seperate issues with my battery I didn't let it finish and took out the battery.I put the battery back...
General Discussion
Windows Update stopped working Code 8007370B
Hi Guys, I'm new to the forum but from what I can gather, you guys know how to resolve Windows Update errors. Each time I run Windows Update I get error code 8007370B. I've tried running SURT but that fails straight away with the error on the screen shot attached. Please help!
Windows Updates & Activation
Windows Update stopped working
80070002 error code. There is a good workaround described in troubleshooting that error code, but it does not solve the problem. There is also a good page at Microsoft with instructions on working around the problems, but those instructions do not solve the problem. I searched here and...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App