Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Elune replacement explorerframe.dll crashes my computer


15 Apr 2012   #1

Windows 7 Home Premium 32bit
 
 
Elune replacement explorerframe.dll crashes my computer

Hello!

I am attempting to install the Elune theme from dA (Browsing deviantART). I installed UxStyle and copied the theme files into the C:\Windows\Resources\Themes folder. The new theme shows up under the Personalize window, but when I click it it looks like a weird mix of XP and Windows 95...not what the theme is supposed to look like at all.

Then I realized I had skipped the step where you replace the explorerframe.dll with the one included in the download. I took ownership of the file, renamed it as explorerframebackup.dll, moved the new one to the system32 file, and restarted my computer. When I tried to log in, explorer refused to start and I had to run system restore.

Everything is working fine now, but I can't seem to leave well enough alone and I still want that stupid theme! Where did I go wrong? Has anyone installed this theme successfully and can offer some insight?

Thank you!

My System SpecsSystem Spec
.

15 Apr 2012   #2

windows 7 x64 Home Premium
 
 

Hello again, sanddobby.

To rename the explorerframe.dll file, you need to open up an Elevated Command Prompt and rename the file there. The new file name should be explorerframe.dll.bak (or explorerframe.dll.old is another common renaming convention). Then copy in the new explorerframe.dll file.

Do you need help in doing those steps? Let me know.
My System SpecsSystem Spec
15 Apr 2012   #3

Windows 7 Home Premium 32bit
 
 

Hi Stevieray!

I tried your steps and opened an Elevated Command Prompt, renamed the file explorerframe.dll.old, and copied the new file into the folder, but when I restarted it still crashed

The error I get is "The application failed to initialize properly 0xc000007B
Click on ok to terminate the application," for explorer and nothing will open. Should I just give up?
My System SpecsSystem Spec
.


15 Apr 2012   #4

windows 7 x64 Home Premium
 
 

That's up to you.

Do you have sp1 installed? I read through the comments at DeviantArt, and some folks seem to have trouble installing it on systems with sp1 installed as the explorer versions no longer match. If the version numbers don't match, then explorer will crash. That can be fixed with Resource Hacker or Restorator.

You could also try another theme, a more recent one perhaps, that was designed with sp1 in mind. If that works, then you could go back and change the new explorerframe.dll's version and product numbers so it matches your system.
My System SpecsSystem Spec
16 Apr 2012   #5

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

I installed the theme it seemed to work with no problem. I did not change the explorerframe.dll as stevieray pointed out there could be a problem with that .dll.
Did the theme look like this after you've installed it?
Elune replacement explorerframe.dll crashes my computer-theme.png

Sometimes when using UxStyle you will need to restart the service to make it work properly here is how
Click on the Start Button type in Services In the search box and then click on Services
Name:  1.png
Views: 32
Size:  44.0 KB


Scroll down until you see unsigned themes select it in click on the Stop text and let it stop after that click on Start text and see if the theme works. Your screen may blink when you do this.
Elune replacement explorerframe.dll crashes my computer-4.pngName:  stop.PNG
Views: 15
Size:  10.7 KB
Elune replacement explorerframe.dll crashes my computer-5.pngName:  start.png
Views: 14
Size:  9.5 KB

If we can get the theme going for you then we can work on getting the explorerframe.dll straightened out next.
Jerry


My System SpecsSystem Spec
16 Apr 2012   #6

Windows 7 Home Premium 32bit
 
 

Quote   Quote: Originally Posted by stevieray View Post
That's up to you.

Do you have sp1 installed? I read through the comments at DeviantArt, and some folks seem to have trouble installing it on systems with sp1 installed as the explorer versions no longer match. If the version numbers don't match, then explorer will crash. That can be fixed with Resource Hacker or Restorator.
I just made it so the explorerframe.dll version from the theme matched the one from the system32 folder (I guess I do have sp1 installed, surprise!), but it still crashed.


Quote   Quote: Originally Posted by Bongo View Post

Scroll down until you see unsigned themes select it in click on the Stop text and let it stop after that click on Start text and see if the theme works. Your screen may blink when you do this.

Jerry
Hey Jerry, this is what my desktop looks like when I click on it:

But when I go to the services list the unsigned themes service isn't there.
My System SpecsSystem Spec
16 Apr 2012   #7

windows 7 x64 Home Premium
 
 

Drats! I hoped the mismatched version numbers would fix it for you... it's done wonders for me in the past.

Hmmm... if UxStyle Core shows up in Control Panel but not in Services, it is installed, but it is not running for some reason. It could be blocked by an antivirus program, or perhaps there is a corruption in your system files.

You could try uninstalling UxStyle, disabling your antivirus, and then re-installing it. If that doesn't work, you also could try running sfc /scannow to repair your system, and then again try installing UxStyle.
My System SpecsSystem Spec
16 Apr 2012   #8

Windows 7 Home Premium 32bit
 
 

So I reinstalled UxStyle with both UAC and antivirus turned off, and restarted. It showed up under services, but it won't start because it can't find the file. According to the service's executable path it's supposed to be in C:\Windows...and it was! I tried to run UnsignedThemesSvc.exe(which is what the service is executing) but it wouldn't start.

Whaaaat is going on! The problems never end!
My System SpecsSystem Spec
16 Apr 2012   #9

windows 7 x64 Home Premium
 
 

Well, you're getting closer... but it is still being blocked somehow. What antivirus program are you using? Do you have one of those third-party security programs that "lock down" your start menu or startup?
My System SpecsSystem Spec
16 Apr 2012   #10

Windows 7 Home Premium 32bit
 
 

I use AVG, but I disabled the anti-virus and identity protection before installing and trying UxStyle. I'm not sure I know what you mean by "lock down" the start menu, I guess that means it doesn't do it? I also made an exception for the program in Windows Firewall, and nothing changed. I feel like the fix for this is going to be something really dumb :P
My System SpecsSystem Spec
Reply

 Elune replacement explorerframe.dll crashes my computer




Thread Tools



Similar help and support threads for2: Elune replacement explorerframe.dll crashes my computer
Thread Forum
ExplorerFrame.dll? Customization
Solved Help with Explorerframe.dll Themes and Styles
Solved Replacing explorerframe.dll crashes explorer.exe - 0xc000007B Themes and Styles
Computer Crashes, Is my computer overheated? PC Custom Builds and Overclocking
Solved explorerframe.dll / Windows 7 x64 Customization
explorerframe.dll Themes and Styles
Computer Replacement, help me choose. General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:46 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33