Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Third party themes are not being applied completely

15 Nov 2012   #1

Windows 7 Ultimate 64-bit
 
 
Third party themes are not being applied completely

I'm going nuts trying to figure this out. First, I'm running Windows 7 Ultimate SP1 64-bit on a new Asus G75VW. I've had a few systems that run the same version of Windows, and on all of them I've used the Unsigned Themes Service (UxStyle Core) to use third party themes. My problem is that on my new system the themes are being applied only partially.

On my last system, I used UxStyle Core and it worked perfectly. The themes I used may not have been created perfectly, but I was happy. On my new system I can use 3rd party themes, but most applications (like Photoshop, Notepad++, etc.) and some Windows apps seem to be using the Win 2000 styles for parts of their UI. The best way I can illustrate this is with a screenshot, which I've attached. The Old System screenshot looks good to me, but the New System shot shows how Notepad++ is using the classic style for its open dialog. The same app on my old system (same version exactly) uses the 3rd party theme's styling (Gaia09).

I've uninstalled and reinstalled UxStyle, tried using the Universal Theme Patcher (x86 and x64), manually copied the patched system files from my old system to my new one, ran SFC /scannow to replace patched system files with the originals, etc., etc.

After completely removing UxStyle, and using non-patched system files, some apps STILL use the Win 2000 style for parts of their UI. Out of frustration, I also tried using TuneUp Utilities and WindowBlinds. But no matter what I do, the same thing is happening.

Can anyone please help?




Attached Thumbnails
Third party themes are not being applied completely-test.jpg  
My System SpecsSystem Spec
.

15 Nov 2012   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

I do not see a difference in Notepad ++ in your screenshots.
As for Photoshop it uses its own UI so it always looks the same no matter what theme you are using.

Post a link to the theme you are using and I will check it out.

Jerry
My System SpecsSystem Spec
15 Nov 2012   #3

Windows 7 Ultimate 64-bit
 
 

Thanks for replying! First, here's a link to the VS:

Gaia09 VS for Seven 2 by ~jg-visuals on deviantART

Unfortunately, the issue shows up no matter what 3rd party VS I use - I've tried dozens of them.

I apologize for not providing a clearer explanation in the screenshot of what I was talking about. I've attached a new shot that points out the specific UI elements I'm talking about.

I knew that the Adobe apps use their own UI, but even on my old system those same apps used 3rd party theming for buttons & controls in their open/save dialog windows. On my new system, they default to the classic theme styling.

I have a feeling that this is a problem unrelated to 3rd party themes, because if I revert the system to pre-patching and just use the standard Aero theme, the same thing happens.


Attached Thumbnails
Third party themes are not being applied completely-test2.jpg  
My System SpecsSystem Spec
.


15 Nov 2012   #4

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

Click on start button in the search box type Aero and look for Find and fix problems with transparency and check for problems.

Jerry
Name:  s.png
Views: 8
Size:  51.1 KBName:  Aero.png
Views: 8
Size:  23.8 KB


My System SpecsSystem Spec
15 Nov 2012   #5

Windows 7 Ultimate 64-bit
 
 

I ran the utility and it came back with zero issues. I also thought that maybe the Aero theme itself got corrupted somehow (yeah, a stretch), so I copied the one from my old system to the new one, but no luck.
My System SpecsSystem Spec
15 Nov 2012   #6

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

In your screenshot I see that the 2 Open windows are different from Notepad ++ when opening a file how is that done?

Click on the Start Button type in Services In the search box and then click on Services
Name:  1.png
Views: 8
Size:  44.0 KB


Scroll down until you see Desktop Windows Manager Sessions Manager select it in click on the Stop text and let it stop after that click on Start text and see if that works. Your screen may blink when you do this.
Third party themes are not being applied completely-2.pngName:  stop.PNG
Views: 7
Size:  10.7 KBThird party themes are not being applied completely-3.pngName:  start.png
Views: 7
Size:  9.5 KB

Do the same thing with unsigned themes
Third party themes are not being applied completely-4.pngThird party themes are not being applied completely-5.png

Jerry


My System SpecsSystem Spec
15 Nov 2012   #7

Windows 7 Ultimate 64-bit
 
 

OK, I stopped and started the service per your instructions. No dice.

As far as the screenshot goes, they're from two different laptops. The old one is the laptop where the themes work properly.

I see what you mean about them being different, and that's part of my problem - on the old laptop, most applications would use the Windows open/save dialog with the navigation pane on the left. On my new laptop, the same apps that I have installed on the old system don't use the dialog with the navigation pane. They use this other dialog that only shows the places bar on the left.

Not to beat this thing to death, but I included another shot of the standard Windows Notepad app on both systems. It doesn't seem to be limited to 3rd party apps.


Attached Thumbnails
Third party themes are not being applied completely-test3.jpg  
My System SpecsSystem Spec
15 Nov 2012   #8

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

You said you did a sfc /scannow to undo Universal Theme Patcher, did you do it with Elevated Command Prompt then did you install UxStyle Core again?

Jerry
My System SpecsSystem Spec
15 Nov 2012   #9

Windows 7 Ultimate 64-bit
 
 

I actually did quite a few operations. Here's the history of my attempts:

1) Ran Universal Theme Patcher (both x64 and x86)
2) Rebooted
3) Applied 3rd party theme = theme worked but the problem showed up
4) Ran UTP again and restored the patched files (x64 and x86)
5) Rebooted
6) Repeated steps 1-3 = theme worked but same problem
7) Ran SFC /scannow from elevated command prompt
8) Rebooted
9) Applied standard Aero theme = theme worked but problem persisted
10) Copied patched themeservice.dll, themeui.dll, uxtheme.dll and explorer.exe files from my old laptop to my new one (from System32 and SysWOW64) - backed up the originals first
11) Rebooted
12) Applied 3rd party theme = theme worked but problem persisted
13) Removed patched files and replaced with the original backups
14) Rebooted
15) Applied standard Aero theme = theme worked but problem persisted
16) Installed Unsigned Themes service
17) Rebooted
18) Applied 3rd party theme = theme worked, but problem still there

After that point I sought your help.
My System SpecsSystem Spec
16 Nov 2012   #10

Microsoft Community Contributor Award Recipient

Win 7 Pro x64 / Win 8.1 Pro
 
 

All the things you have done looks like the correct actions was taken, and I am starting to run out of ideas.

If you can switch to the Windows Classic theme logoff logon then go to your theme folder and move all of the third-party custom themes(theme folders and .theme files) to a new location other than the theme folder then reboot your computer and then try to apply the default Aero theme and see what happens.

Jerry
My System SpecsSystem Spec
Reply

 Third party themes are not being applied completely




Thread Tools



Similar help and support threads for2: Third party themes are not being applied completely
Thread Forum
My Problem With Third Party Themes Backup and Restore
HELP PLZ on 3rd party themes Themes and Styles
Cannot install third party themes on windows 7 Themes and Styles
How do i completely get rid of my old 3rd party themepack? Themes and Styles
Installing 3rd party themes on Windows 7 Themes and Styles
Solved Patching windows for the use of third party themes Customization
viewing 3rd party themes Themes and Styles

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:57 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33