Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Desktop Slideshow doesn't work after saving theme

19 Jan 2009   #1
Razgriz panavia

Windows 7 64bit/Ubuntu 10.04 32bit/Linux Mint 9 64bit
Desktop Slideshow doesn't work after saving theme

Hello, I tried making the desktop slideshow, but when I save my theme, the desktop image no longer changes automatically. I am using pictures from my Pictures folder which vary in dimensions, set the timer to 3mins and turned shuffle off, it all works fine with the background window open but as soon as I save changes it stops working, this also happens when I save the custom theme which may be working to a installed theme which then stops it from working. Any ideas to my problem?

My System SpecsSystem Spec
19 Jan 2009   #2


When saving the theme try changing the file type to .themepack instead of the default .theme
My System SpecsSystem Spec
19 Jan 2009   #3
Razgriz panavia

Windows 7 64bit/Ubuntu 10.04 32bit/Linux Mint 9 64bit

Thanks z3r010 but it's still not changing, It changes on start up but after that it sticks to the current wallpaper. should I delete my .theme files and then create .themepack files (which don't appear in the installed themes section for me) is there any other solutions?
My System SpecsSystem Spec

21 Jan 2009   #4

64-bit Windows 10 Pro

Hello Razgriz, and welcome to Seven Forums.

See if you can save your theme as a .themepack, then click on the saved .themepack file to load it in the Personalization window to have it available to select if needed.

Theme Pack - Create, Save, Install, and Delete

Hope this helps,
My System SpecsSystem Spec
23 Jan 2009   #5
Razgriz panavia

Windows 7 64bit/Ubuntu 10.04 32bit/Linux Mint 9 64bit

Thanks Brink

Ok, I deleted the themes I made and started from scratch, I created a themepack which i saved to a folder in my documents. The slideshow speed is set to 5min. However whilst playing within the timer (setting it to different values) it would seem that the 10sec, 30sec settings run fine, but the 3min and 5min settings are touch n go. As I might have mentioned before, the saving of the themes as a file seems to break the feature, though when I right click on the desktop and select the "change desktop background" option, it's clear that the other backgrounds are there. My backgrouns are 1440 x 900 and I'm using the Fill setting. Any ideas? The default themes work fine, but mine don't.

On another note I have noticed that the desktop gadgets no longer work, I have tried launching the application but the app does not run.

Edit: Ok the issue with the Sidebar has been fixed, just needed a little reg editing after reading another post.
My System SpecsSystem Spec
23 Jan 2009   #6

Windows 7 Ultimate Vista Ultimate x64

Once you have saved a theme as a themepack you still need to go to the themepack file to activate the new theme and then it will saved permanently in Personalization until you want to delete it
My System SpecsSystem Spec
24 Jan 2009   #7
Razgriz panavia

Windows 7 64bit/Ubuntu 10.04 32bit/Linux Mint 9 64bit

Some how I don't think this is going to work properly, I have tried everything so far and had no such luck, this isn't going to work for me. Is there anything else?
My System SpecsSystem Spec
21 Oct 2009   #8

windows 7 Ultimate x64

I've been struggling with this issue for weeks now and it was really bugging me.

Just found the fix on this thread and it's working for me perfectly now:

Desktop Wallpaper Slide-Show stopped working

It's likely a problem with the powerplan:

Resolved the issue (at least for me). This had to do with the Power schemes. Do this

Type edit power plan in the Start Search box, and then click Edit power plan.
Click Change advanced power settings.
Select Available in Desktop background settings->Slide show.
That's it you should see the background changing.

Hopefully that helps.
My System SpecsSystem Spec
12 Nov 2009   #9

win 7 premium home
it works when

I have the same problem, I did notice it runs fine while I am runnung Control Panel> proformance info and tools>re-rub the assessment , but the minute it stops testing the slideshow stops also.
My System SpecsSystem Spec
12 Nov 2009   #10

win 7 premium home

thanks spacedog, it works , but you have to selest the power scheme your using not the one it brings up
high proformance
or powersave
My System SpecsSystem Spec

 Desktop Slideshow doesn't work after saving theme

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Aero theme doesn't work, can't find solution
Recently my aero theme stopped working, and it is rather frustrating. It has been working for the past 5-6 months, and now it suddenly stops. There is something weird, though. Whenever i start up Torchlight 2, the aero theme starts working, with transparency and all. Whenever i restart the computer...
Themes and Styles
My theme transparency doesn't work i downloaded themes for my windows 7 from deviantart like months ago they were working fine last time i used them, but then i started using Windows normal theme now that i want to use one of the themes i downloaded my transparency doesn't work. It turns in to the Classic windows theme and...
Themes and Styles
Trouble saving customized desktop backgrounds theme
I like to change my desktop background pictures with the changing seasons. I'm trying to save four themes (Autumn, Winter, Spring, Summer), with the only difference among the themes being the desktop backgrounds (a set of 6 or so pictures that will cycle every 20 minutes). I've chosen the pictures...
Themes and Styles
Remote Desktop doesn't work after upgrade to SP1
Hi, After I upgraded my windows ultimate to SP1 my rdp stopped working. My remote settings now look like this: I can't find any reason why this would have happened. Does anyone have any idea what I can do to solve this, without reinstalling windows/sp1?
Network & Sharing
Remote Desktop Connection Doesn't Work!!!! HELP!!!
Hello everyone. I am having an issue getting my laptop (has Windows 7 Home Premium) to connect to my desktop work computer (has Windows 7 Professional) using RDC. I keep getting the following message: "The Local Security Authority cannot be contacted". I have searched the forum and Google and can't...
Network & Sharing
Desktop Slideshow Theme stopped switching images
That basically says it all. When I installed Win7 Home Premium 32 bit I installed some desktop themes with images that switched. Cool. After a while I downloaded some picktures and created my own. I have them set to switch every 15 minutes. THe past few weeks, I noticed that they were no longer...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:34.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App